aboutsummaryrefslogtreecommitdiff
path: root/math/sage
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-02-02 13:53:07 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-02-02 13:53:07 +0000
commit1a94f7bc8530e44f0aea0407cfe336546873b003 (patch)
tree0eb17e1cfb16390eb1bf2a4fe218fb37b14107ca /math/sage
parente3c8b21b1d2519ee84b15e7d6ee94ade66effc81 (diff)
downloadports-1a94f7bc8530e44f0aea0407cfe336546873b003.tar.gz
ports-1a94f7bc8530e44f0aea0407cfe336546873b003.zip
Notes
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile4
-rw-r--r--math/sage/files/spkg-patch-gfan-0.4plus.p1_-_patches_Makefile11
2 files changed, 13 insertions, 2 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index c11964f3e089..d29c89632428 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -32,7 +32,7 @@ USE_TK= yes
USE_GMAKE= yes
USE_ICONV= yes
MAKE_JOBS_SAFE= yes
-LDFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib
+LDFLAGS:= -Wl,-rpath=${WRKSRC}/local/lib ${LDFLAGS}
FFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib
CFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib
CXXFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib
@@ -96,7 +96,7 @@ post-patch:
IGNORE= POSIX semaphores are required, and the support only works in FreeBSD 7-STABLE and later
.endif
-.if !defined(DISABLE_MAKE_JOBS) && ${OSVERSION} < 900000
+.if !defined(DISABLE_MAKE_JOBS)
MAKE_ENV+= MAKE="make -j${MAKE_JOBS_NUMBER}"
.endif
diff --git a/math/sage/files/spkg-patch-gfan-0.4plus.p1_-_patches_Makefile b/math/sage/files/spkg-patch-gfan-0.4plus.p1_-_patches_Makefile
new file mode 100644
index 000000000000..1c35d7f07226
--- /dev/null
+++ b/math/sage/files/spkg-patch-gfan-0.4plus.p1_-_patches_Makefile
@@ -0,0 +1,11 @@
+--- gfan-0.4plus.p1/patches/Makefile-orig 2012-02-01 18:41:42.000000000 +0000
++++ gfan-0.4plus.p1/patches/Makefile 2012-02-01 18:42:10.000000000 +0000
+@@ -270,7 +270,7 @@
+ default: $(OBJECTS) $(ADDITIONALOBJECTS) $(EXECS)
+
+ $(MAIN): $(OBJECTS)
+- $(CXX) $(CXXFLAG64) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
++ $(CXX) ${LDFLAGS} $(CXXFLAG64) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
+
+ release:
+ rm -f -r $(RELEASEDIR)/*