aboutsummaryrefslogtreecommitdiff
path: root/math/sage
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2015-05-25 00:00:55 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2015-05-25 00:00:55 +0000
commitc4d7e70760eb12983f3d746e15d51fba5274f8db (patch)
tree4605ebe6d3f232f6eff688ccf42365ea118d57bc /math/sage
parent41f5c927c60a2f8ccd662bca17a45832a49f9a47 (diff)
downloadports-c4d7e70760eb12983f3d746e15d51fba5274f8db.tar.gz
ports-c4d7e70760eb12983f3d746e15d51fba5274f8db.zip
Notes
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile5
-rw-r--r--math/sage/files/patch-build_pkgs_git_spkg-install16
2 files changed, 16 insertions, 5 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 5e0d3ecb8fb2..064b518916a4 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -37,7 +37,7 @@ pre-extract:
PLIST_FILES= bin/sage
USE_TEX= latex:build
-USES= gmake iconv tk
+USES= gmake iconv tk perl5
MAKE_JOBS_SAFE= yes
# Optimization flags will be defined by the source
@@ -47,7 +47,8 @@ FFLAGS:= ${CFLAGS:C/^-O.*$//}
MAKE_ENV+= SAGE_PORT=yes \
SAGE_ATLAS_LIB=${LOCALBASE}/lib \
DOT_SAGE=${WRKSRC}/tmp/.sage \
- SAGE_FAT_BINARY=yes
+ SAGE_FAT_BINARY=yes \
+ PERL=${PERL}
LATEST_LINK= sage-math # Conflicts with graphics/sage.
diff --git a/math/sage/files/patch-build_pkgs_git_spkg-install b/math/sage/files/patch-build_pkgs_git_spkg-install
index 4b03d3fcc578..61e0c8d4411a 100644
--- a/math/sage/files/patch-build_pkgs_git_spkg-install
+++ b/math/sage/files/patch-build_pkgs_git_spkg-install
@@ -1,6 +1,16 @@
---- build/pkgs/git/spkg-install.bak 2015-02-17 00:15:08.000000000 +0000
-+++ build/pkgs/git/spkg-install 2015-03-27 02:33:07.652231000 +0000
-@@ -77,7 +77,7 @@
+--- build/pkgs/git/spkg-install.orig 2015-05-17 22:46:55.000000000 +0000
++++ build/pkgs/git/spkg-install 2015-05-24 22:10:32.517077000 +0000
+@@ -69,7 +69,8 @@
+ --libexecdir="$SAGE_LOCAL"/libexec \
+ --with-python="$SAGE_LOCAL"/bin/python \
+ --without-tcltk \
+- --with-sane-tool-path=
++ --with-sane-tool-path= \
++ --with-perl=$PERL
+ if [ $? -ne 0 ]; then
+ echo >&2 "Error configuring git."
+ exit 1
+@@ -77,7 +78,7 @@
echo "Building git..."