aboutsummaryrefslogtreecommitdiff
path: root/math/sc-im
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-05-23 17:05:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-05-23 17:05:47 +0000
commitf83106b6c1265d9fa396ec7162235eaeb50edb77 (patch)
tree3f94d9e9efa1fe97f248c6775c8aac7bd436ffe9 /math/sc-im
parent88b5baf67c8e4134010fb59d3036d51bffa5f9de (diff)
downloadports-f83106b6c1265d9fa396ec7162235eaeb50edb77.tar.gz
ports-f83106b6c1265d9fa396ec7162235eaeb50edb77.zip
Update to 0.7.0-81
Upstream changes fixes a conflict with textproc/scim Some cleanups PR: 237839 Approved by: Samy Mahmoudi <samy.mahmoudi@gmail.com>
Notes
Notes: svn path=/head/; revision=502344
Diffstat (limited to 'math/sc-im')
-rw-r--r--math/sc-im/Makefile12
-rw-r--r--math/sc-im/distinfo6
-rw-r--r--math/sc-im/files/patch-cmds__command.c4
-rw-r--r--math/sc-im/files/patch-doc4
-rw-r--r--math/sc-im/files/patch-file.c54
-rw-r--r--math/sc-im/pkg-plist14
6 files changed, 62 insertions, 32 deletions
diff --git a/math/sc-im/Makefile b/math/sc-im/Makefile
index 4fa5938559d9..be8a40807da9 100644
--- a/math/sc-im/Makefile
+++ b/math/sc-im/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= sc-im
-PORTVERSION= 0.7.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+DISTVERSION= 0.7.0-81
+DISTVERSIONSUFFIX= -g9beb5c0
CATEGORIES= math
MAINTAINER= bapt@FreeBSD.org
@@ -12,10 +12,10 @@ COMMENT= Ncurses spreadsheet program for terminal
LICENSE= BSD4CLAUSE
LIB_DEPENDS= libxlsreader.so:math/libxls \
- libzip.so:archivers/libzip \
- libxlsxwriter.so:math/libxlsxwriter
+ libxlsxwriter.so:math/libxlsxwriter \
+ libzip.so:archivers/libzip
-USES= gmake pkgconfig lua:51 ncurses
+USES= gmake gnome lua:51 ncurses pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= andmarti1424
USE_GNOME= libxml2
@@ -27,6 +27,6 @@ MAKE_ENV+= LDLIBS="${LIBS}"
MAKE_ARGS+= CC="${CC}" prefix="${PREFIX}" MANDIR="${MANPREFIX}/man/man1"
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scim
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sc-im
.include <bsd.port.mk>
diff --git a/math/sc-im/distinfo b/math/sc-im/distinfo
index e7df2f942c3e..c5929933f796 100644
--- a/math/sc-im/distinfo
+++ b/math/sc-im/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513334880
-SHA256 (andmarti1424-sc-im-v0.7.0_GH0.tar.gz) = 87225918cb6f52bbc068ee6b12eaf176c7c55ba9739b29ca08cb9b6699141cad
-SIZE (andmarti1424-sc-im-v0.7.0_GH0.tar.gz) = 1109887
+TIMESTAMP = 1557829056
+SHA256 (andmarti1424-sc-im-v0.7.0-81-g9beb5c0_GH0.tar.gz) = 70aecca365ae382c05088c6fb40736cc1046c62e1ef8868fb2dc72f126b1f5b3
+SIZE (andmarti1424-sc-im-v0.7.0-81-g9beb5c0_GH0.tar.gz) = 1114554
diff --git a/math/sc-im/files/patch-cmds__command.c b/math/sc-im/files/patch-cmds__command.c
index 31705a6e84b3..dfd44b752cca 100644
--- a/math/sc-im/files/patch-cmds__command.c
+++ b/math/sc-im/files/patch-cmds__command.c
@@ -1,6 +1,6 @@
---- cmds_command.c.orig 2018-08-03 06:04:39 UTC
+--- cmds_command.c.orig 2019-02-22 18:41:46 UTC
+++ cmds_command.c
-@@ -826,7 +826,7 @@ void do_commandmode(struct block * sb) {
+@@ -853,7 +853,7 @@ void do_commandmode(struct block * sb) {
exec_cmd(line);
} else if ( inputline[0] == L'w' ) {
diff --git a/math/sc-im/files/patch-doc b/math/sc-im/files/patch-doc
index 1b8d22145672..968c56486d77 100644
--- a/math/sc-im/files/patch-doc
+++ b/math/sc-im/files/patch-doc
@@ -1,6 +1,6 @@
---- doc.orig 2018-08-03 06:09:42 UTC
+--- doc.orig 2019-02-22 18:41:46 UTC
+++ doc
-@@ -328,6 +328,8 @@ Commands for handling cell content:
+@@ -330,6 +330,8 @@ Commands for handling cell content:
:w {file} Save the current spreadsheet as {file}.
:w! {file} Save the current spreadsheet as {file}, forcing an overwrite
if {file} already exists.
diff --git a/math/sc-im/files/patch-file.c b/math/sc-im/files/patch-file.c
index 7f5c554e6651..386fdb241913 100644
--- a/math/sc-im/files/patch-file.c
+++ b/math/sc-im/files/patch-file.c
@@ -1,16 +1,46 @@
---- file.c.orig 2017-12-13 17:48:59 UTC
+--- file.c.orig 2019-05-11 16:23:57 UTC
+++ file.c
-@@ -202,7 +202,12 @@ int savefile() {
- del_range_chars(name, 0, 1 + force_rewrite);
+@@ -189,21 +189,23 @@ int modcheck() {
+
+ int savefile() {
+ int force_rewrite = 0;
++ int shall_quit = 0;
+ char name[BUFFERSIZE];
+ #ifndef NO_WORDEXP
+ size_t len;
+ wordexp_t p;
+ #endif
+
+- if (! curfile[0] && wcslen(inputline) < 3) { // casos ":w" ":w!" ":x" ":x!"
++ if (! curfile[0] && wcslen(inputline) < 3) { // casos ":w" ":w!" ":wq" ":x" ":x!"
+ sc_error("There is no filename");
+ return -1;
+ }
+
+ if (inputline[1] == L'!') force_rewrite = 1;
++ if (inputline[1] == L'q') shall_quit = 1;
+
+ wcstombs(name, inputline, BUFFERSIZE);
+- del_range_chars(name, 0, 1 + force_rewrite);
++ del_range_chars(name, 0, 1 + force_rewrite + shall_quit);
+
+ #ifndef NO_WORDEXP
wordexp(name, &p, 0);
+@@ -221,7 +223,7 @@ int savefile() {
+ #endif
-- if (! force_rewrite && p.we_wordv[0] && file_exists(p.we_wordv[0])) {
-+ if (wcslen(inputline) > 2 && (!p.we_wordv || !p.we_wordv[0])) {
-+ sc_error("Trailing space(s)");
-+ return -1;
-+ }
-+
-+ if (! force_rewrite && p.we_wordv && p.we_wordv[0] && file_exists(p.we_wordv[0])) {
- sc_error("File already exists. Use \"!\" to force rewrite.");
- wordfree(&p);
+ if (! force_rewrite && file_exists(name)) {
+- sc_error("File already exists. Use \"!\" to force rewrite.");
++ sc_error("File already exists. Use \"w!\" to force rewrite.");
return -1;
+ }
+
+@@ -235,7 +237,7 @@ int savefile() {
+ // if it exists and no '!' is set, return.
+ if (!strlen(curfile) && backup_exists(name)) {
+ if (!force_rewrite) {
+- sc_error("Backup file of %s exists. Use \"!\" to force the write process.", name);
++ sc_error("Backup file of %s exists. Use \"w!\" to force the write process.", name);
+ return -1;
+ } else remove_backup(name);
+ }
diff --git a/math/sc-im/pkg-plist b/math/sc-im/pkg-plist
index 7391d531af22..b4b174b8874e 100644
--- a/math/sc-im/pkg-plist
+++ b/math/sc-im/pkg-plist
@@ -1,7 +1,7 @@
-bin/scim
-man/man1/scim.1.gz
-share/scim/plot_bar
-share/scim/plot_line
-share/scim/plot_pie
-share/scim/plot_scatter
-share/scim/scim_help
+bin/sc-im
+man/man1/sc-im.1.gz
+share/sc-im/plot_bar
+share/sc-im/plot_line
+share/sc-im/plot_pie
+share/sc-im/plot_scatter
+share/sc-im/sc-im_help