aboutsummaryrefslogtreecommitdiff
path: root/math/sc
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2009-01-09 09:42:42 +0000
committerJohan van Selst <johans@FreeBSD.org>2009-01-09 09:42:42 +0000
commit4ec97ae8f0635d29930320a95c4eaf7f87bc2d6e (patch)
treebab63332531c16c43394a4b0c55cdf78faee2441 /math/sc
parent7b92bd1792b919627cdf6af7de6a4d98ef1eab0f (diff)
downloadports-4ec97ae8f0635d29930320a95c4eaf7f87bc2d6e.tar.gz
ports-4ec97ae8f0635d29930320a95c4eaf7f87bc2d6e.zip
Notes
Diffstat (limited to 'math/sc')
-rw-r--r--math/sc/Makefile33
-rw-r--r--math/sc/distinfo3
-rw-r--r--math/sc/pkg-descr7
-rw-r--r--math/sc/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/math/sc/Makefile b/math/sc/Makefile
new file mode 100644
index 000000000000..df9765ca0e3c
--- /dev/null
+++ b/math/sc/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sc
+# Date created: 30 July 1998
+# Whom: Heinz Tschabitscher
+#
+# $FreeBSD$
+#
+
+PORTNAME= sc
+PORTVERSION= 7.16
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/financial/spreadsheet
+
+MAINTAINER= johans@stack.nl
+COMMENT= A curses-based spreadsheet program
+
+MAN1= sc.1 psc.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^prefix=/s,=.*,=$${PREFIX},' \
+ -e '/^CC=/s,=.*,=${CC},' \
+ -e '/^CFLAGS=/s,=.*,=-DSYSV3 ${CFLAGS},' \
+ -e '/^LIBDIR=/s,=.*,=${DATADIR},' \
+ -e '/^YACC=/s,=.*,=${YACC},' \
+ -e '/usr.bin.crypt/s,^# *,,' \
+ -e '/mkdir.*plugins/d' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/^void/int/' ${WRKSRC}/crypt.c
+ @${REINPLACE_CMD} -e '/flag.val/s/.*/#undef is_cleared/' ${WRKSRC}/sc.h
+
+.include <bsd.port.post.mk>
diff --git a/math/sc/distinfo b/math/sc/distinfo
new file mode 100644
index 000000000000..61e6e711cf97
--- /dev/null
+++ b/math/sc/distinfo
@@ -0,0 +1,3 @@
+MD5 (sc-7.16.tar.gz) = 1db636e9b2dc7cd73c40aeece6852d47
+SHA256 (sc-7.16.tar.gz) = 1997a00b6d82d189b65f6fd2a856a34992abc99e50d9ec463bbf1afb750d1765
+SIZE (sc-7.16.tar.gz) = 210809
diff --git a/math/sc/pkg-descr b/math/sc/pkg-descr
new file mode 100644
index 000000000000..d0ed9f7ad3c2
--- /dev/null
+++ b/math/sc/pkg-descr
@@ -0,0 +1,7 @@
+The spreadsheet calculator sc is based on rectangular tables much like
+a financial spreadsheet. When invoked it presents you with a table
+organized as rows and columns of cells. If invoked without a file
+argument, the table is initially empty. Each cell may have associated
+with it a numeric value, a label string, and/or an expression (formula)
+which evaluates to a numeric value or label string, often based on other
+cell values.
diff --git a/math/sc/pkg-plist b/math/sc/pkg-plist
new file mode 100644
index 000000000000..a512e1d9d353
--- /dev/null
+++ b/math/sc/pkg-plist
@@ -0,0 +1,5 @@
+bin/sc
+bin/scqref
+bin/psc
+%%DATADIR%%/tutorial.sc
+@dirrm %%DATADIR%%