aboutsummaryrefslogtreecommitdiff
path: root/math/sc
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-10 00:20:29 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-10 00:20:29 +0000
commitff262bc5f011aede71819932072dc563b50a173e (patch)
tree4d6028d3ef33cb4fe69d980893d3b6ba6c430a4c /math/sc
parent3d81b65a049cff3fb8c5fb45768120448e434567 (diff)
downloadports-ff262bc5f011aede71819932072dc563b50a173e.tar.gz
ports-ff262bc5f011aede71819932072dc563b50a173e.zip
Notes
Diffstat (limited to 'math/sc')
-rw-r--r--math/sc/Makefile19
-rw-r--r--math/sc/distinfo1
-rw-r--r--math/sc/files/patch-aa126
-rw-r--r--math/sc/files/patch-ab16
-rw-r--r--math/sc/pkg-comment1
-rw-r--r--math/sc/pkg-descr10
-rw-r--r--math/sc/pkg-plist6
7 files changed, 179 insertions, 0 deletions
diff --git a/math/sc/Makefile b/math/sc/Makefile
new file mode 100644
index 000000000000..c4bf68189a25
--- /dev/null
+++ b/math/sc/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: sc
+# Version required: 6.21
+# Date created: 30 July 1998
+# Whom: Heinz Tschabitscher
+#
+# $Id$
+#
+
+DISTNAME= sc-6.21
+CATEGORIES= math
+MASTER_SITES= ftp://gatekeeper.dec.com/pub/misc/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= semper@doubt.com
+
+NO_WRKSUBDIR= yes
+MAN1= sc.1 psc.1
+
+.include <bsd.port.mk>
diff --git a/math/sc/distinfo b/math/sc/distinfo
new file mode 100644
index 000000000000..20338e8cdad5
--- /dev/null
+++ b/math/sc/distinfo
@@ -0,0 +1 @@
+MD5 (sc-6.21.tar.Z) = 8fe8886f0139036717ba09f2fdcb2de7
diff --git a/math/sc/files/patch-aa b/math/sc/files/patch-aa
new file mode 100644
index 000000000000..6eeb4e102b4e
--- /dev/null
+++ b/math/sc/files/patch-aa
@@ -0,0 +1,126 @@
+--- Makefile.orig Mon May 11 20:43:33 1992
++++ Makefile Thu Jul 30 20:02:22 1998
+@@ -18,18 +18,18 @@
+
+ # This is where the install step puts it.
+ #EXDIR=/site/bin
+-EXDIR=/usr/local/bin
++EXDIR=${PREFIX}/bin
+
+ # This is where the man page goes.
+-#MANDIR=/usr/local/src/man/man1 # reno
+-#MANEXT=1 # reno
+-MANDIR=/usr/man/manl
+-MANEXT=l
++MANDIR=${PREFIX}/man/man1 # reno
++MANEXT=1 # reno
++#MANDIR=/usr/man/manl
++#MANEXT=l
+ MANMODE=644
+
+ # This is where the library file (tutorial) goes.
+ #LIBDIR=/usr/local/share/$(name) # reno
+-LIBDIR=/usr/local/lib/$(name)
++LIBDIR=${PREFIX}/share/$(name)
+
+ # Set SIMPLE for lex.c if you don't want arrow keys or lex.c blows up
+ SIMPLE=
+@@ -47,8 +47,8 @@
+
+ # Set INTERNATIONAL if you need 8 bit characters. You should
+ # not set this if you are running 5.3.0. I think it is OK in 5.3.1.
+-#INTERNATIONAL=-DINTERNATIONAL
+-INTERNATIONAL=
++INTERNATIONAL=-DINTERNATIONAL
++#INTERNATIONAL=
+
+ # Set SIGVOID if signal routines are type void.
+ # use: SIGVOID=-DSIGVOID for:
+@@ -67,30 +67,30 @@
+ # Set RINT= on/with (they have rint):
+ # SunOS 4.0.3c compiler
+ # BSD4.4 (reno)
+-#RINT=
+-RINT=-DRINT
++RINT=
++#RINT=-DRINT
+
+ # Set RE_COMP if you have the re_comp/re_exec regular expression routines
+ # (most BSD based systems do).
+-#RE_COMP=-DRE_COMP
+-RE_COMP=
++RE_COMP=-DRE_COMP
++#RE_COMP=
+
+ # Set REGCMP if you have the regcmp/regex regular expression routines
+ # (most System V based systems do)
+-REGCMP=-DREGCMP
++#REGCMP=-DREGCMP
+ #REGCMP=
+
+ # This is the name of a pager like "more".
+ # "pg" may be appropriate for SYSV.
+-DFLT_PAGER=-DDFLT_PAGER=\"less\"
+-#DFLT_PAGER=-DDFLT_PAGER=\"more\" # generic && reno
++#DFLT_PAGER=-DDFLT_PAGER=\"less\"
++DFLT_PAGER=-DDFLT_PAGER=\"more\" # generic && reno
+
+ # this is the name to save back ups in
+ SAVE=-DSAVENAME=\"$(NAME).SAVE\"
+
+ # path to crypt, do not define if you don't have crypt
+ # most systems
+-CRYPT=-DCRYPT_PATH=\"/bin/crypt\"
++#CRYPT=-DCRYPT_PATH=\"/bin/crypt\"
+ # BSD
+ #CRYPT=-DCRYPT_PATH=\"/usr/bin/crypt\"
+ # other people?
+@@ -133,8 +133,8 @@
+ # noticing the rows become 2, 3, 40, 41, 42... (etc).
+ # Known systems/terminfos w/ curses problems:
+ # {Esix Rev. D+, AT&T SysV3.2.1}:at386-m,xterm, HP-UX7.0:(not sure)
+-IDLOKISBAD=-DIDLOKBAD
+-#IDLOKISBAD=
++#IDLOKISBAD=-DIDLOKBAD
++IDLOKISBAD=
+
+ # If you don't have idlok() in your curses define NOIDLOK
+ NO_IDLOK=
+@@ -158,8 +158,8 @@
+ YTAB=y.tab
+
+ # Command to use to make temporary copies of some source files.
+-LN=ln
+-#LN=ln -s
++#LN=ln
++LN=ln -s
+ #LN=cp
+
+ #### SYSTEM DEFINES ####
+@@ -178,11 +178,11 @@
+ #CFLAGS= -DSYSV2 -g -pipe -traditional
+
+ # Use this for system V.3
+-CFLAGS= -DSYSV3 -O
+-LDFLAGS= -s
++#CFLAGS= -O -DSYSV3
++#LDFLAGS= -s
+ #CFLAGS= -DSYSV3 -g
+ #LDFLAGS= -g
+-LIB=-lm -lcurses -lPW
++LIB=
+ # with gcc also use:
+ #CC=gcc
+ #CFLAGS= -DSYSV3 -O -pipe -traditional
+@@ -221,9 +221,9 @@
+ #CFLAGS= -O -DBSD42 -pipe
+
+ # Use this for BSD 4.3
+-#CFLAGS= -O -DBSD43
++CFLAGS += -DBSD43
+ #LDFLAGS=
+-#LIB=-lm -lcurses -ltermcap
++LIB=-lm -lcurses -ltermcap -lcompat
+
+ # Use this for SunOS 4.X if you have the System V package installed.
+ # This will link with the System V curses which is preferable to the
diff --git a/math/sc/files/patch-ab b/math/sc/files/patch-ab
new file mode 100644
index 000000000000..44fa4f2c9223
--- /dev/null
+++ b/math/sc/files/patch-ab
@@ -0,0 +1,16 @@
+--- lex.c.orig Mon May 11 20:43:36 1992
++++ lex.c Thu Jul 30 20:26:51 1998
+@@ -384,11 +384,11 @@
+ ctl('z'), 0
+ };
+
+-void
++int
+ charout(c)
+ int c;
+ {
+- (void)putchar(c);
++ return putchar(c);
+ }
+
+ void
diff --git a/math/sc/pkg-comment b/math/sc/pkg-comment
new file mode 100644
index 000000000000..a01d30c28549
--- /dev/null
+++ b/math/sc/pkg-comment
@@ -0,0 +1 @@
+A curses-based spreadsheet program
diff --git a/math/sc/pkg-descr b/math/sc/pkg-descr
new file mode 100644
index 000000000000..917c1a25fe0d
--- /dev/null
+++ b/math/sc/pkg-descr
@@ -0,0 +1,10 @@
+The spreadsheet calculator sc is based on rectangular tables much like
+a financial spreadsheet. When invoked it presents you with a table
+organized as rows and columns of cells. If invoked without a file
+argument, the table is initially empty. Each cell may have associated
+with it a numeric value, a label string, and/or an expression (formula)
+which evaluates to a numeric value or label string, often based on other
+cell values.
+
+- Heinzl
+semper@doubt.com
diff --git a/math/sc/pkg-plist b/math/sc/pkg-plist
new file mode 100644
index 000000000000..9eb6c6a80c4f
--- /dev/null
+++ b/math/sc/pkg-plist
@@ -0,0 +1,6 @@
+bin/sc
+bin/scqref
+bin/psc
+share/sc/tutorial.sc
+man/man1/sc.1.gz
+man/man1/psc.1.gz