aboutsummaryrefslogtreecommitdiff
path: root/math/scalapack
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-11-28 10:44:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-11-28 10:44:56 +0000
commit532f881192e54b6a05668cf16b6189f5bdd6b7e5 (patch)
tree98425fe5718b372e97a66d6b0f071f732e042bd3 /math/scalapack
parenta9969884fb77e493740fae5649c192f9c5a9ab15 (diff)
downloadports-532f881192e54b6a05668cf16b6189f5bdd6b7e5.tar.gz
ports-532f881192e54b6a05668cf16b6189f5bdd6b7e5.zip
Notes
Diffstat (limited to 'math/scalapack')
-rw-r--r--math/scalapack/Makefile12
-rw-r--r--math/scalapack/files/SLmake.inc-mpich.diff2
-rw-r--r--math/scalapack/files/pkg-message.in12
3 files changed, 13 insertions, 13 deletions
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 8e16690b938e..ea5070e3ef80 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scalapack
PORTVERSION= 1.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/scalapack/
DISTFILES= scalapack-${PORTVERSION}.tgz manpages.tgz
@@ -57,7 +57,7 @@ LAPACK= -llapack
.endif
.if exists(${LOCALBASE}/mpi/openmpi/bin/mpirun)
-WITH_OPENMPI= yes
+WITH_OPENMPI= yes
.endif
.if defined(WITH_OPENMPI)
@@ -66,8 +66,8 @@ RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
EXTRA_PATCHES+= ${FILESDIR}/SLmake.inc-openmpi.diff
.else
#LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
EXTRA_PATCHES+= ${FILESDIR}/SLmake.inc-mpich.diff
.endif
@@ -100,8 +100,8 @@ NOOPT= -O0
MPIF77= ${LOCALBASE}/mpi/openmpi/bin/mpif77
MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
.else
-MPIF77= ${LOCALBASE}/mpich2/bin/mpif77
-MPICC= ${LOCALBASE}/mpich2/bin/mpicc
+MPIF77= ${LOCALBASE}/bin/mpif77
+MPICC= ${LOCALBASE}/bin/mpicc
.endif
post-patch:
diff --git a/math/scalapack/files/SLmake.inc-mpich.diff b/math/scalapack/files/SLmake.inc-mpich.diff
index e24f66bd150a..3a35693d450c 100644
--- a/math/scalapack/files/SLmake.inc-mpich.diff
+++ b/math/scalapack/files/SLmake.inc-mpich.diff
@@ -27,7 +27,7 @@
-BLACSFINIT = $(BLACSdir)/libmpiblacsF77init-p4.a
-BLACSCINIT = $(BLACSdir)/libmpiblacsCinit-p4.a
-BLACSLIB = $(BLACSdir)/libmpiblacs-p4.a
-+SMPLIB = -L@LOCALBASE@/mpich2 -lmpich
++SMPLIB = -L@LOCALBASE@ -lmpich
+BLACSFINIT = $(BLACSdir)/libblacsf77.a #-L$(BLACSdir) -lblacsf77
+BLACSCINIT = $(BLACSdir)/libblacsc.a #-L$(BLACSdir) -lblacsc
+BLACSLIB = $(BLACSdir)/libblacs.a #-L$(BLACSdir) -lblacs
diff --git a/math/scalapack/files/pkg-message.in b/math/scalapack/files/pkg-message.in
index 28d99c43a274..74b24ecc5d10 100644
--- a/math/scalapack/files/pkg-message.in
+++ b/math/scalapack/files/pkg-message.in
@@ -6,19 +6,19 @@
Example:
% cd %%DATADIR%%/TESTING
- % %%LOCALBASE%%/mpich2/bin/mpd &
- % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xcbrd
- % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xcdblu
+ % %%LOCALBASE%%/bin/mpd &
+ % %%LOCALBASE%%/bin/mpirun -np 4 ./xcbrd
+ % %%LOCALBASE%%/bin/mpirun -np 4 ./xcdblu
etc., etc. ...
to perform all the tests,
% cd %%DATADIR%%/TESTING
- % %%LOCALBASE%%/mpich2/bin/mpd &
+ % %%LOCALBASE%%/bin/mpd &
% csh
% foreach i (x*)
- ? %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./$i >& ~/$i.log
+ ? %%LOCALBASE%%/bin/mpirun -np 4 ./$i >& ~/$i.log
? end
- % %%LOCALBASE%%/mpich2/bin/mpdallexit
+ % %%LOCALBASE%%/bin/mpdallexit
If you're using OpenMPI, use this instead:
% cd %%DATADIR%%/TESTING