aboutsummaryrefslogtreecommitdiff
path: root/math/scalapack
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-07-24 01:42:21 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-07-24 01:42:21 +0000
commit3115d648d88a878b13e1591372ffccd8437adee0 (patch)
treef114137d732bcd9d8b9fb4f0f245b6bc0f33c139 /math/scalapack
parent18d9746bbfabf04243cb40b33e7393155869d1ab (diff)
downloadports-3115d648d88a878b13e1591372ffccd8437adee0.tar.gz
ports-3115d648d88a878b13e1591372ffccd8437adee0.zip
Notes
Diffstat (limited to 'math/scalapack')
-rw-r--r--math/scalapack/Makefile10
-rw-r--r--math/scalapack/files/patch-SLmake.inc6
-rw-r--r--math/scalapack/files/pkg-message.in20
-rw-r--r--math/scalapack/pkg-message21
4 files changed, 20 insertions, 37 deletions
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 9e4bc2387e43..a2460ead9fad 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scalapack
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/scalapack/
DISTNAME= SCALAPACK
@@ -23,7 +23,7 @@ EXTRACT_ONLY= scalapack.tgz manpages.tgz
MAINTAINER= maho@FreeBSD.org
COMMENT= The ScaLAPACK Scalable LAPACK library
-BUILD_DEPENDS= ${LOCALBASE}/mpich/lib/libmpich.a:${PORTSDIR}/net/mpich \
+BUILD_DEPENDS= ${LOCALBASE}/mpich2/lib/libmpich.a:${PORTSDIR}/net/mpich2 \
${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/bin/f2c:${PORTSDIR}/lang/f2c
LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
@@ -40,6 +40,7 @@ BLAS= -lf77blas -latlas
DATADIR= ${PREFIX}/share/${PORTNAME:U}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:U}
PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
.include "files/manpages"
@@ -57,8 +58,9 @@ FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
.endif
.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's,@BLAS@,${BLAS},g; s,@WRKSRC@,${WRKSRC},g ; s,@PREFIX@,${PREFIX},g ; s,@CC@,${CC},g ; s,@CFLAGS@,${CFLAGS},g ; s,@F77@,${F77},g ; s,@FFLAGS@,${FFLAGS},g ; s,@F77EXTRAFLAGS@,${F77EXTRAFLAGS},g ; s,^ARCH *.= ar,ARCMD = ar,' ${WRKSRC}/SLmake.inc
+ ${REINPLACE_CMD} -e 's,@BLAS@,${BLAS},g; s,@WRKSRC@,${WRKSRC},g ; s,@LOCALBASE@,${LOCALBASE},g ; s,@CC@,${CC},g ; s,@CFLAGS@,${CFLAGS},g ; s,@F77@,${F77},g ; s,@FFLAGS@,${FFLAGS},g ; s,@F77EXTRAFLAGS@,${F77EXTRAFLAGS},g ; s,^ARCH *.= ar,ARCMD = ar,' ${WRKSRC}/SLmake.inc
.for mkf in ${ARCH2FIX}
${REINPLACE_CMD} -e 's|\$$(ARCH)|$$(ARCMD)|' ${WRKSRC}/${mkf}/Makefile
.endfor
@@ -98,8 +100,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's,/usr/local,${PREFIX},g' ${FILESDIR}/pkg-message.in \
- > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/math/scalapack/files/patch-SLmake.inc b/math/scalapack/files/patch-SLmake.inc
index 3cb679a9e177..b484fadc4a89 100644
--- a/math/scalapack/files/patch-SLmake.inc
+++ b/math/scalapack/files/patch-SLmake.inc
@@ -17,7 +17,7 @@
#
BLACSDBGLVL = 0
-BLACSdir = /usr/local/lib
-+BLACSdir = @PREFIX@/lib
++BLACSdir = @LOCALBASE@/lib
#
# MPI setup; tailor to your system if using MPIBLACS
# Will need to comment out these 6 lines if using PVM
@@ -27,7 +27,7 @@
-BLACSFINIT = $(BLACSdir)/libmpiblacsF77init-p4.a
-BLACSCINIT = $(BLACSdir)/libmpiblacsCinit-p4.a
-BLACSLIB = $(BLACSdir)/libmpiblacs-p4.a
-+SMPLIB = @PREFIX@/mpich/lib/libmpich.a @PREFIX@/mpich/lib/libpmpich.a
++SMPLIB = @LOCALBASE@/mpich2/lib/libmpich.a
+BLACSFINIT = $(BLACSdir)/libblacsf77.a
+BLACSCINIT = $(BLACSdir)/libblacsc.a
+BLACSLIB = $(BLACSdir)/libblacs.a
@@ -56,7 +56,7 @@
#
SCALAPACKLIB = $(home)/libscalapack.a
-BLASLIB = /usr/local/lib/libf77blas.a /usr/local/lib/libatlas.a
-+BLASLIB = -L@PREFIX@/lib @BLAS%
++BLASLIB = -L@LOCALBASE@/lib @BLAS@
#
PBLIBS = $(SCALAPACKLIB) $(FBLACSLIB) $(BLASLIB) $(SMPLIB)
PRLIBS = $(SCALAPACKLIB) $(CBLACSLIB) $(SMPLIB)
diff --git a/math/scalapack/files/pkg-message.in b/math/scalapack/files/pkg-message.in
index ca405055f55a..61261cc6fa64 100644
--- a/math/scalapack/files/pkg-message.in
+++ b/math/scalapack/files/pkg-message.in
@@ -1,21 +1,25 @@
***********************************************************************
Please test your scalapack installation
- Example programs are located at /usr/local/share/SCALAPACK/examples
+ Example programs are located at %%EXAMPLESDIR%%
- Test programs are located at /usr/local/share/SCALAPACK/TESTING
+ Test programs are located at %%DATADIR%%/TESTING
Example:
- % cd /usr/local/share/SCALAPACK/TESTING
- % /usr/local/mpich/bin/mpirun -np 4 xcbrd
- % /usr/local/mpich/bin/mpirun -np 4 xcdblu
+ % cd %%DATADIR%%/TESTING
+ % %%LOCALBASE%%/mpich2/bin/mpd &
+ % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xcbrd
+ % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xcdblu
etc., etc. ...
to perform all the tests,
- % cd /usr/local/share/SCALAPACK/TESTING
+ % cd %%DATADIR%%/TESTING
+ % %%LOCALBASE%%/mpich2/bin/mpd &
% csh
% foreach i (x*)
- ? /usr/local/mpich/bin/mpirun -np 4 $i >& ~/$i.log
+ ? %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./$i >& ~/$i.log
? end
+ % %%LOCALBASE%%/mpich2/bin/mpdallexit
+
You can change -np 4 to any number to meet your environment.
-See files at /usr/local/share/doc/scalapack for detail.
+See files at %%DOCSDIR%% for detail.
**********************************************************************
diff --git a/math/scalapack/pkg-message b/math/scalapack/pkg-message
index c06a730d934c..e69de29bb2d1 100644
--- a/math/scalapack/pkg-message
+++ b/math/scalapack/pkg-message
@@ -1,21 +0,0 @@
-***********************************************************************
- Please test your blacs installation
- Example programs are located at /usr/local/share/SCALAPACK/examples
-
- Test programs are located at /usr/local/share/SCALAPACK/TESTING
-
- Example:
- % cd /usr/local/share/SCLAPACK/TESTING
- % mpirun -np 4 xcbrd
- % mpirun -np 4 xcdblu
- etc., etc. ...
-
- to perform all the tests,
- % cd /usr/local/share/SCLAPACK/TESTING
- % csh
- % foreach i (x*)
- ? mpirun -np 4 $i >& ~/$i.log
- ? end
-You can change -np 4 to any number to meet your environment.
-See files at /usr/local/share/doc/scalapack for detail.
-**********************************************************************