aboutsummaryrefslogtreecommitdiff
path: root/math/scigraphica/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-27 12:51:47 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-27 12:51:47 +0000
commit55bb03a02c39ed09e98e9bf009b36aaac44bc376 (patch)
treece55f8a9450e4e178ec2398b162eb152083b4dad /math/scigraphica/Makefile
parent0458f5ff5e9267fa845e3cc0b6f8c1171707b584 (diff)
Update to 0.7.1.
Notes
Notes: svn path=/head/; revision=45527
Diffstat (limited to 'math/scigraphica/Makefile')
-rw-r--r--math/scigraphica/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
index 0e67be687e34..9c4b85cdf887 100644
--- a/math/scigraphica/Makefile
+++ b/math/scigraphica/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= scigraphica
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.1
CATEGORIES= math gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://scigraphica.sourceforge.net/src/ \
+MASTER_SITES= http://scigraphica.sourceforge.net/src/ \
+ ${MASTER_SITE_SOURCEFORGE} \
http://magnet.fsu.edu/~feiguin/scigraphica/src/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= sg-${PORTVERSION}
@@ -17,8 +17,9 @@ DISTNAME= sg-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gtkextra.15:${PORTSDIR}/x11-toolkits/gtkextra
-RUN_DEPENDS= ${PYNUMERIC}
+LIB_DEPENDS= gtkextra.16:${PORTSDIR}/x11-toolkits/gtkextra
+RUN_DEPENDS= ${PYNUMERIC} \
+ ${PYTHON_SITELIBDIR}/_gtkmodule.so:${PORTSDIR}/x11-toolkits/py-gtk
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -43,4 +44,8 @@ pre-patch:
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/scigraphica
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/scigraphica
+
.include <bsd.port.post.mk>