aboutsummaryrefslogtreecommitdiff
path: root/math/scilab-toolbox-swt
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-23 13:08:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-23 13:08:41 +0000
commit21646392b027298c4aca08ad5386649a6869ccea (patch)
tree902ae1e48303d70f1045908f9eb477d7722924c8 /math/scilab-toolbox-swt
parent6c8d9e9eb93b758a9136ea26f6d089c61feae712 (diff)
downloadports-21646392b027298c4aca08ad5386649a6869ccea.tar.gz
ports-21646392b027298c4aca08ad5386649a6869ccea.zip
Notes
Diffstat (limited to 'math/scilab-toolbox-swt')
-rw-r--r--math/scilab-toolbox-swt/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index e8f98e231e76..3acfc0eb3862 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -27,7 +27,6 @@ OPTIONS_DEFAULT= HELP
HELP_DESC= Build help files (requires scilab with gui support)
SIVP_DESC= Enable Image and Video support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSIVP}
@@ -61,15 +60,15 @@ do-build:
${SETENV} ${MAKE_ENV} ${SCILAB_CMD} ${SCILAB_ARGS} -f builder.sce
do-install:
- ${MKDIR} ${TOOLBOXDIR}/sci_gateway/c
- ${INSTALL_DATA} ${WRKSRC}/loader.sce ${TOOLBOXDIR}
+ ${MKDIR} ${STAGEDIR}${TOOLBOXDIR}/sci_gateway/c
+ ${INSTALL_DATA} ${WRKSRC}/loader.sce ${STAGEDIR}${TOOLBOXDIR}
${INSTALL_DATA} ${WRKSRC}/sci_gateway/loader_gateway.sce \
- ${TOOLBOXDIR}/sci_gateway
+ ${STAGEDIR}${TOOLBOXDIR}/sci_gateway
cd ${WRKSRC}/sci_gateway/c && \
- ${INSTALL_DATA} loader.sce ${TOOLBOXDIR}/sci_gateway/c && \
- ${INSTALL_PROGRAM} libswt_c.so ${TOOLBOXDIR}/sci_gateway/c
+ ${INSTALL_DATA} loader.sce ${STAGEDIR}${TOOLBOXDIR}/sci_gateway/c && \
+ ${INSTALL_PROGRAM} libswt_c.so ${STAGEDIR}${TOOLBOXDIR}/sci_gateway/c
.for d in ${TOOLBOX_SUBDIRS}
- cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${TOOLBOXDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${TOOLBOXDIR}
.endfor
.include <bsd.port.mk>