aboutsummaryrefslogtreecommitdiff
path: root/math/scilab/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-16 08:53:14 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-16 08:53:14 +0000
commit095eeae99d4f2f63ba4cf57731e2c8a7f513c40b (patch)
treefaab2bcc3ecfbf240c4ea3eaf967ee0bc61e0ecf /math/scilab/Makefile
parent92275f2f27f43be94333c5830ab2e5d940a82846 (diff)
downloadports-095eeae99d4f2f63ba4cf57731e2c8a7f513c40b.tar.gz
ports-095eeae99d4f2f63ba4cf57731e2c8a7f513c40b.zip
Notes
Diffstat (limited to 'math/scilab/Makefile')
-rw-r--r--math/scilab/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 86613c41ffee..d7c890449cec 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scilab
PORTVERSION= 4.1
+PORTREVISION= 1
CATEGORIES= math cad parallel
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/
EXTRACT_SUFX= -src.tar.gz
@@ -22,6 +23,7 @@ RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
GNU_CONFIGURE= yes
USE_GETTEXT= yes
WANT_GNOME= yes
+USE_AUTOTOOLS= autoconf:259
CONFIGURE_ARGS= --with-tk \
--with-tk-library=${LOCALBASE}/lib \
@@ -34,12 +36,11 @@ CONFIGURE_ARGS= --with-tk \
--without-java \
--without-ocaml
-CONFIGURE_ENV= X11BASE=${X11BASE} F77=${F77} FFLAGS="${FFLAGS}"
+CONFIGURE_ENV+= X11BASE=${X11BASE} F77=${F77} FFLAGS="${FFLAGS}"
PLIST_SUB= PORTVERSION="${PORTVERSION}" DOCSDIR="share/doc/scilab"
-OPTIONS= ATLAS "Use Atlas" off \
- GTK2 "Use Gtk+2 interface" off \
+OPTIONS= GTK2 "Use Gtk+2 interface" off \
PVM "Use PVM" off
.include <bsd.port.pre.mk>
@@ -67,13 +68,16 @@ LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
PLIST_SUB+= GTK2="@comment " NOGTK2=""
.endif
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
.if defined(WITH_ATLAS)
CONFIGURE_ARGS+= --with-atlas-library=${LOCALBASE}/lib
-LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS_LIBS= -lalapack -lcblas -lf77blas -latlas
.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
-LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS_LIBS?= -llapack -lblas
.endif
MAKE_ENV+= BLAS_LIBS="-L${LOCALBASE}/lib ${BLAS_LIBS}"
@@ -83,6 +87,12 @@ MAKE_ENV+= BLAS_LIBS="-L${LOCALBASE}/lib ${BLAS_LIBS}"
USE_GCC= 3.2
.endif
+WANT_FORTRAN=yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+F77= gfortran42
+FC= gfortran42
+CONFIGURE_ARGS+= --with-gfortran
+
.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102 || ${ARCH} == "ia64" || \
${ARCH} == "sparc64" || ${ARCH} == "amd64" && ${OSVERSION} >= 700000
BROKEN= does not compile on alpha 5.x, ia64, sparc64 or amd64 -CURRENT