aboutsummaryrefslogtreecommitdiff
path: root/math/scilab/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-11 08:09:50 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-11 08:09:50 +0000
commitc7724d2425e64e55d7a4d11f5ae1ea7baa8d9db2 (patch)
treed55b53382c44485e4fed9d301a5ef1114c6c259a /math/scilab/Makefile
parent950514d8777570ee7f01dc54f192df5020eeacd6 (diff)
downloadports-c7724d2425e64e55d7a4d11f5ae1ea7baa8d9db2.tar.gz
ports-c7724d2425e64e55d7a4d11f5ae1ea7baa8d9db2.zip
Notes
Diffstat (limited to 'math/scilab/Makefile')
-rw-r--r--math/scilab/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index ef6f1b585b2c..964890db5bc1 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scilab
-PORTVERSION= 2.7
-PORTREVISION= 2
+PORTVERSION= 3.0
CATEGORIES= math cad parallel
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Scilab/distributions/
EXTRACT_SUFX= .src.tar.gz
@@ -19,8 +18,10 @@ LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d \
f77blas.1:${PORTSDIR}/math/atlas \
lapack.3:${PORTSDIR}/math/lapack
BUILD_DEPENDS= pvm:${PORTSDIR}/net/pvm \
+ wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
+ sabcmd:${PORTSDIR}/textproc/sablotron
+RUN_DEPENDS+= pvm:${PORTSDIR}/net/pvm \
wish8.4:${PORTSDIR}/x11-toolkits/tk84
-RUN_DEPENDS+= ${BUILD_DEPENDS}
PVM_ROOT= ${LOCALBASE}/lib/pvm
@@ -39,11 +40,14 @@ CONFIGURE_ARGS= --with-tk \
--with-xaw3d \
--x-include=${X11BASE}/include \
--x-libraries=${X11BASE}/lib \
- --with-atlas-library=${LOCALBASE}/lib
+ --with-atlas-library=${LOCALBASE}/lib \
+ --without-ocaml
CONFIGURE_ENV= PVM_ROOT=${PVM_ROOT} X11BASE=${X11BASE}
MAKE_ENV= PVM_INCLUDE=${LOCALBASE}/include
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102 || ${ARCH} == "sparc64"