aboutsummaryrefslogtreecommitdiff
path: root/math/scilab
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-01-07 12:26:00 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-01-07 12:26:00 +0000
commit1f35c756bd1062b54ced9b571150eb59d403f929 (patch)
treed905ce6eab308fe1d4ee8450c3408a4317c51334 /math/scilab
parenta61ee25d86b4339b52af50236219d316ea500be1 (diff)
downloadports-1f35c756bd1062b54ced9b571150eb59d403f929.tar.gz
ports-1f35c756bd1062b54ced9b571150eb59d403f929.zip
Notes
Diffstat (limited to 'math/scilab')
-rw-r--r--math/scilab/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index c21d8c9f123f..203df47c12dd 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
pvm:${PORTSDIR}/net/pvm
+USE_FORTRAN=yes
+CONFIGURE_ARGS+= --with-gfortran
USE_XORG= x11
GNU_CONFIGURE= yes
USE_GETTEXT= yes
@@ -44,8 +46,7 @@ CONFIGURE_ARGS= --with-tk \
--with-gtk2
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-CONFIGURE_ENV+= F77=${F77} CFLAGS="${CFLAGS}" FFLAGS="${FFLAGS}" \
- PVM_ROOT=${LOCALBASE}/lib/pvm
+CONFIGURE_ENV+= PVM_ROOT=${LOCALBASE}/lib/pvm
.include <bsd.port.pre.mk>
@@ -67,13 +68,6 @@ BLAS_LIBS?= -llapack -lblas
.endif
MAKE_ENV+= BLAS_LIBS="-L${LOCALBASE}/lib ${BLAS_LIBS}"
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-RUN_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-F77= gfortran42
-FC= gfortran42
-CONFIGURE_ARGS+= --with-gfortran
-
.if ${ARCH} == "alpha" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= does not compile on alpha 5.x, ia64, sparc64
.endif