aboutsummaryrefslogtreecommitdiff
path: root/math/scilab
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-10-12 14:31:07 +0000
committerSteve Wills <swills@FreeBSD.org>2015-10-12 14:31:07 +0000
commit495acc0a67d1034c62509adf49d004e12bba449d (patch)
tree61bfca0d4f22385a52fcd88c1a3832bf5a19ade4 /math/scilab
parent27eef1fe35af004717db3ff8730fc448c941a631 (diff)
downloadports-495acc0a67d1034c62509adf49d004e12bba449d.tar.gz
ports-495acc0a67d1034c62509adf49d004e12bba449d.zip
math/scilab: fix build with OpenJDK8
PR: 203511 Approved by: makc (maintainer)
Notes
Notes: svn path=/head/; revision=399136
Diffstat (limited to 'math/scilab')
-rw-r--r--math/scilab/Makefile8
-rw-r--r--math/scilab/files/extra-patch-Makefile.in11
-rw-r--r--math/scilab/files/patch-configure11
3 files changed, 29 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index dbb6bb71e30c..7388afbc4cc4 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -115,6 +115,12 @@ TK_USE= XORG=x11
CONFIGURE_ARGS+= --without-openmp
.endif
+.include <bsd.port.pre.mk>
+
+.if ${JAVA_PORT_VERSION:M1.8.*}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.in
+.endif
+
post-patch:
@# Configure fixes
@${REINPLACE_CMD} -e 's|-ldl | |' ${WRKSRC}/configure
@@ -161,4 +167,4 @@ check test regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${_MAKE_JOBS} \
${MAKE_ARGS} check)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/scilab/files/extra-patch-Makefile.in b/math/scilab/files/extra-patch-Makefile.in
new file mode 100644
index 000000000000..a9cc5e6b3039
--- /dev/null
+++ b/math/scilab/files/extra-patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2015-10-02 17:25:36.689224000 +0000
++++ Makefile.in 2015-10-02 17:25:47.634538000 +0000
+@@ -2110,7 +2110,7 @@
+ # This is not done in the module itself because its needs also the "types"
+ # module
+ javadoc:
+- $(JAVADOC) -noindex -nohelp -nonavbar -notree \
++ $(JAVADOC) -Xdoclint:none -noindex -nohelp -nonavbar -notree \
+ -d $(top_builddir)/modules/javasci/javadoc \
+ -sourcepath $(top_srcdir)/modules/javasci/src/java:$(top_srcdir)/modules/types/src/java::$(top_srcdir)/modules/localization/src/java \
+ org.scilab.modules.javasci org.scilab.modules.types
diff --git a/math/scilab/files/patch-configure b/math/scilab/files/patch-configure
new file mode 100644
index 000000000000..517bb451f5e0
--- /dev/null
+++ b/math/scilab/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2015-10-02 17:09:45.251035000 +0000
++++ configure 2015-10-02 17:07:21.796652000 +0000
+@@ -11863,7 +11863,7 @@
+ fi
+ fi
+ ac_java_jvm_jni_lib_runtime_path="${ac_java_jvm_jni_lib_runtime_path}:$D"
+- ac_java_jvm_jni_lib_flags="$ac_java_jvm_jni_lib_flags -L$D -ljvm"
++ ac_java_jvm_jni_lib_flags="$ac_java_jvm_jni_lib_flags -L$D -ljvm -pthread"
+ D=$ac_java_jvm_dir/jre/lib/$machine/native_threads
+ if test -d $D; then
+ ac_java_jvm_jni_lib_runtime_path="${ac_java_jvm_jni_lib_runtime_path}:$D"