aboutsummaryrefslogtreecommitdiff
path: root/math/sdpara
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-02-16 07:22:10 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-02-16 07:22:10 +0000
commitec62a2fde2773ea1bc3237b1e419c858077847ff (patch)
treeb38b7c2dd9837f2acdee2a8de107a01564bfbb7c /math/sdpara
parentb0186f2ea4acbcc4b6f02f9338cf9322c176efce (diff)
downloadports-ec62a2fde2773ea1bc3237b1e419c858077847ff.tar.gz
ports-ec62a2fde2773ea1bc3237b1e419c858077847ff.zip
Fix build with gotoblas.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=249924
Diffstat (limited to 'math/sdpara')
-rw-r--r--math/sdpara/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index 6858dc0713dd..fc9ba3bf166d 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -33,7 +33,7 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -45,10 +45,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+LAPACK= -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r