aboutsummaryrefslogtreecommitdiff
path: root/math/sdpara
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-07-04 04:59:27 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-07-04 04:59:27 +0000
commit4746a2a816049e63af763d3d549e2836e8eb29d4 (patch)
tree8c8a1d9d09f8eb374afff651655f6a7dd8305d41 /math/sdpara
parent314c3abb8697d639d49954eade9465f687e9c95e (diff)
downloadports-4746a2a816049e63af763d3d549e2836e8eb29d4.tar.gz
ports-4746a2a816049e63af763d3d549e2836e8eb29d4.zip
Notes
Diffstat (limited to 'math/sdpara')
-rw-r--r--math/sdpara/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index 268e6b0fa828..98a63f654fd4 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -35,12 +35,16 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
.include <bsd.port.pre.mk>
.if defined(WITH_OPTIMIZED_FLAGS)
-FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
-CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
-.if (${ARCH} == "i386")
-FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3
-CXXFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3
-.endif # i386
+.if ${ARCH} == "amd64"
+FFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time
+CFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time
+.else if ${ARCH} == "i386"
+FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+.else
+FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
+CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
+.endif
.endif
post-patch: