aboutsummaryrefslogtreecommitdiff
path: root/math/sfst
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-07-07 12:05:05 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-07-07 12:05:05 +0000
commit9e7ba1ae563bccce4896323177e202cd3b1392a2 (patch)
tree509f0ae7147b589f08dbef4b8d13b58df9d0a1a5 /math/sfst
parent5b7567af2da3babec5962eb27e055555a99d77c5 (diff)
downloadports-9e7ba1ae563bccce4896323177e202cd3b1392a2.tar.gz
ports-9e7ba1ae563bccce4896323177e202cd3b1392a2.zip
Notes
Diffstat (limited to 'math/sfst')
-rw-r--r--math/sfst/Makefile18
-rw-r--r--math/sfst/distinfo2
-rw-r--r--math/sfst/files/patch-src-Makefile78
-rw-r--r--math/sfst/pkg-descr18
-rw-r--r--math/sfst/pkg-plist44
5 files changed, 160 insertions, 0 deletions
diff --git a/math/sfst/Makefile b/math/sfst/Makefile
new file mode 100644
index 000000000000..1b7a15928efb
--- /dev/null
+++ b/math/sfst/Makefile
@@ -0,0 +1,18 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= sfst
+PORTVERSION= 1.4.6h
+CATEGORIES= math
+MASTER_SITES= http://www.cis.uni-muenchen.de/~schmid/tools/SFST/data/
+DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A toolbox for the implementation of morphological analysers
+
+WRKSRC= ${WRKDIR}/${PORTNAME:tu}/src
+INSTALL_TARGET= install maninstall libinstall
+USES= gmake
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/sfst/distinfo b/math/sfst/distinfo
new file mode 100644
index 000000000000..902a3fabd369
--- /dev/null
+++ b/math/sfst/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SFST-1.4.6h.tar.gz) = d26dc4754af0e994208409e04f6278aa9b50c7f01bda98e13119f7cb4cdbce9d
+SIZE (SFST-1.4.6h.tar.gz) = 583946
diff --git a/math/sfst/files/patch-src-Makefile b/math/sfst/files/patch-src-Makefile
new file mode 100644
index 000000000000..0a7d2f5e78b8
--- /dev/null
+++ b/math/sfst/files/patch-src-Makefile
@@ -0,0 +1,78 @@
+--- Makefile.orig 2012-01-10 13:13:14.000000000 +0400
++++ Makefile 2014-07-07 15:57:36.000000000 +0400
+@@ -1,8 +1,8 @@
+
+ # try different definitions of SGILIB if hash_map is not found
+ #SGILIB=
+-SGILIB=-DSGI__gnu_cxx
+-#SGILIB=-DSGIext
++#SGILIB=-DSGI__gnu_cxx
++SGILIB=-DSGIext
+
+ # comment the following lines if readline is not found
+ READLINE = -DREADLINE
+@@ -18,18 +18,18 @@
+
+ # Uncomment this line in order to compile a library and
+ # run "make clean" in order to force a recompilation of the object files
+-# FPIC = -fPIC
++FPIC = -fPIC
+
+-CXX = g++
++CXX ?= CC
+ WARNING = -Wall -Wcast-qual -Wconversion -std=c++98 -Wno-deprecated -ansi
+
+ ifeq ($(findstring CYGWIN,$(shell uname)),CYGWIN)
+ EXE = .exe
+ endif
+
+-CC = g++
++CC ?= cc
+ CL = $(CC)
+-CFLAGS = -O3 $(WARNING) $(SGILIB) $(CDT) $(READLINE) $(FPIC)
++CFLAGS += $(WARNING) $(SGILIB) $(CDT) $(READLINE) $(FPIC)
+ LDFLAGS =
+
+ CXXFLAGS = $(CFLAGS)
+@@ -46,7 +46,7 @@
+ endif
+
+ DESTDIR =
+-PREFIX = /usr/local/
++PREFIX ?= /usr/local/
+
+ PROGRAMS = fst-compiler$(EXE) fst-infl$(EXE) fst-generate$(EXE) fst-print$(EXE)\
+ fst-compare$(EXE) fst-compact$(EXE) fst-infl2$(EXE) fst-lowmem$(EXE)\
+@@ -138,12 +138,12 @@
+ -rm $(ALLPROGRAMS) testprogram 2>&- > /dev/null
+
+ install: $(PROGRAMS)
+- $(INSTALL_DIR) $(DESTDIR)$(PREFIX)bin
+- for p in $(PROGRAMS); do $(INSTALL) $$p $(DESTDIR)$(PREFIX)bin/$$p; done
++ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/bin
++ for p in $(PROGRAMS); do $(INSTALL) -s $$p $(DESTDIR)$(PREFIX)/bin/$$p; done
+
+ maninstall:
+- $(INSTALL_DIR) $(DESTDIR)$(PREFIX)man/man1
+- for m in man1/*.1; do $(INSTALL_MANPAGES) $$m $(DESTDIR)$(PREFIX)man/$$m; done
++ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/man/man1
++ for m in man1/*.1; do $(INSTALL_MANPAGES) $$m $(DESTDIR)$(PREFIX)/man/$$m; done
+
+ ifeq ($(findstring arwin, $(shell uname)),arwin)
+ DYNLIBS = libsfst.dylib
+@@ -154,12 +154,12 @@
+ libinstall: dynlib hfiles
+
+ dynlib: $(DYNLIBS)
+- $(INSTALL_LIBS) $^ $(PREFIX)lib
++ $(INSTALL_LIBS) $^ $(DESTDIR)$(PREFIX)/lib
+ (ldconfig || true)
+
+ hfiles: alphabet.h basic.h fst.h interface.h mem.h sgi.h utf8.h
+- -@if [ ! -d $(PREFIX)include/sfst ]; then mkdir -p $(PREFIX)include/sfst; fi
+- $(INSTALL) $^ $(PREFIX)include/sfst
++ -@if [ ! -d $(DESTDIR)$(PREFIX)/include/sfst ]; then mkdir -p $(DESTDIR)$(PREFIX)/include/sfst; fi
++ $(INSTALL) $^ $(DESTDIR)$(PREFIX)/include/sfst
+
+
+ # DO NOT DELETE
diff --git a/math/sfst/pkg-descr b/math/sfst/pkg-descr
new file mode 100644
index 000000000000..9aebaab74b64
--- /dev/null
+++ b/math/sfst/pkg-descr
@@ -0,0 +1,18 @@
+SFST is a toolbox for the implementation of morphological analysers and other
+tools which are based on finite state transducer technology.
+
+The SFST tools comprise:
+-- a compiler which translates transducer programs into minimised transducers
+-- interactive and batch-mode analysis programs
+-- tools for comparing and printing transducers
+-- an efficient C++ transducer library
+
+Features:
+-- easy to learn for users who are familiar with grep, sed, or Perl.
+-- efficient implementation in C++
+-- supports
+ -- a wide range of transducer operations
+ -- UTF-8 character coding
+ -- weighted transducers (basic functionality only)
+
+WWW: http://www.cis.uni-muenchen.de/~schmid/tools/SFST/
diff --git a/math/sfst/pkg-plist b/math/sfst/pkg-plist
new file mode 100644
index 000000000000..485d5ff83e09
--- /dev/null
+++ b/math/sfst/pkg-plist
@@ -0,0 +1,44 @@
+bin/fst-compact
+bin/fst-compare
+bin/fst-compiler
+bin/fst-compiler-utf8
+bin/fst-generate
+bin/fst-infl
+bin/fst-infl2
+bin/fst-infl2-daemon
+bin/fst-infl3
+bin/fst-lattice
+bin/fst-lowmem
+bin/fst-match
+bin/fst-mor
+bin/fst-parse
+bin/fst-parse2
+bin/fst-print
+bin/fst-text2bin
+bin/fst-train
+include/sfst/alphabet.h
+include/sfst/basic.h
+include/sfst/fst.h
+include/sfst/interface.h
+include/sfst/mem.h
+include/sfst/sgi.h
+include/sfst/utf8.h
+lib/libsfst.so
+man/man1/fst-compact.1.gz
+man/man1/fst-compare.1.gz
+man/man1/fst-compiler-utf8.1.gz
+man/man1/fst-compiler.1.gz
+man/man1/fst-generate.1.gz
+man/man1/fst-infl.1.gz
+man/man1/fst-infl2.1.gz
+man/man1/fst-infl3.1.gz
+man/man1/fst-lattice.1.gz
+man/man1/fst-lowmem.1.gz
+man/man1/fst-match.1.gz
+man/man1/fst-mor.1.gz
+man/man1/fst-parse.1.gz
+man/man1/fst-parse2.1.gz
+man/man1/fst-print.1.gz
+man/man1/fst-text2bin.1.gz
+man/man1/fst-train.1.gz
+@dirrm include/sfst