aboutsummaryrefslogtreecommitdiff
path: root/math/spar/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-01 03:47:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-01 03:47:52 +0000
commitac027f3c61ce18bfca895ff0971b0777e04b374e (patch)
treea9461ea0f2c5c53d31dd4283db6debfc1c0315b9 /math/spar/Makefile
parent5ce67365d60f3257c635b420c2b0a246e24b6f59 (diff)
Notes
Diffstat (limited to 'math/spar/Makefile')
-rw-r--r--math/spar/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/spar/Makefile b/math/spar/Makefile
new file mode 100644
index 000000000000..8d4e7d508cd1
--- /dev/null
+++ b/math/spar/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: spar
+# Date created: Jun 1, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= spar
+PORTVERSION= 0.5.1
+CATEGORIES= math devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+INSTALLS_SHLIB= yes
+
+MAN1= spar.1
+
+post-patch:
+ @${PERL} -pi -e "s,-ldl,,g" ${WRKSRC}/lib/Makefile.in
+
+.include <bsd.port.mk>