aboutsummaryrefslogtreecommitdiff
path: root/math/speedcrunch
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-03-31 10:57:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-03-31 10:57:12 +0000
commit4b137716d1445f283db8b49d19f42c553929a770 (patch)
treeb84820a9771f9758514b4e5ba8e2284671c13c37 /math/speedcrunch
parent9bf7371d9aec47f2ff651abe62f4196866a362be (diff)
downloadports-4b137716d1445f283db8b49d19f42c553929a770.tar.gz
ports-4b137716d1445f283db8b49d19f42c553929a770.zip
math/speedcrunch:
- update to 0.11 - remove NLS option (l10ns are incorporated into binary now)
Notes
Notes: svn path=/head/; revision=349725
Diffstat (limited to 'math/speedcrunch')
-rw-r--r--math/speedcrunch/Makefile39
-rw-r--r--math/speedcrunch/distinfo4
-rw-r--r--math/speedcrunch/files/patch-src__CMakeLists.txt29
-rw-r--r--math/speedcrunch/files/patch-src__SourceFiles.cmake16
-rw-r--r--math/speedcrunch/files/patch-src__gui__mainwindow.cpp47
-rw-r--r--math/speedcrunch/pkg-plist282
6 files changed, 52 insertions, 365 deletions
diff --git a/math/speedcrunch/Makefile b/math/speedcrunch/Makefile
index 1c5037cfa7da..e68723c80a74 100644
--- a/math/speedcrunch/Makefile
+++ b/math/speedcrunch/Makefile
@@ -2,38 +2,25 @@
# $FreeBSD$
PORTNAME= speedcrunch
-DISTVERSION= 0.10.1
-PORTREVISION= 2
+DISTVERSION= 0.11
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GITHUB
MAINTAINER= makc@FreeBSD.org
-COMMENT= Desktop calculator for power users
+COMMENT= Keyboard-oriented desktop scientific calculator
-USE_QT4= qmake_build moc_build rcc_build uic_build gui xml
-USES= cmake
-CMAKE_SOURCE_PATH= src
+USE_QT4= qmake_build moc_build rcc_build uic_build gui network
+USES= cmake:outsource
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
-LRELEASE_CMD= ${LOCALBASE}/bin/lrelease-qt4
-LRELEASE_ARGS= -compress -silent
-
-OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USE_QT4+= linguist
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+USE_GITHUB= yes
+GH_ACCOUNT= speedcrunch
+GH_PROJECT= SpeedCrunch
+GH_COMMIT= 90d56d1
pre-configure:
-.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC}/src/i18n && ${LRELEASE_CMD} ${LRELEASE_ARGS} *.ts
-.else
- ${REINPLACE_CMD} -e '/speedcrunch_TRANSLATIONS/d' ${WRKSRC}/src/CMakeLists.txt
-.endif
- ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/src/gui/mainwindow.cpp
+ ${REINPLACE_CMD} -e '/CMAKE_COLOR_MAKEFILE/d' \
+ -e '/CMAKE_VERBOSE_MAKEFILE/d' \
+ ${WRKSRC}/src/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/math/speedcrunch/distinfo b/math/speedcrunch/distinfo
index 2335813b969a..b48e43fc5a47 100644
--- a/math/speedcrunch/distinfo
+++ b/math/speedcrunch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (speedcrunch-0.10.1.tar.gz) = 9d4e4ddd8bc6a60d59b9cb4815511ba20a5767719928eae3729e4df6c96dec84
-SIZE (speedcrunch-0.10.1.tar.gz) = 1722124
+SHA256 (speedcrunch-0.11.tar.gz) = 6d7aa7ea364c4c64454e3effa87fe8aeb4554f98d33188a354ce386d8602698d
+SIZE (speedcrunch-0.11.tar.gz) = 1517068
diff --git a/math/speedcrunch/files/patch-src__CMakeLists.txt b/math/speedcrunch/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..3159168f2b75
--- /dev/null
+++ b/math/speedcrunch/files/patch-src__CMakeLists.txt
@@ -0,0 +1,29 @@
+--- ./src/CMakeLists.txt.orig 2014-01-29 21:24:08.000000000 +0000
++++ ./src/CMakeLists.txt 2014-03-30 08:34:09.135721829 +0000
+@@ -71,12 +71,13 @@
+
+ ADD_CUSTOM_TARGET( confclean COMMAND rm -rf Makefile CMakeFiles/ CMakeCache.txt cmake_install.cmake DartTestfile.txt install_manifest.txt )
+
+-find_library(x11 X11)
+-IF(x11)
+- TARGET_LINK_LIBRARIES(${PROGNAME} ${QT_LIBRARIES} X11)
+-ELSE(x11)
++find_package(X11)
++IF(X11_FOUND)
++ INCLUDE_DIRECTORIES(${X11_INCLUDE_DIR})
++ TARGET_LINK_LIBRARIES(${PROGNAME} ${QT_LIBRARIES} ${X11_LIBRARIES})
++ELSE(X11_FOUND)
+ TARGET_LINK_LIBRARIES(${PROGNAME} ${QT_LIBRARIES})
+-ENDIF(x11)
++ENDIF(X11_FOUND)
+
+ # only needed for static builds when directx is enabled in qt and you
+ # get a linker error because of missing a directx function
+@@ -98,6 +99,7 @@
+ ADD_TEST(testevaluator testevaluator)
+
+ ADD_EXECUTABLE(testfloatnum ${testfloatnum_SOURCES})
++TARGET_LINK_LIBRARIES(testfloatnum m)
+ ADD_TEST(testfloatnum testfloatnum)
+
+ INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR} thirdparty core gui math)
diff --git a/math/speedcrunch/files/patch-src__SourceFiles.cmake b/math/speedcrunch/files/patch-src__SourceFiles.cmake
index 39746de58fa6..56ae17f56384 100644
--- a/math/speedcrunch/files/patch-src__SourceFiles.cmake
+++ b/math/speedcrunch/files/patch-src__SourceFiles.cmake
@@ -1,10 +1,10 @@
---- ./src/SourceFiles.cmake.orig 2008-05-23 01:45:21.000000000 +0400
-+++ ./src/SourceFiles.cmake 2009-07-06 22:48:59.000000000 +0400
-@@ -43,7 +43,6 @@
- )
+--- ./src/SourceFiles.cmake.orig 2014-01-29 21:24:08.000000000 +0000
++++ ./src/SourceFiles.cmake 2014-03-30 08:33:39.027726508 +0000
+@@ -55,7 +55,6 @@
set(speedcrunch_SOURCES
--3rdparty/util/binreloc.c
- base/constants.cpp
- base/evaluator.cpp
- base/functions.cpp
+ main.cpp
+-thirdparty/binreloc.c
+ core/book.cpp
+ core/constants.cpp
+ core/evaluator.cpp
diff --git a/math/speedcrunch/files/patch-src__gui__mainwindow.cpp b/math/speedcrunch/files/patch-src__gui__mainwindow.cpp
deleted file mode 100644
index 9839d4a7a8f3..000000000000
--- a/math/speedcrunch/files/patch-src__gui__mainwindow.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- ./src/gui/mainwindow.cpp.orig 2008-05-23 01:45:21.000000000 +0400
-+++ ./src/gui/mainwindow.cpp 2009-07-06 22:50:48.000000000 +0400
-@@ -37,7 +37,6 @@
- #include "tipwidget.hxx"
- #include "variablesdock.hxx"
-
--#include "3rdparty/util/binreloc.h"
- #include "base/constants.hxx"
- #include "base/evaluator.hxx"
- #include "base/functions.hxx"
-@@ -340,17 +339,7 @@
- translator->load( fname );
- return translator;
- #else
--
-- BrInitError error;
-- if ( br_init( & error ) == 0 && error != BR_INIT_ERROR_DISABLED )
-- {
-- qDebug( "Warning: BinReloc failed to initialize (error code %d)", error );
-- qDebug( "Will fallback to hardcoded default path." );
-- }
--
-- char * dataDir = br_find_data_dir( 0 );
-- QString localeDir = QString( dataDir ) + "/speedcrunch/locale";
-- free( dataDir );
-+ QString localeDir = "%%PREFIX%%/share/speedcrunch/locale";
- if ( translator->load( localeFile, localeDir ) )
- return translator;
- else
-@@ -1004,16 +993,7 @@
- appPath.remove( ii, appPath.length() );
- booksDir = appPath + '/' + QString( "books/" );
- #else
-- BrInitError error;
-- if ( br_init( & error ) == 0 && error != BR_INIT_ERROR_DISABLED )
-- {
-- qDebug( "Warning: BinReloc failed to initialize (error code %d)", error );
-- qDebug( "Will fallback to hardcoded default path." );
-- }
--
-- char * dataDir = br_find_data_dir( 0 );
-- booksDir = QString( dataDir ) + "/speedcrunch/books/";
-- free( dataDir );
-+ booksDir = "%%PREFIX%%/share/speedcrunch/books/";
- #endif
-
- docks.book = new BookDock( booksDir, "math_index.html", settings.language,
diff --git a/math/speedcrunch/pkg-plist b/math/speedcrunch/pkg-plist
index 6e3eac3a0e08..cd733a326f3e 100644
--- a/math/speedcrunch/pkg-plist
+++ b/math/speedcrunch/pkg-plist
@@ -1,285 +1,3 @@
bin/speedcrunch
share/applications/speedcrunch.desktop
share/pixmaps/speedcrunch.png
-share/speedcrunch/books/books.css
-share/speedcrunch/books/ca/circle.html
-share/speedcrunch/books/ca/cone.html
-share/speedcrunch/books/ca/cube.html
-share/speedcrunch/books/ca/cylinder.html
-share/speedcrunch/books/ca/math_index.html
-share/speedcrunch/books/ca/quadratic_equation.html
-share/speedcrunch/books/ca/right_triangle.html
-share/speedcrunch/books/ca/sector.html
-share/speedcrunch/books/ca/sphere.html
-share/speedcrunch/books/cs/circle.html
-share/speedcrunch/books/cs/cone.html
-share/speedcrunch/books/cs/cube.html
-share/speedcrunch/books/cs/cylinder.html
-share/speedcrunch/books/cs/index.html
-share/speedcrunch/books/cs/math_index.html
-share/speedcrunch/books/cs/quadratic_equation.html
-share/speedcrunch/books/cs/right_triangle.html
-share/speedcrunch/books/cs/sector.html
-share/speedcrunch/books/cs/sphere.html
-share/speedcrunch/books/de/circle.html
-share/speedcrunch/books/de/cone.html
-share/speedcrunch/books/de/cube.html
-share/speedcrunch/books/de/cylinder.html
-share/speedcrunch/books/de/index.html
-share/speedcrunch/books/de/math_index.html
-share/speedcrunch/books/de/quadratic_equation.html
-share/speedcrunch/books/de/right_triangle.html
-share/speedcrunch/books/de/sector.html
-share/speedcrunch/books/de/sphere.html
-share/speedcrunch/books/en/circle.html
-share/speedcrunch/books/en/cone.html
-share/speedcrunch/books/en/cube.html
-share/speedcrunch/books/en/cylinder.html
-share/speedcrunch/books/en/index.html
-share/speedcrunch/books/en/math_index.html
-share/speedcrunch/books/en/quadratic_equation.html
-share/speedcrunch/books/en/right_triangle.html
-share/speedcrunch/books/en/sector.html
-share/speedcrunch/books/en/sphere.html
-share/speedcrunch/books/es/circle.html
-share/speedcrunch/books/es/cone.html
-share/speedcrunch/books/es/cube.html
-share/speedcrunch/books/es/cylinder.html
-share/speedcrunch/books/es/index.html
-share/speedcrunch/books/es/math_index.html
-share/speedcrunch/books/es/quadratic_equation.html
-share/speedcrunch/books/es/right_triangle.html
-share/speedcrunch/books/es/sector.html
-share/speedcrunch/books/es/sphere.html
-share/speedcrunch/books/es_AR/circle.html
-share/speedcrunch/books/es_AR/cone.html
-share/speedcrunch/books/es_AR/cube.html
-share/speedcrunch/books/es_AR/cylinder.html
-share/speedcrunch/books/es_AR/index.html
-share/speedcrunch/books/es_AR/math_index.html
-share/speedcrunch/books/es_AR/quadratic_equation.html
-share/speedcrunch/books/es_AR/right_triangle.html
-share/speedcrunch/books/es_AR/sector.html
-share/speedcrunch/books/es_AR/sphere.html
-share/speedcrunch/books/eu/circle.html
-share/speedcrunch/books/eu/cone.html
-share/speedcrunch/books/eu/cube.html
-share/speedcrunch/books/eu/cylinder.html
-share/speedcrunch/books/eu/math_index.html
-share/speedcrunch/books/eu/quadratic_equation.html
-share/speedcrunch/books/eu/right_triangle.html
-share/speedcrunch/books/eu/sector.html
-share/speedcrunch/books/eu/sphere.html
-share/speedcrunch/books/fi/circle.html
-share/speedcrunch/books/fi/cone.html
-share/speedcrunch/books/fi/cube.html
-share/speedcrunch/books/fi/cylinder.html
-share/speedcrunch/books/fi/index.html
-share/speedcrunch/books/fi/math_index.html
-share/speedcrunch/books/fi/quadratic_equation.html
-share/speedcrunch/books/fi/right_triangle.html
-share/speedcrunch/books/fi/sector.html
-share/speedcrunch/books/fi/sphere.html
-share/speedcrunch/books/fr/circle.html
-share/speedcrunch/books/fr/cone.html
-share/speedcrunch/books/fr/cube.html
-share/speedcrunch/books/fr/cylinder.html
-share/speedcrunch/books/fr/index.html
-share/speedcrunch/books/fr/math_index.html
-share/speedcrunch/books/fr/quadratic_equation.html
-share/speedcrunch/books/fr/right_triangle.html
-share/speedcrunch/books/fr/sector.html
-share/speedcrunch/books/fr/sphere.html
-share/speedcrunch/books/he/circle.html
-share/speedcrunch/books/he/cone.html
-share/speedcrunch/books/he/cube.html
-share/speedcrunch/books/he/cylinder.html
-share/speedcrunch/books/he/index.html
-share/speedcrunch/books/he/math_index.html
-share/speedcrunch/books/he/quadratic_equation.html
-share/speedcrunch/books/he/right_triangle.html
-share/speedcrunch/books/he/sector.html
-share/speedcrunch/books/he/sphere.html
-share/speedcrunch/books/id/circle.html
-share/speedcrunch/books/id/cone.html
-share/speedcrunch/books/id/cube.html
-share/speedcrunch/books/id/cylinder.html
-share/speedcrunch/books/id/index.html
-share/speedcrunch/books/id/math_index.html
-share/speedcrunch/books/id/quadratic_equation.html
-share/speedcrunch/books/id/right_triangle.html
-share/speedcrunch/books/id/sector.html
-share/speedcrunch/books/id/sphere.html
-share/speedcrunch/books/images/circle.png
-share/speedcrunch/books/images/circle.svgz
-share/speedcrunch/books/images/cone.png
-share/speedcrunch/books/images/cone.svgz
-share/speedcrunch/books/images/cube.png
-share/speedcrunch/books/images/cube.svgz
-share/speedcrunch/books/images/cylinder.png
-share/speedcrunch/books/images/cylinder.svgz
-share/speedcrunch/books/images/make_math_pngs.sh
-share/speedcrunch/books/images/quadratic_equation.mml
-share/speedcrunch/books/images/quadratic_equation.png
-share/speedcrunch/books/images/right_triangle.png
-share/speedcrunch/books/images/right_triangle.svgz
-share/speedcrunch/books/images/sector.png
-share/speedcrunch/books/images/sector.svgz
-share/speedcrunch/books/images/sphere.png
-share/speedcrunch/books/images/sphere.svgz
-share/speedcrunch/books/it/circle.html
-share/speedcrunch/books/it/cone.html
-share/speedcrunch/books/it/cube.html
-share/speedcrunch/books/it/cylinder.html
-share/speedcrunch/books/it/index.html
-share/speedcrunch/books/it/math_index.html
-share/speedcrunch/books/it/quadratic_equation.html
-share/speedcrunch/books/it/right_triangle.html
-share/speedcrunch/books/it/sector.html
-share/speedcrunch/books/it/sphere.html
-share/speedcrunch/books/nb/circle.html
-share/speedcrunch/books/nb/cone.html
-share/speedcrunch/books/nb/cube.html
-share/speedcrunch/books/nb/cylinder.html
-share/speedcrunch/books/nb/index.html
-share/speedcrunch/books/nb/math_index.html
-share/speedcrunch/books/nb/quadratic_equation.html
-share/speedcrunch/books/nb/right_triangle.html
-share/speedcrunch/books/nb/sector.html
-share/speedcrunch/books/nb/sphere.html
-share/speedcrunch/books/nl/circle.html
-share/speedcrunch/books/nl/cone.html
-share/speedcrunch/books/nl/cube.html
-share/speedcrunch/books/nl/cylinder.html
-share/speedcrunch/books/nl/index.html
-share/speedcrunch/books/nl/math_index.html
-share/speedcrunch/books/nl/quadratic_equation.html
-share/speedcrunch/books/nl/right_triangle.html
-share/speedcrunch/books/nl/sector.html
-share/speedcrunch/books/nl/sphere.html
-share/speedcrunch/books/pl/circle.html
-share/speedcrunch/books/pl/cone.html
-share/speedcrunch/books/pl/cube.html
-share/speedcrunch/books/pl/cylinder.html
-share/speedcrunch/books/pl/index.html
-share/speedcrunch/books/pl/math_index.html
-share/speedcrunch/books/pl/quadratic_equation.html
-share/speedcrunch/books/pl/right_triangle.html
-share/speedcrunch/books/pl/sector.html
-share/speedcrunch/books/pl/sphere.html
-share/speedcrunch/books/pt/circle.html
-share/speedcrunch/books/pt/cone.html
-share/speedcrunch/books/pt/cube.html
-share/speedcrunch/books/pt/cylinder.html
-share/speedcrunch/books/pt/index.html
-share/speedcrunch/books/pt/math_index.html
-share/speedcrunch/books/pt/quadratic_equation.html
-share/speedcrunch/books/pt/right_triangle.html
-share/speedcrunch/books/pt/sector.html
-share/speedcrunch/books/pt/sphere.html
-share/speedcrunch/books/pt_BR/circle.html
-share/speedcrunch/books/pt_BR/cone.html
-share/speedcrunch/books/pt_BR/cube.html
-share/speedcrunch/books/pt_BR/cylinder.html
-share/speedcrunch/books/pt_BR/index.html
-share/speedcrunch/books/pt_BR/math_index.html
-share/speedcrunch/books/pt_BR/quadratic_equation.html
-share/speedcrunch/books/pt_BR/right_triangle.html
-share/speedcrunch/books/pt_BR/sector.html
-share/speedcrunch/books/pt_BR/sphere.html
-share/speedcrunch/books/ro/circle.html
-share/speedcrunch/books/ro/cone.html
-share/speedcrunch/books/ro/cube.html
-share/speedcrunch/books/ro/cylinder.html
-share/speedcrunch/books/ro/index.html
-share/speedcrunch/books/ro/math_index.html
-share/speedcrunch/books/ro/quadratic_equation.html
-share/speedcrunch/books/ro/right_triangle.html
-share/speedcrunch/books/ro/sector.html
-share/speedcrunch/books/ro/sphere.html
-share/speedcrunch/books/ru/circle.html
-share/speedcrunch/books/ru/cone.html
-share/speedcrunch/books/ru/cube.html
-share/speedcrunch/books/ru/cylinder.html
-share/speedcrunch/books/ru/index.html
-share/speedcrunch/books/ru/math_index.html
-share/speedcrunch/books/ru/quadratic_equation.html
-share/speedcrunch/books/ru/right_triangle.html
-share/speedcrunch/books/ru/sector.html
-share/speedcrunch/books/ru/sphere.html
-share/speedcrunch/books/sv/circle.html
-share/speedcrunch/books/sv/cone.html
-share/speedcrunch/books/sv/cube.html
-share/speedcrunch/books/sv/cylinder.html
-share/speedcrunch/books/sv/index.html
-share/speedcrunch/books/sv/math_index.html
-share/speedcrunch/books/sv/quadratic_equation.html
-share/speedcrunch/books/sv/right_triangle.html
-share/speedcrunch/books/sv/sector.html
-share/speedcrunch/books/sv/sphere.html
-share/speedcrunch/books/tr/circle.html
-share/speedcrunch/books/tr/cone.html
-share/speedcrunch/books/tr/cube.html
-share/speedcrunch/books/tr/cylinder.html
-share/speedcrunch/books/tr/index.html
-share/speedcrunch/books/tr/math_index.html
-share/speedcrunch/books/tr/quadratic_equation.html
-share/speedcrunch/books/tr/right_triangle.html
-share/speedcrunch/books/tr/sector.html
-share/speedcrunch/books/tr/sphere.html
-share/speedcrunch/books/zh_CN/circle.html
-share/speedcrunch/books/zh_CN/cone.html
-share/speedcrunch/books/zh_CN/cube.html
-share/speedcrunch/books/zh_CN/cylinder.html
-share/speedcrunch/books/zh_CN/math_index.html
-share/speedcrunch/books/zh_CN/quadratic_equation.html
-share/speedcrunch/books/zh_CN/right_triangle.html
-share/speedcrunch/books/zh_CN/sector.html
-share/speedcrunch/books/zh_CN/sphere.html
-%%NLS%%share/speedcrunch/locale/ca.qm
-%%NLS%%share/speedcrunch/locale/cs.qm
-%%NLS%%share/speedcrunch/locale/de.qm
-%%NLS%%share/speedcrunch/locale/es.qm
-%%NLS%%share/speedcrunch/locale/es_AR.qm
-%%NLS%%share/speedcrunch/locale/eu.qm
-%%NLS%%share/speedcrunch/locale/fi.qm
-%%NLS%%share/speedcrunch/locale/fr.qm
-%%NLS%%share/speedcrunch/locale/he.qm
-%%NLS%%share/speedcrunch/locale/id.qm
-%%NLS%%share/speedcrunch/locale/it.qm
-%%NLS%%share/speedcrunch/locale/nb.qm
-%%NLS%%share/speedcrunch/locale/nl.qm
-%%NLS%%share/speedcrunch/locale/pl.qm
-%%NLS%%share/speedcrunch/locale/pt.qm
-%%NLS%%share/speedcrunch/locale/pt_BR.qm
-%%NLS%%share/speedcrunch/locale/ro.qm
-%%NLS%%share/speedcrunch/locale/ru.qm
-%%NLS%%share/speedcrunch/locale/sv.qm
-%%NLS%%share/speedcrunch/locale/tr.qm
-%%NLS%%share/speedcrunch/locale/zh_CN.qm
-%%NLS%%@dirrm share/speedcrunch/locale
-@dirrm share/speedcrunch/books/zh_CN
-@dirrm share/speedcrunch/books/tr
-@dirrm share/speedcrunch/books/sv
-@dirrm share/speedcrunch/books/ru
-@dirrm share/speedcrunch/books/ro
-@dirrm share/speedcrunch/books/pt_BR
-@dirrm share/speedcrunch/books/pt
-@dirrm share/speedcrunch/books/pl
-@dirrm share/speedcrunch/books/nl
-@dirrm share/speedcrunch/books/nb
-@dirrm share/speedcrunch/books/it
-@dirrm share/speedcrunch/books/images
-@dirrm share/speedcrunch/books/id
-@dirrm share/speedcrunch/books/he
-@dirrm share/speedcrunch/books/fr
-@dirrm share/speedcrunch/books/fi
-@dirrm share/speedcrunch/books/eu
-@dirrm share/speedcrunch/books/es_AR
-@dirrm share/speedcrunch/books/es
-@dirrm share/speedcrunch/books/en
-@dirrm share/speedcrunch/books/de
-@dirrm share/speedcrunch/books/cs
-@dirrm share/speedcrunch/books/ca
-@dirrm share/speedcrunch/books
-@dirrm share/speedcrunch