aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-12-28 00:31:03 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-12-28 00:31:03 +0000
commit28000180118407957638ddfb273c9e937787352f (patch)
tree8c8fbefc235d02bf1985d98f53725ac2c01d4f86 /math/suitesparse
parenta27a794bed4227dc04b32b167305caa1c42cfd33 (diff)
downloadports-28000180118407957638ddfb273c9e937787352f.tar.gz
ports-28000180118407957638ddfb273c9e937787352f.zip
Notes
Diffstat (limited to 'math/suitesparse')
-rw-r--r--math/suitesparse/Makefile9
-rw-r--r--math/suitesparse/distinfo6
-rw-r--r--math/suitesparse/files/patch-Makefile18
-rw-r--r--math/suitesparse/files/patch-UFconfig+UFconfig.mk18
-rw-r--r--math/suitesparse/files/patch-size_t26
5 files changed, 26 insertions, 51 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 170e8bc3f3f7..0520db8362df 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= suitesparse
-PORTVERSION= 2.1.1
-PORTREVISION= 3
+PORTVERSION= 2.3.1
CATEGORIES= math
-MASTER_SITES= http://www.cise.ufl.edu/research/sparse/SuiteSparse/current/
-DISTNAME= SuiteSparse
+MASTER_SITES= http://www.cise.ufl.edu/research/sparse/SuiteSparse/
+DISTNAME= SuiteSparse-${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
@@ -42,7 +41,7 @@ CONFLICTS= umfpack-*
USE_LDCONFIG= yes
USE_GMAKE= yes
-
+WRKSRC=${WRKDIR}/SuiteSparse
WRKSRC_SHARED=${WRKSRC}_shared
CFLAGS_SHARED=${CFLAGS} ${FPIC}
FFLAGS_SHARED=${CFLAGS} ${FPIC}
diff --git a/math/suitesparse/distinfo b/math/suitesparse/distinfo
index 1a15580f2f1c..60829395433d 100644
--- a/math/suitesparse/distinfo
+++ b/math/suitesparse/distinfo
@@ -1,3 +1,3 @@
-MD5 (suitesparse/2.1.1/SuiteSparse.tar.gz) = bc01ef2f26e6ad3eed83b4ad62e46a68
-SHA256 (suitesparse/2.1.1/SuiteSparse.tar.gz) = 200f970f2dc596fffe5c9ff9fe6b9f11d3ce9d28a963df1e209942b3f4012ce1
-SIZE (suitesparse/2.1.1/SuiteSparse.tar.gz) = 7839523
+MD5 (suitesparse/2.3.1/SuiteSparse-2.3.1.tar.gz) = 52d5088aaae7231b8c540657ccaf3625
+SHA256 (suitesparse/2.3.1/SuiteSparse-2.3.1.tar.gz) = 81f739db72ed67525673ce8847b817af03a656353f4e566988bdb17d65a5be9f
+SIZE (suitesparse/2.3.1/SuiteSparse-2.3.1.tar.gz) = 7970203
diff --git a/math/suitesparse/files/patch-Makefile b/math/suitesparse/files/patch-Makefile
index 5f602e688fd0..ced710ba1c98 100644
--- a/math/suitesparse/files/patch-Makefile
+++ b/math/suitesparse/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile~ Fri Jul 28 04:49:43 2006
-+++ Makefile Sun Sep 17 22:33:10 2006
-@@ -19,7 +19,7 @@
- ( cd CSparse ; $(MAKE) )
- ( cd CXSparse ; $(MAKE) )
- # ( cd LPDASA ; $(MAKE) )
+--- Makefile Sat Dec 2 07:31:29 2006
++++ Makefile Thu Dec 28 09:02:28 2006
+@@ -7,7 +7,7 @@
+ # Compile the default rules for each package
+ default:
+ ( cd UFconfig/xerbla ; $(MAKE) )
- ( cd metis-4.0 ; $(MAKE) )
+# ( cd metis-4.0 ; $(MAKE) )
- # ( cd PARAKLETE ; $(MAKE) )
-
- library: default
+ ( cd AMD ; $(MAKE) )
+ ( cd CAMD ; $(MAKE) )
+ ( cd COLAMD ; $(MAKE) )
diff --git a/math/suitesparse/files/patch-UFconfig+UFconfig.mk b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
index 4a86cb3d8844..bf16e9ab2194 100644
--- a/math/suitesparse/files/patch-UFconfig+UFconfig.mk
+++ b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
@@ -1,5 +1,5 @@
---- UFconfig/UFconfig.mk Wed Sep 20 05:36:35 2006
-+++ UFconfig/UFconfig.mk Wed Sep 20 05:36:38 2006
+--- UFconfig/UFconfig.mk Wed Nov 29 20:18:52 2006
++++ UFconfig/UFconfig.mk Thu Dec 28 09:14:51 2006
@@ -31,8 +31,8 @@
# C compiler and compiler flags: These will normally not give you optimal
# performance. You should select the optimization parameters that are best
@@ -22,18 +22,18 @@
F77LIB =
# C and Fortran libraries
-@@ -77,8 +77,8 @@
+@@ -73,8 +73,8 @@
# These settings will probably not work, since there is no fixed convention for
# naming the BLAS and LAPACK library (*.a or *.so) files. Assume the Goto
# BLAS are available.
--BLAS = -lgoto -lgfortran
+-BLAS = -lgoto -lgfortran -lgfortranbegin
-LAPACK = -llapack
+BLAS = %%BLAS%%
+LAPACK = %%LAPACK%%
# The BLAS might not contain xerbla, an error-handling routine for LAPACK and
# the BLAS. Also, the standard xerbla requires the Fortran I/O library, and
-@@ -106,8 +106,8 @@
+@@ -102,8 +102,8 @@
# The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
# You may wish to use an absolute path. METIS is optional. Compile
# CHOLMOD with -DNPARTITION if you do not wish to use METIS.
@@ -44,7 +44,7 @@
# If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
# options:
-@@ -130,7 +130,7 @@
+@@ -126,7 +126,7 @@
# -DNRECIPROCAL do not multiply by the reciprocal
# -DNO_DIVIDE_BY_ZERO do not divide by zero
@@ -53,7 +53,7 @@
#------------------------------------------------------------------------------
# CHOLMOD configuration
-@@ -180,11 +180,11 @@
+@@ -176,12 +176,12 @@
# alternatives:
# CFLAGS = -g -fexceptions \
@@ -64,8 +64,10 @@
# CFLAGS = -O3 -fexceptions \
- -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
+-CFLAGS = -O3 -fexceptions
+# -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
- # CFLAGS = -g -fexceptions
++CFLAGS = %%CFLAGS%%
# CFLAGS = -O3
+ # consider:
diff --git a/math/suitesparse/files/patch-size_t b/math/suitesparse/files/patch-size_t
deleted file mode 100644
index 222eb978face..000000000000
--- a/math/suitesparse/files/patch-size_t
+++ /dev/null
@@ -1,26 +0,0 @@
---- AMD/Include/amd_internal.h.old Tue May 2 20:11:29 2006
-+++ AMD/Include/amd_internal.h Sun Sep 17 22:20:26 2006
-@@ -153,7 +153,9 @@
- #define NULL 0
-
- /* largest value of size_t */
--#define SIZE_T_MAX ((size_t) (-1))
-+#if !defined SIZE_T_MAX
-+#define SIZE_T_MAX ((size_t) (-1)) */
-+#endif
-
- /* ------------------------------------------------------------------------- */
- /* integer type for AMD: int or UF_long */
---- CAMD/Include/camd_internal.h~ Wed Jun 28 06:43:39 2006
-+++ CAMD/Include/camd_internal.h Sun Sep 17 22:22:07 2006
-@@ -154,8 +154,9 @@
- #define NULL 0
-
- /* largest value of size_t */
-+#if !defined SIZE_T_MAX
- #define SIZE_T_MAX ((size_t) (-1))
--
-+#endif
- /* ------------------------------------------------------------------------- */
- /* integer type for CAMD: int or UF_long */
- /* ------------------------------------------------------------------------- */