aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2011-06-22 08:14:02 +0000
committerMaho Nakata <maho@FreeBSD.org>2011-06-22 08:14:02 +0000
commit3042d1d3a19319b66173733e47ce330f9cc5e2cd (patch)
tree0acf4d53ae615ebeae9cae2b2b5aa1b0c0e6844a /math/suitesparse
parent12ebf45c5c9fab9220c9e9a8598695e3ef59e263 (diff)
downloadports-3042d1d3a19319b66173733e47ce330f9cc5e2cd.tar.gz
ports-3042d1d3a19319b66173733e47ce330f9cc5e2cd.zip
Notes
Diffstat (limited to 'math/suitesparse')
-rw-r--r--math/suitesparse/Makefile14
-rw-r--r--math/suitesparse/distinfo4
-rw-r--r--math/suitesparse/files/patch-CSparse3+Lib+Makefile11
-rw-r--r--math/suitesparse/files/patch-UFconfig+UFconfig.mk46
4 files changed, 46 insertions, 29 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 705005ff30a7..466c3fbaac2a 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= suitesparse
-PORTVERSION= 3.4.0
-PORTREVISION= 1
+PORTVERSION= 3.6.1
CATEGORIES= math
MASTER_SITES= http://www.cise.ufl.edu/research/sparse/SuiteSparse/
DISTNAME= SuiteSparse-${PORTVERSION}
@@ -90,18 +89,21 @@ post-patch:
${WRKSRC}/UFconfig/UFconfig.mk \
${WRKSRC_SHARED}/UFconfig/UFconfig.mk\
${WRKSRC}/CSparse/Lib/Makefile \
- ${WRKSRC_SHARED}/CSparse/Lib/Makefile
+ ${WRKSRC_SHARED}/CSparse/Lib/Makefile \
+ ${WRKSRC}/CSparse3/Lib/Makefile \
+ ${WRKSRC_SHARED}/CSparse3/Lib/Makefile
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}|g' \
-e 's|%%FFLAGS%%|${FFLAGS}|g' \
${WRKSRC}/UFconfig/UFconfig.mk \
- ${WRKSRC}/CSparse/Lib/Makefile
+ ${WRKSRC}/CSparse/Lib/Makefile \
+ ${WRKSRC}/CSparse3/Lib/Makefile
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS_SHARED}|g' \
-e 's|%%FFLAGS%%|${FFLAGS_SHARED}|g' \
${WRKSRC_SHARED}/UFconfig/UFconfig.mk \
- ${WRKSRC_SHARED}/CSparse/Lib/Makefile
-
+ ${WRKSRC_SHARED}/CSparse/Lib/Makefile \
+ ${WRKSRC_SHARED}/CSparse3/Lib/Makefile
do-build:
cd ${WRKSRC} ; ${GMAKE}
cd ${WRKSRC_SHARED} ; ${GMAKE}
diff --git a/math/suitesparse/distinfo b/math/suitesparse/distinfo
index 56c0d8a933d6..7a13b8267774 100644
--- a/math/suitesparse/distinfo
+++ b/math/suitesparse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (SuiteSparse-3.4.0.tar.gz) = fea78cca92a4f4a56dc482cc93abed6f37bd6a3c350bf7bc5bcd2d772c2852d4
-SIZE (SuiteSparse-3.4.0.tar.gz) = 10372827
+SHA256 (SuiteSparse-3.6.1.tar.gz) = 9876a27ad365ce02610b074167081eb22aa61a18141268dbd84218b7ae37c540
+SIZE (SuiteSparse-3.6.1.tar.gz) = 13043105
diff --git a/math/suitesparse/files/patch-CSparse3+Lib+Makefile b/math/suitesparse/files/patch-CSparse3+Lib+Makefile
new file mode 100644
index 000000000000..33f052e9ec6b
--- /dev/null
+++ b/math/suitesparse/files/patch-CSparse3+Lib+Makefile
@@ -0,0 +1,11 @@
+--- CSparse3/Lib/Makefile~ Wed Feb 27 11:41:43 2008
++++ CSparse3/Lib/Makefile Wed Feb 27 11:50:50 2008
+@@ -1,6 +1,6 @@
+ # Modify the "-O" optimization option for best performance (-O3 on Linux):
+-CC = cc
+-CFLAGS = -O -I../Include
++CC = %%CC%%
++CFLAGS = %%CFLAGS%% -I../Include
+
+ AR = ar cr
+ RANLIB = ranlib
diff --git a/math/suitesparse/files/patch-UFconfig+UFconfig.mk b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
index 0378ab98ed15..55308d18221b 100644
--- a/math/suitesparse/files/patch-UFconfig+UFconfig.mk
+++ b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
@@ -1,11 +1,11 @@
---- UFconfig/UFconfig.mk~ 2009-02-16 14:40:18.000000000 +0900
-+++ UFconfig/UFconfig.mk 2009-02-16 14:44:33.000000000 +0900
+--- UFconfig/UFconfig.mk.orig 2011-05-11 05:47:15.000000000 +0900
++++ UFconfig/UFconfig.mk 2011-06-22 16:35:36.000000000 +0900
@@ -33,11 +33,11 @@
# C compiler and compiler flags: These will normally not give you optimal
# performance. You should select the optimization parameters that are best
# for your system. On Linux, use "CFLAGS = -O3 -fexceptions" for example.
-CC = cc
--# CFLAGS = -O (for example; see below for details)
+-CFLAGS = -O3 -fexceptions
+CC = %%CC%%
+CFLAGS = %%CFLAGS%%
@@ -15,7 +15,7 @@
# ranlib, and ar, for generating libraries
RANLIB = ranlib
-@@ -48,8 +48,8 @@
+@@ -49,8 +49,8 @@
MV = mv -f
# Fortran compiler (not normally required)
@@ -26,18 +26,18 @@
F77LIB =
# C and Fortran libraries
-@@ -89,8 +89,8 @@
- # BLAS = -lgoto -lgfortran -lgfortranbegin -lg2c
+@@ -91,8 +91,8 @@
+ # naming the BLAS and LAPACK library (*.a or *.so) files.
# This is probably slow ... it might connect to the Standard Reference BLAS:
--BLAS = -lblas -lgfortran -lgfortranbegin -lg2c
+-BLAS = -lblas -lgfortran
-LAPACK = -llapack
+BLAS = %%BLAS%% %%FORTRANRUNTIME%%
+LAPACK = %%LAPACK%%
- # Using non-optimized versions:
- # BLAS = -lblas_plain -lgfortran -lgfortranbegin -lg2c
-@@ -122,8 +122,8 @@
+ # NOTE: this next option for the "Goto BLAS" has nothing to do with a "goto"
+ # statement. Rather, the Goto BLAS is written by Dr. Kazushige Goto.
+@@ -132,8 +132,8 @@
# The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
# You may wish to use an absolute path. METIS is optional. Compile
# CHOLMOD with -DNPARTITION if you do not wish to use METIS.
@@ -48,7 +48,7 @@
# If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
# options:
-@@ -184,7 +184,7 @@
+@@ -194,7 +194,7 @@
# -DNSUNPERF for Solaris only. If defined, do not use the Sun
# Performance Library
@@ -57,7 +57,7 @@
#------------------------------------------------------------------------------
# SuiteSparseQR configuration:
-@@ -198,7 +198,7 @@
+@@ -208,7 +208,7 @@
# -DHAVE_TBB enable the use of Intel's Threading Building Blocks (TBB)
# default, without timing, without TBB:
@@ -66,19 +66,16 @@
# with timing and TBB:
# SPQR_CONFIG = -DTIMING -DHAVE_TBB
# with timing
-@@ -220,15 +220,15 @@
-
- # Using default compilers:
- # CC = gcc
--CFLAGS = -O3 -fexceptions
-+# CFLAGS = -O3 -fexceptions
+@@ -237,18 +237,18 @@
# alternatives:
# CFLAGS = -g -fexceptions \
- -Wall -W -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
+- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi \
+- -funit-at-a-time
+# -Wall -W -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
++# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi \
++# -funit-at-a-time
# CFLAGS = -O3 -fexceptions \
- -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
@@ -87,4 +84,11 @@
# CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
# CFLAGS = -O3
# CFLAGS = -O3 -g -fexceptions
-
+ # CFLAGS = -g -fexceptions \
+- -Wall -W -Wshadow \
+- -Wredundant-decls -Wdisabled-optimization -ansi
++# -Wall -W -Wshadow \
++# -Wredundant-decls -Wdisabled-optimization -ansi
+
+ # consider:
+ # -fforce-addr -fmove-all-movables -freduce-all-givs -ftsp-ordering