aboutsummaryrefslogtreecommitdiff
path: root/math/sundials
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-27 07:47:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-27 07:47:30 +0000
commit2a3f43cb6b9c094d6cfecae772117a63620777f7 (patch)
treeeccb4ef6314e0cb5c8d4a822f80fa56dc88164da /math/sundials
parentf02e9b1855dc11dfa3de0a0a24519c758caea34a (diff)
downloadports-2a3f43cb6b9c094d6cfecae772117a63620777f7.tar.gz
ports-2a3f43cb6b9c094d6cfecae772117a63620777f7.zip
Notes
Diffstat (limited to 'math/sundials')
-rw-r--r--math/sundials/Makefile82
-rw-r--r--math/sundials/distinfo3
-rw-r--r--math/sundials/files/patch-config_SundialsBlas.cmake10
-rw-r--r--math/sundials/files/patch-config_SundialsFortran.cmake15
-rw-r--r--math/sundials/files/patch-config_SundialsFortran90.cmake15
-rw-r--r--math/sundials/files/patch-config_SundialsLapack.cmake10
-rw-r--r--math/sundials/files/patch-src_arkode_CMakeLists.txt22
-rw-r--r--math/sundials/files/patch-src_cvode_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_cvodes_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_ida_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_idas_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_kinsol_CMakeLists.txt21
-rw-r--r--math/sundials/pkg-descr11
-rw-r--r--math/sundials/pkg-plist137
14 files changed, 410 insertions, 0 deletions
diff --git a/math/sundials/Makefile b/math/sundials/Makefile
new file mode 100644
index 000000000000..48c5d5368d2f
--- /dev/null
+++ b/math/sundials/Makefile
@@ -0,0 +1,82 @@
+# $FreeBSD$
+
+PORTNAME= sundials
+DISTVERSION= 3.1.0
+CATEGORIES= math
+MASTER_SITES= https://computation.llnl.gov/projects/sundials/download/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= SUite of Nonlinear and DIfferential/ALgebraic Equation Solvers
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource,noninja python:build # ninja doesn't support fortran
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DPTHREAD_ENABLE:BOOL=ON \
+ -DBUILD_STATIC_LIBS:BOOL=OFF
+
+PLIST_SUB= SHL3=${DISTVERSION} SHL1=${DISTVERSION:R:R} SHLX3=1.1.0 SHLX1=1 SHLY3=2.1.0 SHLY1=2
+
+OPTIONS_DEFINE= BLAS EXAMPLES LAPACK MPI SUPERLUMT # OPENMP detection is broken in cmake: https://gitlab.kitware.com/cmake/cmake/issues/17474
+OPTIONS_GROUP= VECTORS
+OPTIONS_GROUP_VECTORS= HYPRE PETSC
+VECTORS_DESC= Alternative vector libraries
+BLAS_DESC= Enable BLAS support
+HYPRE_DESC= HYPRE vectors support (also enables MPI)
+LAPACK_DESC= Use Lapack linear algebra (sets SUNDIALS_INDEX_TYPE=int32)
+PETSC_DESC= PETSc vectors support (also enables MPI)
+SUPERLUMT_DESC= Sparse matrix factorization through SUPERLUMT
+OPTIONS_SUB= yes
+
+BLAS_CMAKE_BOOL= BLAS_ENABLE
+BLAS_USES= blaslapack:openblas fortran
+BLAS_CMAKE_ON= -DFREEBSD_GCC_DIR:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT:S/.//} # assumes that fortran:gcc is used
+
+EXAMPLES_CMAKE_BOOL= EXAMPLES_ENABLE_C EXAMPLES_ENABLE_CXX EXAMPLES_ENABLE_F77 EXAMPLES_ENABLE_F90
+EXAMPLES_CMAKE_ON= -DEXAMPLES_INSTALL_PATH=${EXAMPLESDIR}
+
+HYPRE_CMAKE_BOOL= HYPRE_ENABLE
+HYPRE_CMAKE_ON= -DHYPRE_INCLUDE_DIR=${LOCALBASE}/include \
+ -DHYPRE_LIBRARY_DIR=${LOCALBASE}/lib \
+ -DMPI_ENABLE:BOOL=ON
+HYPRE_LIB_DEPENDS= libHYPRE.so:science/hypre
+
+LAPACK_USES= blaslapack:openblas fortran
+LAPACK_CMAKE_BOOL= LAPACK_ENABLE
+LAPACK_CMAKE_ON= -DSUNDIALS_INDEX_TYPE:STRING=int32_t \
+ -DFREEBSD_GCC_DIR:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT:S/.//} # assumes that fortran:gcc is used
+
+MPI_CMAKE_ON= -DMPI_ENABLE:BOOL=ON
+
+PETSC_CMAKE_BOOL= PETSC_ENABLE
+PETSC_CMAKE_ON= -DPETSC_INCLUDE_DIR=${LOCALBASE}/include \
+ -DPETSC_LIBRARY_DIR=${LOCALBASE}/lib \
+ -DMPI_ENABLE:BOOL=ON
+PETSC_LIB_DEPENDS= libpetsc.so:science/PETSc
+
+SUPERLU_CMAKE_BOOL= SUPERLUMT_ENABLE
+SUPERLU_CMAKE_ON= -DSUPERLUMT_INCLUDE_DIR=${LOCALBASE}/include/superlu_mt \
+ -DSUPERLUMT_LIBRARY_DIR=${LOCALBASE}/lib \
+ -DSUPERLUMT_THREAD_TYPE=Pthread
+SUPERLUMT_DEPENDS= libsuperlu_mt_PTHREAD.so:math/superlu_mt
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMPI} || ${PORT_OPTIONS:MHYPRE} || ${PORT_OPTIONS:MPETSC}
+LIB_DEPENDS+= libmpich.so:net/mpich2
+
+PLIST_FILES= include/nvector/nvector_parallel.h \
+ include/sundials/sundials_mpi_types.h \
+ lib/libsundials_nvecparallel.so \
+ lib/libsundials_nvecparallel.so.${DISTVERSION:R:R} \
+ lib/libsundials_nvecparallel.so.${DISTVERSION}
+.endif
+
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/LICENSE
+
+.include <bsd.port.mk>
diff --git a/math/sundials/distinfo b/math/sundials/distinfo
new file mode 100644
index 000000000000..8803953a0a86
--- /dev/null
+++ b/math/sundials/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514338444
+SHA256 (sundials-3.1.0.tar.gz) = 18d52f8f329626f77b99b8bf91e05b7d16b49fde2483d3a0ea55496ce4cdd43a
+SIZE (sundials-3.1.0.tar.gz) = 13033516
diff --git a/math/sundials/files/patch-config_SundialsBlas.cmake b/math/sundials/files/patch-config_SundialsBlas.cmake
new file mode 100644
index 000000000000..74a9406d0ff4
--- /dev/null
+++ b/math/sundials/files/patch-config_SundialsBlas.cmake
@@ -0,0 +1,10 @@
+--- config/SundialsBlas.cmake.orig 2017-11-07 23:47:45 UTC
++++ config/SundialsBlas.cmake
+@@ -74,6 +74,7 @@ if(BLAS_LIBRARIES)
+
+ # Attempt to link the "ltest" executable
+ try_compile(LTEST_OK ${BlasTest_DIR} ${BlasTest_DIR}
++ LINK_DIRECTORIES ${FREEBSD_GCC_DIR}
+ ltest OUTPUT_VARIABLE MY_OUTPUT)
+
+ # To ensure we do not use stuff from the previous attempts,
diff --git a/math/sundials/files/patch-config_SundialsFortran.cmake b/math/sundials/files/patch-config_SundialsFortran.cmake
new file mode 100644
index 000000000000..561332abb4ba
--- /dev/null
+++ b/math/sundials/files/patch-config_SundialsFortran.cmake
@@ -0,0 +1,15 @@
+--- config/SundialsFortran.cmake.orig 2017-11-07 23:47:45 UTC
++++ config/SundialsFortran.cmake
+@@ -51,9 +51,9 @@ if(CMAKE_Fortran_COMPILER)
+ (NOT "${ENV_FCFLAGS}" STREQUAL "") AND
+ ("${CMAKE_Fortran_FLAGS}" STREQUAL ""))
+ # check if environment variables are equal
+- IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
+- PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
+- ENDIF()
++ #IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
++ # PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
++ #ENDIF()
+ ENDIF()
+
+ # Enable the language for next steps
diff --git a/math/sundials/files/patch-config_SundialsFortran90.cmake b/math/sundials/files/patch-config_SundialsFortran90.cmake
new file mode 100644
index 000000000000..081d9cbc4dc5
--- /dev/null
+++ b/math/sundials/files/patch-config_SundialsFortran90.cmake
@@ -0,0 +1,15 @@
+--- config/SundialsFortran90.cmake.orig 2017-11-07 23:47:45 UTC
++++ config/SundialsFortran90.cmake
+@@ -35,9 +35,9 @@ if(CMAKE_Fortran_COMPILER)
+ (NOT "${ENV_FCFLAGS}" STREQUAL "") AND
+ ("${CMAKE_Fortran_FLAGS}" STREQUAL ""))
+ # check if environment variables are equal
+- IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
+- PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
+- ENDIF()
++ #IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
++ # PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
++ #ENDIF()
+ ENDIF()
+
+ # Enable the language for next steps
diff --git a/math/sundials/files/patch-config_SundialsLapack.cmake b/math/sundials/files/patch-config_SundialsLapack.cmake
new file mode 100644
index 000000000000..248f4d07f0cf
--- /dev/null
+++ b/math/sundials/files/patch-config_SundialsLapack.cmake
@@ -0,0 +1,10 @@
+--- config/SundialsLapack.cmake.orig 2017-11-07 23:47:45 UTC
++++ config/SundialsLapack.cmake
+@@ -75,6 +75,7 @@ if(LAPACK_LIBRARIES)
+
+ # Attempt to link the "ltest" executable
+ try_compile(LTEST_OK ${LapackTest_DIR} ${LapackTest_DIR}
++ LINK_DIRECTORIES ${FREEBSD_GCC_DIR}
+ ltest OUTPUT_VARIABLE MY_OUTPUT)
+
+ # To ensure we do not use stuff from the previous attempts,
diff --git a/math/sundials/files/patch-src_arkode_CMakeLists.txt b/math/sundials/files/patch-src_arkode_CMakeLists.txt
new file mode 100644
index 000000000000..93a9caa23adf
--- /dev/null
+++ b/math/sundials/files/patch-src_arkode_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- src/arkode/CMakeLists.txt.orig 2017-11-07 23:47:45 UTC
++++ src/arkode/CMakeLists.txt
+@@ -112,6 +112,19 @@ IF(BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(sundials_arkode_shared m)
+ ENDIF()
+
++
++ IF(UNIX)
++ TARGET_LINK_LIBRARIES(sundials_arkode_shared m)
++ ENDIF()
++
++ IF(LAPACK_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_arkode_shared ${LAPACK_LIBRARIES})
++ ENDIF()
++
++ IF(KLU_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_arkode_shared ${KLU_LIBRARIES})
++ ENDIF ()
++
+ # Set the library name and make sure it is not deleted
+ SET_TARGET_PROPERTIES(sundials_arkode_shared
+ PROPERTIES OUTPUT_NAME sundials_arkode CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_cvode_CMakeLists.txt b/math/sundials/files/patch-src_cvode_CMakeLists.txt
new file mode 100644
index 000000000000..03b9411207cf
--- /dev/null
+++ b/math/sundials/files/patch-src_cvode_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- src/cvode/CMakeLists.txt.orig 2017-11-07 23:47:57 UTC
++++ src/cvode/CMakeLists.txt
+@@ -114,6 +114,18 @@ IF(BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(sundials_cvode_shared m)
+ ENDIF()
+
++ IF(UNIX)
++ TARGET_LINK_LIBRARIES(sundials_cvode_shared m)
++ ENDIF()
++
++ IF(LAPACK_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_cvode_shared ${LAPACK_LIBRARIES})
++ ENDIF()
++
++ IF(KLU_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_cvode_shared ${KLU_LIBRARIES})
++ ENDIF ()
++
+ # Set the library name and make sure it is not deleted
+ SET_TARGET_PROPERTIES(sundials_cvode_shared
+ PROPERTIES OUTPUT_NAME sundials_cvode CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_cvodes_CMakeLists.txt b/math/sundials/files/patch-src_cvodes_CMakeLists.txt
new file mode 100644
index 000000000000..9cc862d4f65d
--- /dev/null
+++ b/math/sundials/files/patch-src_cvodes_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- src/cvodes/CMakeLists.txt.orig 2017-11-07 23:48:01 UTC
++++ src/cvodes/CMakeLists.txt
+@@ -116,6 +116,18 @@ IF(BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared m)
+ ENDIF()
+
++ IF(UNIX)
++ TARGET_LINK_LIBRARIES(sundials_cvodes_shared m)
++ ENDIF()
++
++ IF(LAPACK_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_cvodes_shared ${LAPACK_LIBRARIES})
++ ENDIF()
++
++ IF(KLU_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_cvodes_shared ${KLU_LIBRARIES})
++ ENDIF()
++
+ # Set the library name and make sure it is not deleted
+ SET_TARGET_PROPERTIES(sundials_cvodes_shared
+ PROPERTIES OUTPUT_NAME sundials_cvodes CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_ida_CMakeLists.txt b/math/sundials/files/patch-src_ida_CMakeLists.txt
new file mode 100644
index 000000000000..b44f0c2b63a6
--- /dev/null
+++ b/math/sundials/files/patch-src_ida_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- src/ida/CMakeLists.txt.orig 2017-11-07 23:48:06 UTC
++++ src/ida/CMakeLists.txt
+@@ -117,6 +117,18 @@ IF(BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(sundials_ida_shared m)
+ ENDIF()
+
++ IF(UNIX)
++ TARGET_LINK_LIBRARIES(sundials_ida_shared m)
++ ENDIF()
++
++ IF(LAPACK_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_ida_shared ${LAPACK_LIBRARIES})
++ ENDIF()
++
++ IF(KLU_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_ida_shared ${KLU_LIBRARIES})
++ ENDIF()
++
+ # Set the library name and make sure it is not deleted
+ SET_TARGET_PROPERTIES(sundials_ida_shared
+ PROPERTIES OUTPUT_NAME sundials_ida CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_idas_CMakeLists.txt b/math/sundials/files/patch-src_idas_CMakeLists.txt
new file mode 100644
index 000000000000..473abaef7f15
--- /dev/null
+++ b/math/sundials/files/patch-src_idas_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- src/idas/CMakeLists.txt.orig 2017-11-07 23:48:10 UTC
++++ src/idas/CMakeLists.txt
+@@ -113,6 +113,18 @@ IF(BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(sundials_idas_shared m)
+ ENDIF()
+
++ IF(UNIX)
++ TARGET_LINK_LIBRARIES(sundials_idas_shared m)
++ ENDIF()
++
++ IF(LAPACK_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_idas_shared ${LAPACK_LIBRARIES})
++ ENDIF()
++
++ IF(KLU_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_idas_shared ${KLU_LIBRARIES})
++ ENDIF()
++
+ # Set the library name and make sure it is not deleted
+ SET_TARGET_PROPERTIES(sundials_idas_shared
+ PROPERTIES OUTPUT_NAME sundials_idas CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_kinsol_CMakeLists.txt b/math/sundials/files/patch-src_kinsol_CMakeLists.txt
new file mode 100644
index 000000000000..18ee03deee25
--- /dev/null
+++ b/math/sundials/files/patch-src_kinsol_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- src/kinsol/CMakeLists.txt.orig 2017-11-07 23:48:14 UTC
++++ src/kinsol/CMakeLists.txt
+@@ -110,6 +110,18 @@ IF(BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(sundials_kinsol_shared m)
+ ENDIF()
+
++ IF(UNIX)
++ TARGET_LINK_LIBRARIES(sundials_kinsol_shared m)
++ ENDIF()
++
++ IF(LAPACK_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_kinsol_shared ${LAPACK_LIBRARIES})
++ ENDIF()
++
++ IF(KLU_FOUND)
++ TARGET_LINK_LIBRARIES(sundials_kinsol_shared ${KLU_LIBRARIES})
++ ENDIF()
++
+ # Set the library name and make sure it is not deleted
+ SET_TARGET_PROPERTIES(sundials_kinsol_shared
+ PROPERTIES OUTPUT_NAME sundials_kinsol CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/pkg-descr b/math/sundials/pkg-descr
new file mode 100644
index 000000000000..47d0c58dd54e
--- /dev/null
+++ b/math/sundials/pkg-descr
@@ -0,0 +1,11 @@
+SUNDIALS is a SUite of Nonlinear and DIfferential/ALgebraic equation Solvers.
+It consists of the following six solvers: CVODE, solves initial value problems
+for ordinary differential equation (ODE) systems; CVODES, solves ODE systems and
+includes sensitivity analysis capabilities (forward and adjoint); ARKODE, solves
+initial value ODE problems with additive Runge-Kutta methods, include support
+for IMEX methods; IDA, solves initial value problems for differential-algebraic
+equation (DAE) systems; IDAS, solves DAE systems and includes sensitivity
+analysis capabilities (forward and adjoint); KINSOL, solves nonlinear algebraic
+systems.
+
+WWW: https://computation.llnl.gov/projects/sundials
diff --git a/math/sundials/pkg-plist b/math/sundials/pkg-plist
new file mode 100644
index 000000000000..79301da778d0
--- /dev/null
+++ b/math/sundials/pkg-plist
@@ -0,0 +1,137 @@
+include/arkode/arkode.h
+include/arkode/arkode_bandpre.h
+include/arkode/arkode_bbdpre.h
+include/arkode/arkode_direct.h
+include/arkode/arkode_impl.h
+include/arkode/arkode_spils.h
+include/cvode/cvode.h
+include/cvode/cvode_bandpre.h
+include/cvode/cvode_bbdpre.h
+include/cvode/cvode_diag.h
+include/cvode/cvode_direct.h
+include/cvode/cvode_impl.h
+include/cvode/cvode_spils.h
+include/cvodes/cvodes.h
+include/cvodes/cvodes_bandpre.h
+include/cvodes/cvodes_bbdpre.h
+include/cvodes/cvodes_diag.h
+include/cvodes/cvodes_direct.h
+include/cvodes/cvodes_impl.h
+include/cvodes/cvodes_spils.h
+include/ida/ida.h
+include/ida/ida_bbdpre.h
+include/ida/ida_direct.h
+include/ida/ida_impl.h
+include/ida/ida_spils.h
+include/idas/idas.h
+include/idas/idas_bbdpre.h
+include/idas/idas_direct.h
+include/idas/idas_impl.h
+include/idas/idas_spils.h
+include/kinsol/kinsol.h
+include/kinsol/kinsol_bbdpre.h
+include/kinsol/kinsol_direct.h
+include/kinsol/kinsol_impl.h
+include/kinsol/kinsol_spils.h
+%%HYPRE%%include/nvector/nvector_parhyp.h
+%%PETSC%%include/nvector/nvector_petsc.h
+include/nvector/nvector_pthreads.h
+include/nvector/nvector_serial.h
+include/sundials/sundials_band.h
+include/sundials/sundials_config.h
+include/sundials/sundials_dense.h
+include/sundials/sundials_direct.h
+include/sundials/sundials_fconfig.h
+include/sundials/sundials_fnvector.h
+include/sundials/sundials_iterative.h
+%%LAPACK%%include/sundials/sundials_lapack.h
+include/sundials/sundials_linearsolver.h
+include/sundials/sundials_math.h
+include/sundials/sundials_matrix.h
+include/sundials/sundials_nvector.h
+include/sundials/sundials_pcg.h
+include/sundials/sundials_sparse.h
+include/sundials/sundials_spbcgs.h
+include/sundials/sundials_spfgmr.h
+include/sundials/sundials_spgmr.h
+include/sundials/sundials_sptfqmr.h
+include/sundials/sundials_types.h
+include/sundials/sundials_version.h
+include/sunlinsol/sunlinsol_band.h
+include/sunlinsol/sunlinsol_dense.h
+%%LAPACK%%include/sunlinsol/sunlinsol_lapackband.h
+%%LAPACK%%include/sunlinsol/sunlinsol_lapackdense.h
+include/sunlinsol/sunlinsol_pcg.h
+include/sunlinsol/sunlinsol_spbcgs.h
+include/sunlinsol/sunlinsol_spfgmr.h
+include/sunlinsol/sunlinsol_spgmr.h
+include/sunlinsol/sunlinsol_sptfqmr.h
+include/sunmatrix/sunmatrix_band.h
+include/sunmatrix/sunmatrix_dense.h
+include/sunmatrix/sunmatrix_sparse.h
+lib/libsundials_arkode.so
+lib/libsundials_arkode.so.%%SHLY1%%
+lib/libsundials_arkode.so.%%SHLY3%%
+lib/libsundials_cvode.so
+lib/libsundials_cvode.so.%%SHL1%%
+lib/libsundials_cvode.so.%%SHL3%%
+lib/libsundials_cvodes.so
+lib/libsundials_cvodes.so.%%SHL1%%
+lib/libsundials_cvodes.so.%%SHL3%%
+lib/libsundials_ida.so
+lib/libsundials_ida.so.%%SHL1%%
+lib/libsundials_ida.so.%%SHL3%%
+lib/libsundials_idas.so
+lib/libsundials_idas.so.%%SHLY1%%
+lib/libsundials_idas.so.%%SHLY3%%
+lib/libsundials_kinsol.so
+lib/libsundials_kinsol.so.%%SHL1%%
+lib/libsundials_kinsol.so.%%SHL3%%
+%%HYPRE%%lib/libsundials_nvecparhyp.so
+%%HYPRE%%lib/libsundials_nvecparhyp.so.%%SHL1%%
+%%HYPRE%%lib/libsundials_nvecparhyp.so.%%SHL3%%
+%%PETSC%%lib/libsundials_nvecpetsc.so
+%%PETSC%%lib/libsundials_nvecpetsc.so.%%SHL1%%
+%%PETSC%%lib/libsundials_nvecpetsc.so.%%SHL3%%
+lib/libsundials_nvecpthreads.so
+lib/libsundials_nvecpthreads.so.%%SHL1%%
+lib/libsundials_nvecpthreads.so.%%SHL3%%
+lib/libsundials_nvecserial.so
+lib/libsundials_nvecserial.so.%%SHL1%%
+lib/libsundials_nvecserial.so.%%SHL3%%
+lib/libsundials_sunlinsolband.so
+lib/libsundials_sunlinsolband.so.%%SHLX1%%
+lib/libsundials_sunlinsolband.so.%%SHLX3%%
+lib/libsundials_sunlinsoldense.so
+lib/libsundials_sunlinsoldense.so.%%SHLX1%%
+lib/libsundials_sunlinsoldense.so.%%SHLX3%%
+%%LAPACK%%lib/libsundials_sunlinsollapackband.so
+%%LAPACK%%lib/libsundials_sunlinsollapackband.so.%%SHLX1%%
+%%LAPACK%%lib/libsundials_sunlinsollapackband.so.%%SHLX3%%
+%%LAPACK%%lib/libsundials_sunlinsollapackdense.so
+%%LAPACK%%lib/libsundials_sunlinsollapackdense.so.%%SHLX1%%
+%%LAPACK%%lib/libsundials_sunlinsollapackdense.so.%%SHLX3%%
+lib/libsundials_sunlinsolpcg.so
+lib/libsundials_sunlinsolpcg.so.%%SHLX1%%
+lib/libsundials_sunlinsolpcg.so.%%SHLX3%%
+lib/libsundials_sunlinsolspbcgs.so
+lib/libsundials_sunlinsolspbcgs.so.%%SHLX1%%
+lib/libsundials_sunlinsolspbcgs.so.%%SHLX3%%
+lib/libsundials_sunlinsolspfgmr.so
+lib/libsundials_sunlinsolspfgmr.so.%%SHLX1%%
+lib/libsundials_sunlinsolspfgmr.so.%%SHLX3%%
+lib/libsundials_sunlinsolspgmr.so
+lib/libsundials_sunlinsolspgmr.so.%%SHLX1%%
+lib/libsundials_sunlinsolspgmr.so.%%SHLX3%%
+lib/libsundials_sunlinsolsptfqmr.so
+lib/libsundials_sunlinsolsptfqmr.so.%%SHLX1%%
+lib/libsundials_sunlinsolsptfqmr.so.%%SHLX3%%
+lib/libsundials_sunmatrixband.so
+lib/libsundials_sunmatrixband.so.%%SHLX1%%
+lib/libsundials_sunmatrixband.so.%%SHLX3%%
+lib/libsundials_sunmatrixdense.so
+lib/libsundials_sunmatrixdense.so.%%SHLX1%%
+lib/libsundials_sunmatrixdense.so.%%SHLX3%%
+lib/libsundials_sunmatrixsparse.so
+lib/libsundials_sunmatrixsparse.so.%%SHLX1%%
+lib/libsundials_sunmatrixsparse.so.%%SHLX3%%