aboutsummaryrefslogtreecommitdiff
path: root/math/superlu/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-09 23:54:16 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-09 23:54:16 +0000
commitca657d2e574c39d6475818bfc97a413e4315845d (patch)
tree73af3969effa72b870deebf6536f40a3415d0226 /math/superlu/Makefile
parentf35424c0b2879af6d5480e4ec39adafb49224eba (diff)
downloadports-ca657d2e574c39d6475818bfc97a413e4315845d.tar.gz
ports-ca657d2e574c39d6475818bfc97a413e4315845d.zip
Initial import of SuperLU version 1.1.
A library of routines for performing sparse factorization. PR: 5131 Submitted by: Pedro Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=12384
Diffstat (limited to 'math/superlu/Makefile')
-rw-r--r--math/superlu/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
new file mode 100644
index 000000000000..98aa1f1dd584
--- /dev/null
+++ b/math/superlu/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: SuperLU
+# Version required: 1.1
+# Date created: 31 Oct 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $Id$
+#
+
+DISTNAME= superlu_1.1
+PKGNAME= superlu-1.1
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.cs.berkeley.edu/pub/src/lapack/SuperLU/ \
+ http://www.netlib.org/scalapack/prototype/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PREFIX}/lib/libblas.a:${PORTSDIR}/math/blas
+
+WRKSRC= ${WRKDIR}/SuperLU
+ALL_TARGET= superlulib
+#
+# NOTE: The Matlab interface was not built.
+#
+
+post-install:
+ $(INSTALL_DATA) ${WRKSRC}/libsuperlu.* ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/SuperLU
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL/*.ps ${PREFIX}/share/doc/SuperLU
+.endif
+.include <bsd.port.mk>