aboutsummaryrefslogtreecommitdiff
path: root/math/superlu
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-06 23:58:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-06 23:58:10 +0000
commit25fe464d1e6e899fbbcd04b8fab0bb3d66c287a6 (patch)
tree02bb9c718ffae5191247c5d7025b5278d55406e2 /math/superlu
parentddd73c4578d74ef2372b07d5cf2892cb3ab1b6c8 (diff)
downloadports-25fe464d1e6e899fbbcd04b8fab0bb3d66c287a6.tar.gz
ports-25fe464d1e6e899fbbcd04b8fab0bb3d66c287a6.zip
math/superlu: robert.ayrapetyan@gmail.com takes maintainership
Also removed the dysfunctional TEST option and added the do-test target that enables the 'make test'. PR: 228009 Submitted by: robert.ayrapetyan@gmail.com
Notes
Notes: svn path=/head/; revision=469258
Diffstat (limited to 'math/superlu')
-rw-r--r--math/superlu/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index 48286c6b70cc..c3b6c11cc6cb 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://crd-legacy.lbl.gov/~xiaoye/SuperLU/ \
DISTNAME= ${PORTNAME}_${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= robert.ayrapetyan@gmail.com
COMMENT= Library of routines for performing sparse factorization
LICENSE= BSD3CLAUSE
@@ -27,7 +27,7 @@ CMAKE_ARGS= -DUSE_XSDK_DEFAULTS:BOOL=ON \
PORTDOCS= *
-OPTIONS_DEFINE= DOCS TEST
+OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= BLAS
OPTIONS_SINGLE_BLAS= ATLAS GOTOBLAS OPENBLAS REFERENCE
OPTIONS_DEFAULT= REFERENCE
@@ -46,7 +46,6 @@ OPENBLAS_CMAKE_ARGS= -DBLA_VENDOR:STRING="OpenBLAS"
REFERENCE_DESC= Reference blas implementation
REFERENCE_USES= blaslapack
REFERENCE_CMAKE_ARGS= -DBLA_VENDOR:STRING="Generic"
-TEST_CMAKE_ARGS= -Denable_tests:BOOL=ON
SLU_DOCS= SLU_general.ps.gz simax-29176.pdf
@@ -63,4 +62,10 @@ post-install-DOCS-on:
(cd ${WRKSRC}/DOC && ${COPYTREE_SHARE} "html ug.pdf" \
${STAGEDIR}${DOCSDIR})
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Denable_tests:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
.include <bsd.port.mk>