aboutsummaryrefslogtreecommitdiff
path: root/math/superlu
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-10-12 17:50:28 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-10-12 17:50:28 +0000
commit11ebb6cabe8b32c6045a9711d712d6eced708bf2 (patch)
tree50294f3f99af7ba3d8a7fe5cb94318fd300dd4c0 /math/superlu
parentca88d4185442d186287d9694a0b5c4c8ae793b47 (diff)
downloadports-11ebb6cabe8b32c6045a9711d712d6eced708bf2.tar.gz
ports-11ebb6cabe8b32c6045a9711d712d6eced708bf2.zip
Notes
Diffstat (limited to 'math/superlu')
-rw-r--r--math/superlu/Makefile14
-rw-r--r--math/superlu/distinfo5
-rw-r--r--math/superlu/files/patch-SRC_CMakeLists.txt11
3 files changed, 20 insertions, 10 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index b49a51708070..ebf0bba1923b 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= superlu
-PORTVERSION= 5.2.0
+PORTVERSION= 5.2.1
CATEGORIES= math
MASTER_SITES= http://crd-legacy.lbl.gov/~xiaoye/SuperLU/ \
http://crd-legacy.lbl.gov/~xiaoye/:doc
@@ -16,11 +16,10 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/License.txt
USES= cmake:outsource fortran
-
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/SuperLU_${PORTVERSION}
-PLIST_SUB= P_VERSION="${P_VERSION}" P_VER="${P_VER}"
+PLIST_SUB= P_VERSION="${PORTVERSION}" P_VER="${PORTVERSION:R:R}"
CMAKE_ARGS= -DUSE_XSDK_DEFAULTS:BOOL=ON \
-Denable_examples:BOOL=OFF
@@ -29,7 +28,7 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS TEST
OPTIONS_SINGLE= BLAS
-OPTIONS_SINGLE_BLAS= ATLAS GOTOBLAS REFERENCE
+OPTIONS_SINGLE_BLAS= ATLAS GOTOBLAS OPENBLAS REFERENCE
OPTIONS_DEFAULT= REFERENCE
ATLAS_USES= blaslapack:atlas
@@ -40,13 +39,14 @@ DOCS_EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
GOTOBLAS_DESC= GotoBLAS blas implementation
GOTOBLAS_USES= blaslapack:gotoblas
GOTOBLAS_CMAKE_ARGS= -DBLA_VENDOR:STRING="Goto"
+OPENBLAS_DESC= OpenBLAS blas implementation
+OPENBLAS_USES= blaslapack:openblas
+OPENBLAS_CMAKE_ARGS= -DBLA_VENDOR:STRING="OpenBLAS"
REFERENCE_DESC= Reference blas implementation
REFERENCE_USES= blaslapack
REFERENCE_CMAKE_ARGS= -DBLA_VENDOR:STRING="Generic"
TEST_CMAKE_ARGS= -Denable_tests:BOOL=ON
-P_VERSION= 5.1.1
-P_VER= ${P_VERSION:C/^([[:alnum:]]+).*/\1/}
SLU_DOCS= SLU_general.ps.gz simax-29176.pdf
post-patch:
@@ -54,8 +54,6 @@ post-patch:
'/CMAKE_C_FLAGS_RELEASE/s|^|#|' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e \
'/FFLAGS/s|FATAL_ERROR|WARNING|' ${WRKSRC}/cmake/XSDKDefaults.cmake
- @${REINPLACE_CMD} -e \
- 's|\(/include\)$$|\1/superlu|' ${WRKSRC}/SRC/CMakeLists.txt
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/math/superlu/distinfo b/math/superlu/distinfo
index 1a30bd110555..c440a7461a72 100644
--- a/math/superlu/distinfo
+++ b/math/superlu/distinfo
@@ -1,5 +1,6 @@
-SHA256 (superlu/superlu_5.2.0.tar.gz) = 065bb8bfea79f5d3ec09c2d091ec79050fcfc123fb2f38818d95f4d8f9e7ff6c
-SIZE (superlu/superlu_5.2.0.tar.gz) = 2542410
+TIMESTAMP = 1476287508
+SHA256 (superlu/superlu_5.2.1.tar.gz) = 28fb66d6107ee66248d5cf508c79de03d0621852a0ddeba7301801d3d859f463
+SIZE (superlu/superlu_5.2.1.tar.gz) = 2560875
SHA256 (superlu/SLU_general.ps.gz) = 00d00cedfadd96a42014d22b30c0cc451a575d8d309774519068b11d4be1ebe5
SIZE (superlu/SLU_general.ps.gz) = 89463
SHA256 (superlu/simax-29176.pdf) = 1411a3976b932a834157064dbaf0cdda10763f321bae10eb6f18925432250226
diff --git a/math/superlu/files/patch-SRC_CMakeLists.txt b/math/superlu/files/patch-SRC_CMakeLists.txt
new file mode 100644
index 000000000000..239334f71229
--- /dev/null
+++ b/math/superlu/files/patch-SRC_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- SRC/CMakeLists.txt.orig 2016-05-22 15:58:44 UTC
++++ SRC/CMakeLists.txt
+@@ -241,6 +241,6 @@ install(TARGETS superlu
+ )
+
+ install(FILES ${headers}
+-# DESTINATION ${CMAKE_INSTALL_PREFIX}/include
+- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/include/superlu
++# DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ )