aboutsummaryrefslogtreecommitdiff
path: root/math/superlu_mt/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 13:18:17 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 13:18:17 +0000
commit999161a9ed97730daec86fd4a1472d43f1f3c106 (patch)
treef20c586b0416176f121176e4710700155b5cf9bf /math/superlu_mt/Makefile
parenta2636bcc7e88f570e1db12e44a992761fc891649 (diff)
Notes
Diffstat (limited to 'math/superlu_mt/Makefile')
-rw-r--r--math/superlu_mt/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index 8dc292b2256c..6ac91cd15e4e 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -97,7 +97,7 @@ do-build:
${FIND} ${WRKSRC_SHARED} -name "*\.a" -exec ${CP} {} ${WRKDIR}/tmp_shared \;
@cd ${WRKDIR}/tmp_shared ; for i in `ls *.a | ${SED} 's/\.a//' `; do \
${RM} -f $${i}.so.* $${i}.so ; \
- ${FC} ${CFLAGS} ${FPIC} ${LDFLAGS} -shared -o $${i}.so.${SVERSION} \
+ ${FC} ${CFLAGS} ${FPIC} ${LDFLAGS} -shared -o $${i}.so.${SVERSION} \
-Wl,-soname,$${i}.so.${SVERSION} -Wl,--allow-multiple-definition \
-Wl,--whole-archive $${i}.a -Wl,--no-whole-archive -Wl,--as-needed; \
${LN} -s $${i}.so.${SVERSION} $${i}.so ;\