aboutsummaryrefslogtreecommitdiff
path: root/math/superlu_mt
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-07-03 03:53:21 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-07-03 03:53:21 +0000
commitdb61eb1da2293457dbb490f7121067727739965d (patch)
treebc4cbae1a618fe3c85ea09760a1603e188fba2df /math/superlu_mt
parent120191c6b21e65f0722271ea7e402c6d7efe1d5f (diff)
downloadports-db61eb1da2293457dbb490f7121067727739965d.tar.gz
ports-db61eb1da2293457dbb490f7121067727739965d.zip
Notes
Diffstat (limited to 'math/superlu_mt')
-rw-r--r--math/superlu_mt/Makefile8
-rw-r--r--math/superlu_mt/files/patch-make.inc13
2 files changed, 8 insertions, 13 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index 64dfdc27f4b4..3c7ebe1550ca 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -50,8 +50,6 @@ FPIC= -fpic
.endif
USE_LDCONFIG= yes
USE_GMAKE= yes
-CFLAGS_SHARED=${CFLAGS} ${FPIC}
-FFLAGS_SHARED=${CFLAGS} ${FPIC}
WRKSRC= ${WRKDIR}/SuperLU_MT_2.0
WRKSRC_SHARED= ${WRKDIR}/SuperLU_MT_2.0_shared
ALL_TARGET= lib
@@ -71,14 +69,16 @@ post-patch:
s+%%CC%%+${CC}+; s+%%FC%%+${FC}+; \
s+%%CFLAGS%%+${CFLAGS}+; \
s+%%FFLAGS%%+${FFLAGS}+; \
+ s+%%FPIC%%++; \
s+%%PTHREAD_CFLAGS%%+${PTHREAD_CFLAGS}+ ; \
s+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+ ' \
${WRKSRC}/make.inc
@${REINPLACE_CMD} -e 's+%%BLAS_LIBS%%+-L${LOCALBASE}/lib ${BLAS_LIBS}+ ; \
s+%%CC%%+${CC}+; s+%%FC%%+${FC}+; \
- s+%%CFLAGS%%+${CFLAGS_SHARED}+; \
- s+%%FFLAGS%%+${FFLAGS_SHARED}+; \
+ s+%%CFLAGS%%+${CFLAGS} ${FPIC}+; \
+ s+%%FFLAGS%%+${FFLAGS} ${FPIC}+; \
+ s+%%FPIC%%+${FPIC}+; \
s+%%PTHREAD_CFLAGS%%+${PTHREAD_CFLAGS}+ ; \
s+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+ ' \
${WRKSRC_SHARED}/make.inc
diff --git a/math/superlu_mt/files/patch-make.inc b/math/superlu_mt/files/patch-make.inc
index c1b389011630..83adafa4f9d1 100644
--- a/math/superlu_mt/files/patch-make.inc
+++ b/math/superlu_mt/files/patch-make.inc
@@ -1,5 +1,5 @@
---- make.inc.orig 2008-01-18 05:53:51.000000000 +0900
-+++ make.inc 2008-07-02 09:44:04.000000000 +0900
+--- make.inc Fri Jan 18 05:53:51 2008
++++ make.inc Thu Jul 3 12:47:55 2008
@@ -16,13 +16,13 @@
#
# The machine (platform) identifier to append to the library names
@@ -30,7 +30,7 @@
# The archiver and the flag(s) to use when building archive (library)
# If your system has no ranlib, set RANLIB = echo.
-@@ -46,12 +46,12 @@
+@@ -46,16 +46,17 @@
PREDEFS = -D_PTHREAD
#
@@ -46,15 +46,10 @@
+FFLAGS = %%FFLAGS%%
+LOADER = %%FC%%
+LOADOPTS = -O
++NOOPTS = %%FPIC%%
#
# C preprocessor defs for compilation for the Fortran interface
# (-DNoChange, -DAdd_, -DAdd__, or -DUpCase)
-
---- make.inc~ 2008-07-02 09:54:57.000000000 +0900
-+++ make.inc 2008-07-02 09:57:28.000000000 +0900
-@@ -56,6 +56,6 @@
- # C preprocessor defs for compilation for the Fortran interface
- # (-DNoChange, -DAdd_, -DAdd__, or -DUpCase)
#
-CDEFS = -DNoChange
+CDEFS = -DAdd_