aboutsummaryrefslogtreecommitdiff
path: root/math/superlu_mt
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
commit004a7c5ac21475f760354371ae4f8fca5e556acb (patch)
tree47b9539be8bb171263921a641d850025fee218cc /math/superlu_mt
parentbcfacab8772c0f3bf72412386eb13f58def6bef2 (diff)
downloadports-004a7c5ac21475f760354371ae4f8fca5e556acb.tar.gz
ports-004a7c5ac21475f760354371ae4f8fca5e556acb.zip
Notes
Diffstat (limited to 'math/superlu_mt')
-rw-r--r--math/superlu_mt/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index 14c97e8e9646..94ae9bb34331 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -25,24 +25,24 @@ USE_FORTRAN= yes
.include <bsd.port.pre.mk>
-USE_BLAS?= reference
-
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-.if ${USE_BLAS} == reference
+.if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS= -lblas
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
BROKEN= Build stops while testing
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
+BLAS= -lptf77blas
.endif
.if ${ARCH} == "sparc64" || ${ARCH} == "amd64"