aboutsummaryrefslogtreecommitdiff
path: root/math/taucs/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 10:27:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 10:27:38 +0000
commitaa86583435780b2f9d5eda003686cb69e3f7262a (patch)
tree40bd2046539d593c2282ffcefd701cc992b014a4 /math/taucs/Makefile
parent5bfb94574dfc2f0a62a4e86faa7a58eeff7a0421 (diff)
Notes
Diffstat (limited to 'math/taucs/Makefile')
-rw-r--r--math/taucs/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
new file mode 100644
index 000000000000..8bd82508d8b7
--- /dev/null
+++ b/math/taucs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: taucs
+# Date created: 5 July 2003
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taucs
+PORTVERSION= 2.2
+CATEGORIES= math
+MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= C library of sparse linear solvers
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf77blas.a:${PORTSDIR}/math/atlas \
+ ${LOCALBASE}/lib/liblapack.a:${PORTSDIR}/math/lapack \
+ ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+
+NO_WRKSUBDIR= yes
+HAS_CONFIGURE= yes
+MAKEFILE= makefile
+ALL_TARGET=
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/FreeBSD/libtaucs.a ${PREFIX}/lib
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/direct ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/iter ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>