aboutsummaryrefslogtreecommitdiff
path: root/math/testu01
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-07 15:55:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-07 15:55:06 +0000
commit5d2e9071f41e960c34df8a60038fb6640400118a (patch)
tree9c6a1fd4ed779e769788ab6d0152c24b7bebb672 /math/testu01
parentff6be1f09f079332fff63d9c3623f1f9fba1199b (diff)
downloadports-5d2e9071f41e960c34df8a60038fb6640400118a.tar.gz
ports-5d2e9071f41e960c34df8a60038fb6640400118a.zip
Notes
Diffstat (limited to 'math/testu01')
-rw-r--r--math/testu01/Makefile47
-rw-r--r--math/testu01/distinfo6
-rw-r--r--math/testu01/pkg-descr22
-rw-r--r--math/testu01/pkg-plist149
4 files changed, 224 insertions, 0 deletions
diff --git a/math/testu01/Makefile b/math/testu01/Makefile
new file mode 100644
index 000000000000..077ca4e1366f
--- /dev/null
+++ b/math/testu01/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: rngstreams
+# Date created: 13 November 2008
+# Whom: bf <bf2006a@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TestU01
+PORTVERSION= 1.2.1
+CATEGORIES= math
+MASTER_SITES= http://www.iro.umontreal.ca/~simardr/testu01/:0 \
+ http://www.iro.umontreal.ca/~lecuyer/myftp/papers/:1
+DISTFILES= ${PORTNAME}${EXTRACT_SUFX}:0 testu01.pdf:1
+EXTRACT_ONLY= ${PORTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= Utilities for statistical testing of uniform random number generators
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4
+
+USE_ZIP= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --includedir="${PREFIX}/include/${PORTNAME}"
+USE_GMAKE= yes
+MAKE_ARGS= docdir="${DOCSDIR}" exdir="${EXAMPLESDIR}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+CLAGS+= -fPIC
+PLIST_SUB= PORTNAME="${PORTNAME}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^SUBDIRS \=/s/ doc / /' ${WRKSRC}/Makefile.in
+ @${FIND} -X ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} \
+ -e '/^install-data-am\: /s/install-docDATA//'
+.endif
+.ifdef(NOPORTEXAMPLES)
+ @${REINPLACE_CMD} -e '/^SUBDIRS \=/s/ examples / /' ${WRKSRC}/Makefile.in
+.endif
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${INSTALL_DATA} ${DISTDIR}/testu01.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/testu01/distinfo b/math/testu01/distinfo
new file mode 100644
index 000000000000..8d0881a95d97
--- /dev/null
+++ b/math/testu01/distinfo
@@ -0,0 +1,6 @@
+MD5 (TestU01.zip) = f4c017eab89d0867a70c0a7311552915
+SHA256 (TestU01.zip) = 044390799f1236cdad6c8704569d1a6ea056b871451dfeeca362e6a0377e2308
+SIZE (TestU01.zip) = 3306885
+MD5 (testu01.pdf) = 18ff5316e0ee24de4be16c9b0febda8f
+SHA256 (testu01.pdf) = 3a8efb1b6aa4a10c128a25e9ada0b5dacc83191abb5bebae94f6525dfd7f885d
+SIZE (testu01.pdf) = 466695
diff --git a/math/testu01/pkg-descr b/math/testu01/pkg-descr
new file mode 100644
index 000000000000..b1987296e54a
--- /dev/null
+++ b/math/testu01/pkg-descr
@@ -0,0 +1,22 @@
+TestU01 is a software library, implemented in the ANSI C language, and
+offering a collection of utilities for the empirical statistical testing
+of uniform random number generators.
+
+The library implements several types of random number generators in generic
+form, as well as many specific generators proposed in the literature or
+found in widely-used software. It provides general implementations of the
+classical statistical tests for random number generators, as well as several
+others proposed in the literature, and some original ones. These tests can
+be applied to the generators predefined in the library and to user-defined
+generators. Specific tests suites for either sequences of uniform random
+numbers in [0,1] or bit sequences are also available. Basic tools for
+plotting vectors of points produced by generators are provided as well.
+
+Additional software permits one to perform systematic studies of the
+interaction between a specific test and the structure of the point sets
+produced by a given family of random number generators. That is, for a given
+kind of test and a given class of random number generators, to determine how
+large should be the sample size of the test, as a function of the generator's
+period length, before the generator starts to fail the test systematically.
+
+WWW: http://www.iro.umontreal.ca/~simardr/testu01/tu01.html
diff --git a/math/testu01/pkg-plist b/math/testu01/pkg-plist
new file mode 100644
index 000000000000..9c7b3b862c1c
--- /dev/null
+++ b/math/testu01/pkg-plist
@@ -0,0 +1,149 @@
+bin/tcode
+include/%%PORTNAME%%/TestU01.h
+include/%%PORTNAME%%/addstr.h
+include/%%PORTNAME%%/bbattery.h
+include/%%PORTNAME%%/bitset.h
+include/%%PORTNAME%%/chrono.h
+include/%%PORTNAME%%/fbar.h
+include/%%PORTNAME%%/fcho.h
+include/%%PORTNAME%%/fcong.h
+include/%%PORTNAME%%/fdist.h
+include/%%PORTNAME%%/ffam.h
+include/%%PORTNAME%%/ffsr.h
+include/%%PORTNAME%%/finv.h
+include/%%PORTNAME%%/fknuth.h
+include/%%PORTNAME%%/fmarsa.h
+include/%%PORTNAME%%/fmass.h
+include/%%PORTNAME%%/fmultin.h
+include/%%PORTNAME%%/fnpair.h
+include/%%PORTNAME%%/fres.h
+include/%%PORTNAME%%/fspectral.h
+include/%%PORTNAME%%/fstring.h
+include/%%PORTNAME%%/ftab.h
+include/%%PORTNAME%%/fvaria.h
+include/%%PORTNAME%%/fwalk.h
+include/%%PORTNAME%%/gdef.h
+include/%%PORTNAME%%/gdefconf.h
+include/%%PORTNAME%%/gofs.h
+include/%%PORTNAME%%/gofw.h
+include/%%PORTNAME%%/mystr.h
+include/%%PORTNAME%%/num.h
+include/%%PORTNAME%%/num2.h
+include/%%PORTNAME%%/rijndael-alg-fst.h
+include/%%PORTNAME%%/scatter.h
+include/%%PORTNAME%%/scomp.h
+include/%%PORTNAME%%/sentrop.h
+include/%%PORTNAME%%/sknuth.h
+include/%%PORTNAME%%/smarsa.h
+include/%%PORTNAME%%/smultin.h
+include/%%PORTNAME%%/snpair.h
+include/%%PORTNAME%%/sres.h
+include/%%PORTNAME%%/sspacings.h
+include/%%PORTNAME%%/sspectral.h
+include/%%PORTNAME%%/sstring.h
+include/%%PORTNAME%%/statcoll.h
+include/%%PORTNAME%%/svaria.h
+include/%%PORTNAME%%/swalk.h
+include/%%PORTNAME%%/swrite.h
+include/%%PORTNAME%%/tables.h
+include/%%PORTNAME%%/tu01_sha1.h
+include/%%PORTNAME%%/uautomata.h
+include/%%PORTNAME%%/ubrent.h
+include/%%PORTNAME%%/ucarry.h
+include/%%PORTNAME%%/ucrypto.h
+include/%%PORTNAME%%/ucubic.h
+include/%%PORTNAME%%/udeng.h
+include/%%PORTNAME%%/ufile.h
+include/%%PORTNAME%%/ugfsr.h
+include/%%PORTNAME%%/ugranger.h
+include/%%PORTNAME%%/uinv.h
+include/%%PORTNAME%%/uknuth.h
+include/%%PORTNAME%%/ulcg.h
+include/%%PORTNAME%%/ulec.h
+include/%%PORTNAME%%/umarsa.h
+include/%%PORTNAME%%/umrg.h
+include/%%PORTNAME%%/unif01.h
+include/%%PORTNAME%%/unumrec.h
+include/%%PORTNAME%%/uquad.h
+include/%%PORTNAME%%/usoft.h
+include/%%PORTNAME%%/utaus.h
+include/%%PORTNAME%%/utezuka.h
+include/%%PORTNAME%%/util.h
+include/%%PORTNAME%%/utouzin.h
+include/%%PORTNAME%%/uvaria.h
+include/%%PORTNAME%%/uweyl.h
+include/%%PORTNAME%%/uwu.h
+include/%%PORTNAME%%/uxorshift.h
+include/%%PORTNAME%%/vectorsF2.h
+include/%%PORTNAME%%/wdist.h
+lib/libmylib.a
+lib/libmylib.la
+lib/libmylib.so.0
+lib/libmylib.so
+lib/libprobdist.a
+lib/libprobdist.la
+lib/libprobdist.so.0
+lib/libprobdist.so
+lib/libtestu01.a
+lib/libtestu01.la
+lib/libtestu01.so.0
+lib/libtestu01.so
+%%DATADIR%%/param/CombCubLCG.par
+%%DATADIR%%/param/CombCubic2.par
+%%DATADIR%%/param/CombL2.par
+%%DATADIR%%/param/CombWH2.par
+%%DATADIR%%/param/Cubic1.par
+%%DATADIR%%/param/InvExpl.par
+%%DATADIR%%/param/InvExpl2a.par
+%%DATADIR%%/param/InvExpl2b.par
+%%DATADIR%%/param/InvImpl.par
+%%DATADIR%%/param/InvImpl2a.par
+%%DATADIR%%/param/InvImpl2b.par
+%%DATADIR%%/param/LCGBad2.par
+%%DATADIR%%/param/LCGGood.par
+%%DATADIR%%/param/LCGGranger.par
+%%DATADIR%%/param/LCGPow2.par
+%%DATADIR%%/param/LCGWu2.par
+%%DATADIR%%/param/LFSR1.par
+%%DATADIR%%/param/LFSR2.par
+%%DATADIR%%/param/LFSR3.par
+%%DATADIR%%/param/MRG2.par
+%%DATADIR%%/param/MRG3.par
+%%DATADIR%%/param/TausLCG2.par
+%%PORTDOCS%%%%DOCSDIR%%/guidelongtestu01.pdf
+%%PORTDOCS%%%%DOCSDIR%%/guidemylib.pdf
+%%PORTDOCS%%%%DOCSDIR%%/guideprobdist.pdf
+%%PORTDOCS%%%%DOCSDIR%%/guideshorttestu01.pdf
+%%PORTDOCS%%%%DOCSDIR%%/testu01.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bat1.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bat1.res
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bat2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bat2.res
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bat3.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/birth1.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/birth1.res
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/birth2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex3.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex3.res
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex4.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex7.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/excel.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fbirth.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fbirth.res1.tex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fbirth.res2.tex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fcoll.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fcoll.res1.tex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fcoll.res2.tex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mrg32k3a.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/my16807.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/my16807.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scat.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scat2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vax.bin
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xorshift.c
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%/param
+@dirrm %%DATADIR%%
+@dirrm include/%%PORTNAME%%