aboutsummaryrefslogtreecommitdiff
path: root/math/timbl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-13 12:47:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-13 12:47:53 +0000
commit82a46c82341c70817a88d8f470029a5cfd633506 (patch)
tree2cb8b10cc918e9e50ba0c5d5cdca26bf5cae045f /math/timbl
parent14e52c655a67ccfd52d682f790fa7ffdfe6350bb (diff)
downloadports-82a46c82341c70817a88d8f470029a5cfd633506.tar.gz
ports-82a46c82341c70817a88d8f470029a5cfd633506.zip
The TiMBL software package is a fast, decision-tree-based implementation
of k-nearest neighbor classification. The package includes the IB1, IB2, TRIBL, TRIBL2, and IGTree algorithms, and offers various weighting metrics. WWW: http://ilk.uvt.nl/timbl/ PR: ports/121661 Submitted by: Yuri Victorovich <yuri at tsoft.com>
Notes
Notes: svn path=/head/; revision=208938
Diffstat (limited to 'math/timbl')
-rw-r--r--math/timbl/Makefile22
-rw-r--r--math/timbl/distinfo3
-rw-r--r--math/timbl/files/patch-demos_Makefile.in45
-rw-r--r--math/timbl/pkg-descr5
-rw-r--r--math/timbl/pkg-plist39
5 files changed, 114 insertions, 0 deletions
diff --git a/math/timbl/Makefile b/math/timbl/Makefile
new file mode 100644
index 000000000000..85894c978fba
--- /dev/null
+++ b/math/timbl/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: timbl
+# Date created: 13 March 2008
+# Whom: Yuri Victorovich <yuri@tsoft.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= timbl
+PORTVERSION= 6.1.2
+CATEGORIES= math
+MASTER_SITES= http://ilk.uvt.nl/downloads/pub/software/
+
+MAINTAINER= yuri@tsoft.com
+COMMENT= Tilburg Memory Based Learner
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/math/timbl/distinfo b/math/timbl/distinfo
new file mode 100644
index 000000000000..cc53526b79b6
--- /dev/null
+++ b/math/timbl/distinfo
@@ -0,0 +1,3 @@
+MD5 (timbl-6.1.2.tar.gz) = 14415a5864cbafd17307b5a3e1360b1d
+SHA256 (timbl-6.1.2.tar.gz) = 8384190a8e16b521785ed0713681c6359b3038f92aac502d9d54976171fd85a0
+SIZE (timbl-6.1.2.tar.gz) = 823951
diff --git a/math/timbl/files/patch-demos_Makefile.in b/math/timbl/files/patch-demos_Makefile.in
new file mode 100644
index 000000000000..139108287968
--- /dev/null
+++ b/math/timbl/files/patch-demos_Makefile.in
@@ -0,0 +1,45 @@
+--- demos/Makefile.in.orig 2008-03-12 17:15:02.000000000 -0700
++++ demos/Makefile.in 2008-03-12 17:22:05.000000000 -0700
+@@ -248,25 +248,25 @@
+ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ install-binPROGRAMS: $(bin_PROGRAMS)
+- @$(NORMAL_INSTALL)
+- test -z "$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
+- @list='$(bin_PROGRAMS)'; for p in $$list; do \
+- p1=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
+- if test -f $$p \
+- ; then \
+- f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
+- echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
+- $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
+- else :; fi; \
+- done
++ #@$(NORMAL_INSTALL)
++ #test -z "$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
++ #@list='$(bin_PROGRAMS)'; for p in $$list; do \
++ # p1=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
++ # if test -f $$p \
++ # ; then \
++ # f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
++ # echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
++ # $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
++ # else :; fi; \
++ #done
+
+ uninstall-binPROGRAMS:
+- @$(NORMAL_UNINSTALL)
+- @list='$(bin_PROGRAMS)'; for p in $$list; do \
+- f=`echo "$$p" | sed 's,^.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/'`; \
+- echo " rm -f '$(DESTDIR)$(bindir)/$$f'"; \
+- rm -f "$(DESTDIR)$(bindir)/$$f"; \
+- done
++ #@$(NORMAL_UNINSTALL)
++ #@list='$(bin_PROGRAMS)'; for p in $$list; do \
++ # f=`echo "$$p" | sed 's,^.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/'`; \
++ # echo " rm -f '$(DESTDIR)$(bindir)/$$f'"; \
++ # rm -f "$(DESTDIR)$(bindir)/$$f"; \
++ #done
+
+ clean-binPROGRAMS:
+ -test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
diff --git a/math/timbl/pkg-descr b/math/timbl/pkg-descr
new file mode 100644
index 000000000000..6ebdd8304a29
--- /dev/null
+++ b/math/timbl/pkg-descr
@@ -0,0 +1,5 @@
+The TiMBL software package is a fast, decision-tree-based implementation
+of k-nearest neighbor classification. The package includes the IB1, IB2,
+TRIBL, TRIBL2, and IGTree algorithms, and offers various weighting metrics.
+
+WWW: http://ilk.uvt.nl/timbl/
diff --git a/math/timbl/pkg-plist b/math/timbl/pkg-plist
new file mode 100644
index 000000000000..ab5367b10215
--- /dev/null
+++ b/math/timbl/pkg-plist
@@ -0,0 +1,39 @@
+bin/Timbl
+bin/TimblClient
+include/timbl/BestArray.h
+include/timbl/CommandLine.h
+include/timbl/Common.h
+include/timbl/GetOptClass.h
+include/timbl/IBtree.h
+include/timbl/Instance.h
+include/timbl/LogBuffer.h
+include/timbl/LogStream.h
+include/timbl/MBLClass.h
+include/timbl/MsgClass.h
+include/timbl/Options.h
+include/timbl/ServerProcs.h
+include/timbl/SocketBasics.h
+include/timbl/Statistics.h
+include/timbl/StringOps.h
+include/timbl/TimblAPI.h
+include/timbl/TimblExperiment.h
+include/timbl/Tree.h
+include/timbl/Trie.h
+include/timbl/Types.h
+include/timbl/neighborSet.h
+lib/libTimbl.a
+libdata/pkgconfig/timbl.pc
+%%DOCSDIR%%/Timbl_6.1_API.pdf
+%%DOCSDIR%%/Timbl_6.1_Manual.pdf
+%%DOCSDIR%%/examples/cross_val.test
+%%DOCSDIR%%/examples/dimin.script
+%%DOCSDIR%%/examples/dimin.test
+%%DOCSDIR%%/examples/dimin.train
+%%DOCSDIR%%/examples/small_1.train
+%%DOCSDIR%%/examples/small_2.train
+%%DOCSDIR%%/examples/small_3.train
+%%DOCSDIR%%/examples/small_4.train
+%%DOCSDIR%%/examples/small_5.train
+@dirrm %%DOCSDIR%%/examples
+@dirrm %%DOCSDIR%%
+@dirrm include/timbl