aboutsummaryrefslogtreecommitdiff
path: root/math/ufc/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-26 13:22:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-26 13:22:55 +0000
commitd2433644701219972f467913fc7db1aa13d47563 (patch)
tree2681eacf0d048fc6373f07c8cde86d463efed483 /math/ufc/Makefile
parent5903d536a5fde8b6524d35a8ed0862bf2c94ef36 (diff)
Notes
Diffstat (limited to 'math/ufc/Makefile')
-rw-r--r--math/ufc/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/ufc/Makefile b/math/ufc/Makefile
index 6550cd64242f..fd61bfa7a5c7 100644
--- a/math/ufc/Makefile
+++ b/math/ufc/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= ufc
-PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTVERSION= ${MMVERSION}.0
CATEGORIES= math python
-MASTER_SITES= http://launchpad.net/${PORTNAME}/2.0.x/${PORTVERSION}/+download/
+MASTER_SITES= http://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
MAINTAINER= jwbacon@tds.net
COMMENT= Unified framework for finite element assembly
@@ -19,12 +18,15 @@ USES= cmake
USE_PYTHON= -2.7
PYDISTUTILS_PKGNAME= ufc
+CMAKE_ARGS+= -DUFC_PKGCONFIG_DIR=${PREFIX}/libdata/pkgconfig
+
FETCH_ARGS= -F
+MMVERSION= 2.2
+
post-patch:
${REINPLACE_CMD} -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
${WRKSRC}/CMakeLists.txt
- ${REINPLACE_CMD} -i '' -e 's|"usr")|"usr", "local")|g' \
- ${WRKSRC}/src/utils/python/ufc_utils/build.py
+ ${REINPLACE_CMD} -i '' -e 's|os.path.join(os.path.sep, "usr")|os.path.normpath("${PREFIX}")|' ${WRKSRC}/src/utils/python/ufc_utils/build.py
.include <bsd.port.mk>