aboutsummaryrefslogtreecommitdiff
path: root/math/ump/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-05 09:13:30 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-05 09:13:30 +0000
commitf1fcae91f3b87c65c30e68b5a7d1f709081cf5dc (patch)
treef884adb552dc70cfc19e330cf6f4de157e95cf83 /math/ump/Makefile
parent9ec58cbea5c3739eaf9876ccc30df94481961cf6 (diff)
Add ump 0.8.3.2, a graphical, easy to use math program.
PR: 96110 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=161401
Diffstat (limited to 'math/ump/Makefile')
-rw-r--r--math/ump/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/math/ump/Makefile b/math/ump/Makefile
new file mode 100644
index 000000000000..4447e35978a5
--- /dev/null
+++ b/math/ump/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: ump
+# Date created: 2006-04-20
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ump
+PORTVERSION= 0.8.3.2
+CATEGORIES= math
+MASTER_SITES= http://home.swipnet.se/${PORTNAME}/downloads/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFX}
+
+MAINTAINER= nivit@email.it
+COMMENT= A graphical, easy to use math program
+
+CONFLICTS= ump-1.[0-9]*
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+USE_XLIB= yes
+USE_X_PREFIX= yes
+
+ALL_TARGET= ${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAKE_ENV+= CXX="${CXX}" CC="${CC}" DATADIR="${DATADIR}" \
+ X11BASE="${X11BASE}"
+
+FIND_DIRS= -type d
+FIND_DATA= -type f
+
+.if !defined(NOPORTDOCS)
+DOCSDIST= ${PORTNAME}-${PORTVERSION:C/\.[0-9]$//}-doc
+DISTFILES+= ${DOCSDIST}${EXTRACT_SUFX}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 503000
+IGNORE= requires trunc(3) and round(3)
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/main.cpp
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ump.conf ${PREFIX}/etc/ump.conf.dist
+.if !exists(${PREFIX}/etc/ump.conf)
+ ${INSTALL_DATA} ${WRKSRC}/ump.conf ${PREFIX}/etc
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKDIR}/${DOCSDIST} && ${FIND} . ${FIND_DIRS} \
+ -exec ${MKDIR} ${DOCSDIR}/{} \;
+ cd ${WRKDIR}/${DOCSDIST} && ${FIND} . ${FIND_DATA} \
+ -exec ${INSTALL_DATA} {} ${DOCSDIR} \;
+
+.endif
+
+.include <bsd.port.post.mk>