aboutsummaryrefslogtreecommitdiff
path: root/math/ump
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2006-11-08 12:55:59 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2006-11-08 12:55:59 +0000
commit7a6d1b993095b36db06d9d3d8409aaacba9e75cb (patch)
tree4d4e52152ff6894ae8760c47dc4427d231b34970 /math/ump
parent2736d5243e241c24d5265051443ca930b47c61ad (diff)
downloadports-7a6d1b993095b36db06d9d3d8409aaacba9e75cb.tar.gz
ports-7a6d1b993095b36db06d9d3d8409aaacba9e75cb.zip
Update to latest version.
PR: ports/105258 Submitted by: Nicola Vitale <nivit@email.it> (maintainer) Approved by: flz (mentor)
Notes
Notes: svn path=/head/; revision=176810
Diffstat (limited to 'math/ump')
-rw-r--r--math/ump/Makefile21
-rw-r--r--math/ump/distinfo9
-rw-r--r--math/ump/files/patch-Makefile87
-rw-r--r--math/ump/files/patch-src-main.cpp8
-rw-r--r--math/ump/pkg-plist65
5 files changed, 56 insertions, 134 deletions
diff --git a/math/ump/Makefile b/math/ump/Makefile
index 59977b9199f8..073b1ae52460 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= ump
-PORTVERSION= 0.8.4
+PORTVERSION= 0.8.5
CATEGORIES= math
-MASTER_SITES= http://home.swipnet.se/${PORTNAME}/downloads/ \
- http://nivi.interfree.it/distfiles/${PORTNAME}/
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFX}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= u-m-p
MAINTAINER= nivit@email.it
COMMENT= A graphical, easy to use math program
@@ -33,11 +32,6 @@ MAKE_ENV+= CXX="${CXX}" CC="${CC}" DATADIR="${DATADIR}" \
FIND_DIRS= -type d
FIND_DATA= -type f
-.if !defined(NOPORTDOCS)
-DOCSDIST= ${PORTNAME}-${PORTVERSION}-doc
-DISTFILES+= ${PORTNAME}-documentation${EXTRACT_SUFX}
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 503000
@@ -53,13 +47,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ump.conf ${PREFIX}/etc
.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKDIR}/${DOCSDIST} && ${FIND} . ${FIND_DIRS} \
- -exec ${MKDIR} ${DOCSDIR}/{} \;
- cd ${WRKDIR}/${DOCSDIST} && ${FIND} . ${FIND_DATA} \
- -exec ${INSTALL_DATA} {} ${DOCSDIR} \;
-
-.endif
-
.include <bsd.port.post.mk>
diff --git a/math/ump/distinfo b/math/ump/distinfo
index 84eeac1827e9..406b6c9a2b2a 100644
--- a/math/ump/distinfo
+++ b/math/ump/distinfo
@@ -1,6 +1,3 @@
-MD5 (ump-0.8.4-src.tar.bz2) = e33d98078ddd407d72a3bdebcd2d73da
-SHA256 (ump-0.8.4-src.tar.bz2) = 9c985e00ce4153e0c51104e1827fe27aac22ef4280bb4659b2c744793e5ecf54
-SIZE (ump-0.8.4-src.tar.bz2) = 131645
-MD5 (ump-documentation.tar.bz2) = 894df8966d7c76e1c765636c9352ee05
-SHA256 (ump-documentation.tar.bz2) = 11f648ae892a621b15c5e815a07c4fddfcb196a00ba12b30c5715a9b405f70db
-SIZE (ump-documentation.tar.bz2) = 67908
+MD5 (ump-0.8.5.tar.bz2) = 117ece27f5a64854d4a852ceb676bf86
+SHA256 (ump-0.8.5.tar.bz2) = c60aaac1b0f6426e0f4a67cf414ebb0a68aedf41e0cb89b041c3415fdac9c80f
+SIZE (ump-0.8.5.tar.bz2) = 146335
diff --git a/math/ump/files/patch-Makefile b/math/ump/files/patch-Makefile
index b4a69ff27818..7bda4aeff1fd 100644
--- a/math/ump/files/patch-Makefile
+++ b/math/ump/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile Sun Jul 9 12:51:41 2006
-+++ Makefile.port Mon Jul 10 14:07:04 2006
+--- Makefile Sat Oct 7 20:17:18 2006
++++ Makefile.port Tue Nov 7 22:14:53 2006
@@ -2,19 +2,19 @@
APP_NAME = ump
@@ -21,31 +21,32 @@
## You might have to change this path
-GL_LIB = -lGL -lGLU -L/usr/X11/lib
+GL_LIB = -lGL -lGLU -L$(X11BASE)/lib
+ ## The next path will be required on some Mac-systems to compile
+ ##FLAGS += -I/usr/X11/include/GL
-
- ## This will give auto completion in the main window, but it requires GTK+2.6
-@@ -25,7 +25,7 @@
+@@ -27,7 +27,7 @@
## Choose your optimization level
- ##FLAGS += -O0
+ ##FLAGS += -O1
-FLAGS += -O2
+##FLAGS += -O2
##FLAGS += -O3
##FLAGS += -Os
-@@ -40,8 +40,10 @@
+@@ -44,9 +44,10 @@
## Uncomment one or both of these if the compilation failes
## due to trunc undefined or log2 undefined
##FLAGS += -DDONT_HAVE_TRUNC
-##FLAGS += -DDONT_HAVE_LOG2
+-
+FLAGS += -DDONT_HAVE_LOG2
-+# X11 includes
++## X11 includes
+FLAGS += -I$(X11BASE)/include
-
## If you'd like to compile with debuging info avaliable
-@@ -87,7 +89,7 @@
+ ##FLAGS += -ggdb
+@@ -90,7 +91,7 @@
# $< means the name of the first prerequisite
$(APP_NAME): Makefile $(OBJ_FILES) main.o $(GUI_OBJ) addon_functions.o $(ASM_FILES)
@@ -54,7 +55,7 @@
clean:
-rm -f $(OBJ_FILES)
-@@ -99,18 +101,16 @@
+@@ -102,18 +103,16 @@
-rm -f inliner
text: Makefile $(OBJ_FILES) addon_functions.text.o $(ASM_FILES)
@@ -76,38 +77,38 @@
uninstall:
rm -f $(BIN_DIR)/$(APP_NAME)
-@@ -120,107 +120,107 @@
+@@ -123,108 +122,108 @@
- main.o: $(FILES) Makefile $(GUI_HEADER) $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/addon_functions.h $(SRC)/ump_3d_viewer.h
+ main.o: $(FILES) Makefile $(GUI_HEADER) $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h $(SRC)/addon_functions.h $(SRC)/ump_3d_viewer.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $(FILES) -o $@ -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\""
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $(FILES) -o $@ -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\""
- picture2gtk.o: $(SRC)/picture2gtk.cpp Makefile $(SRC)/picture2gtk.h $(SRC)/vartypes.h $(SRC)/picture.h
+ picture2gtk.o: $(SRC)/picture2gtk.cpp Makefile $(SRC)/picture2gtk.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_advancedwin.o: $(SRC)/ump_advancedwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/picture.h $(GUI_HEADER) $(SRC)/vartypes.h
+ ump_advancedwin.o: $(SRC)/ump_advancedwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/picture.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) $(AUTO_COMPLETION) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) $(AUTO_COMPLETION) -c $(GTK_CFLAGS) $< -o $@
- ump_3d_viewer.o: $(SRC)/ump_3d_viewer.cpp Makefile $(SRC)/ump_3d_viewer.h $(SRC)/main.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/picture.h $(SRC)/vartypes.h
+ ump_3d_viewer.o: $(SRC)/ump_3d_viewer.cpp Makefile $(SRC)/ump_3d_viewer.h $(SRC)/main.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/picture.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- ump_editor.o: $(SRC)/ump_editor.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h
+ ump_editor.o: $(SRC)/ump_editor.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_graphwin.o: $(SRC)/ump_graphwin.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vector.h $(SRC)/gradient_editor.h
+ ump_graphwin.o: $(SRC)/ump_graphwin.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vector.h $(SRC)/gradient_editor.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_prefwin.o: $(SRC)/ump_prefwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/picture.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/ump_picturewin.h
+ ump_prefwin.o: $(SRC)/ump_prefwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/picture.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/ump_picturewin.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_aboutwin.o: $(SRC)/ump_aboutwin.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h
+ ump_aboutwin.o: $(SRC)/ump_aboutwin.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
@@ -115,23 +116,23 @@
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- matrix_editor.o: $(SRC)/matrix_editor.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/picture.h
+ matrix_editor.o: $(SRC)/matrix_editor.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_picturewin.o: $(SRC)/ump_picturewin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/picture.h
+ ump_picturewin.o: $(SRC)/ump_picturewin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- addon_functions.o: $(SRC)/addon_functions.cpp Makefile $(SRC)/addon_functions.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/main.h $(SRC)/ump_picturewin.h
+ addon_functions.o: $(SRC)/addon_functions.cpp Makefile $(SRC)/addon_functions.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h $(SRC)/main.h $(SRC)/ump_picturewin.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- addon_functions.text.o: $(SRC)/addon_functions.cpp Makefile $(SRC)/addon_functions.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/main.h
+ addon_functions.text.o: $(SRC)/addon_functions.cpp Makefile $(SRC)/addon_functions.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h $(SRC)/main.h
- g++ $(FLAGS) -c -DNO_GTK $(SRC)/addon_functions.cpp -o $@
+ $(CXX) $(FLAGS) -c -DNO_GTK $(SRC)/addon_functions.cpp -o $@
- gradient_editor.o: $(SRC)/gradient_editor.cpp $(SRC)/gradient_editor.h $(SRC)/vector.h $(SRC)/vartypes.h $(SRC)/picture.h
+ gradient_editor.o: $(SRC)/gradient_editor.cpp $(SRC)/gradient_editor.h $(SRC)/vector.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
@@ -139,65 +140,69 @@
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- keyfile_io.o: $(SRC)/keyfile_io.cpp Makefile $(SRC)/vartypes.h
+ keyfile.o: $(SRC)/keyfile.cpp Makefile $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- picture.o: $(SRC)/picture.cpp Makefile $(SRC)/picture.h $(SRC)/vartypes.h
+ utf8_string.o: $(SRC)/utf8_string.cpp Makefile $(SRC)/utf8_string.h $(SRC)/vartypes.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- integer.o: $(SRC)/integer.cpp Makefile $(SRC)/integer.h $(SRC)/vartypes.h
+ picture.o: $(SRC)/picture.cpp Makefile $(SRC)/picture.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- real.o: $(SRC)/real.cpp Makefile $(SRC)/integer.h $(SRC)/real.h $(SRC)/vartypes.h
+ integer.o: $(SRC)/integer.cpp Makefile $(SRC)/integer.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- complex.o: $(SRC)/complex.cpp Makefile $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/complex.h $(SRC)/vartypes.h
+ real.o: $(SRC)/real.cpp Makefile $(SRC)/integer.h $(SRC)/real.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- matrix.o: $(SRC)/matrix.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/vartypes.h
+ complex.o: $(SRC)/complex.cpp Makefile $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/complex.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
+ matrix.o: $(SRC)/matrix.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h
+- g++ $(FLAGS) -c $< -o $@
++ $(CXX) $(FLAGS) -c $< -o $@
- math2.o: $(SRC)/math2.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/math2.intern.h $(SRC)/vartypes.h $(SRC)/picture.h
+
+ math2.o: $(SRC)/math2.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/math2.intern.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.picture.o: $(SRC)/math2.picture.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.picture.o: $(SRC)/math2.picture.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.variable.o: $(SRC)/math2.variable.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.variable.o: $(SRC)/math2.variable.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.variablelist.o: $(SRC)/math2.variablelist.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.variablelist.o: $(SRC)/math2.variablelist.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.functionlist.o: $(SRC)/math2.functionlist.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.functionlist.o: $(SRC)/math2.functionlist.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.builtin.o: $(SRC)/math2.builtin.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.builtin.o: $(SRC)/math2.builtin.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.codeline.o: $(SRC)/math2.codeline.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.codeline.o: $(SRC)/math2.codeline.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.codeblock.o: $(SRC)/math2.codeblock.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.codeblock.o: $(SRC)/math2.codeblock.cpp Makefile $(SRC)/vector.h $(SRC)/math2.intern.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
- math2.array.o: $(SRC)/math2.array.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h
+ math2.array.o: $(SRC)/math2.array.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/utf8_string.h $(SRC)/keyfile.h $(SRC)/picture.h
- g++ $(FLAGS) -c $< -o $@
+ $(CXX) $(FLAGS) -c $< -o $@
@@ -214,5 +219,3 @@
translation_svenska.o: translation_svenska.c
- gcc $< -c -o $@
+ $(CC) $< -c -o $@
-
-
diff --git a/math/ump/files/patch-src-main.cpp b/math/ump/files/patch-src-main.cpp
index 51870e795b28..23bd4c43252d 100644
--- a/math/ump/files/patch-src-main.cpp
+++ b/math/ump/files/patch-src-main.cpp
@@ -1,11 +1,11 @@
---- src/main.cpp Sun Jun 25 12:48:31 2006
-+++ src/main.cpp.port Mon Jul 10 14:08:33 2006
-@@ -682,7 +682,7 @@
+--- src/main.cpp Mon Oct 2 11:05:33 2006
++++ src/main.cpp.port Tue Nov 7 22:17:00 2006
+@@ -695,7 +695,7 @@
setup_file.replace_escape_sequences = true;
- try{ setup_file.read( DATA_DIR "/ump.conf" ); }
+ try{ setup_file.read( "%%PREFIX%%/etc/ump.conf" ); }
- catch(...) { }
+ catch(...) { std_settings = false; }
snprintf(filename,100,"%s/.ump",getenv("HOME"));
diff --git a/math/ump/pkg-plist b/math/ump/pkg-plist
index f2e3739cbfd6..85db01742565 100644
--- a/math/ump/pkg-plist
+++ b/math/ump/pkg-plist
@@ -2,66 +2,6 @@ bin/ump
@unexec if cmp -s %D/etc/ump.conf %D/etc/ump.conf.dist; then rm -f %D/etc/ump.conf; fi
etc/ump.conf.dist
@exec [ -f %B/ump.conf ] || cp %B/%f %B/ump.conf
-%%PORTDOCS%%%%DOCSDIR%%/_3d_get_prop.html
-%%PORTDOCS%%%%DOCSDIR%%/_3d_set_prop.html
-%%PORTDOCS%%%%DOCSDIR%%/abs.html
-%%PORTDOCS%%%%DOCSDIR%%/and.html
-%%PORTDOCS%%%%DOCSDIR%%/arg.html
-%%PORTDOCS%%%%DOCSDIR%%/array.html
-%%PORTDOCS%%%%DOCSDIR%%/color_matrix.html
-%%PORTDOCS%%%%DOCSDIR%%/constant_list.html
-%%PORTDOCS%%%%DOCSDIR%%/coordinate_matrix.html
-%%PORTDOCS%%%%DOCSDIR%%/cos.html
-%%PORTDOCS%%%%DOCSDIR%%/dec.html
-%%PORTDOCS%%%%DOCSDIR%%/degree.html
-%%PORTDOCS%%%%DOCSDIR%%/delete.html
-%%PORTDOCS%%%%DOCSDIR%%/e.html
-%%PORTDOCS%%%%DOCSDIR%%/equal.html
-%%PORTDOCS%%%%DOCSDIR%%/exit.html
-%%PORTDOCS%%%%DOCSDIR%%/factorize.html
-%%PORTDOCS%%%%DOCSDIR%%/fibonacci.html
-%%PORTDOCS%%%%DOCSDIR%%/frac.html
-%%PORTDOCS%%%%DOCSDIR%%/function_list.html
-%%PORTDOCS%%%%DOCSDIR%%/gcd.html
-%%PORTDOCS%%%%DOCSDIR%%/get_type.html
-%%PORTDOCS%%%%DOCSDIR%%/hello_world.html
-%%PORTDOCS%%%%DOCSDIR%%/i.html
-%%PORTDOCS%%%%DOCSDIR%%/iSqrt.html
-%%PORTDOCS%%%%DOCSDIR%%/im.html
-%%PORTDOCS%%%%DOCSDIR%%/incompatible.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/insert.html
-%%PORTDOCS%%%%DOCSDIR%%/intro.html
-%%PORTDOCS%%%%DOCSDIR%%/lcm.html
-%%PORTDOCS%%%%DOCSDIR%%/ln.html
-%%PORTDOCS%%%%DOCSDIR%%/log.html
-%%PORTDOCS%%%%DOCSDIR%%/log2.html
-%%PORTDOCS%%%%DOCSDIR%%/mandelbrot.html
-%%PORTDOCS%%%%DOCSDIR%%/matrix_editor.html
-%%PORTDOCS%%%%DOCSDIR%%/matrix_editor_left_inverse.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/matrix_editor_left_side.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/matrix_editor_result.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/matrix_editor_right_side.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/not.html
-%%PORTDOCS%%%%DOCSDIR%%/not_equal.html
-%%PORTDOCS%%%%DOCSDIR%%/or.html
-%%PORTDOCS%%%%DOCSDIR%%/pi.html
-%%PORTDOCS%%%%DOCSDIR%%/picture.html
-%%PORTDOCS%%%%DOCSDIR%%/programming.html
-%%PORTDOCS%%%%DOCSDIR%%/radian.html
-%%PORTDOCS%%%%DOCSDIR%%/rand.html
-%%PORTDOCS%%%%DOCSDIR%%/re.html
-%%PORTDOCS%%%%DOCSDIR%%/remove.html
-%%PORTDOCS%%%%DOCSDIR%%/sin.html
-%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/tan.html
-%%PORTDOCS%%%%DOCSDIR%%/time.html
-%%PORTDOCS%%%%DOCSDIR%%/top.html
-%%PORTDOCS%%%%DOCSDIR%%/true_false.html
-%%PORTDOCS%%%%DOCSDIR%%/ump_code.html
-%%PORTDOCS%%%%DOCSDIR%%/variable_types.html
-%%PORTDOCS%%%%DOCSDIR%%/void.html
-%%PORTDOCS%%%%DOCSDIR%%/xor.html
%%DATADIR%%/ump-files/Black.ump
%%DATADIR%%/ump-files/Blue.ump
%%DATADIR%%/ump-files/Gray.ump
@@ -81,9 +21,6 @@ etc/ump.conf.dist
%%DATADIR%%/ump-files/lcm.ump
%%DATADIR%%/ump-files/sign.ump
%%DATADIR%%/ump-files/trans.ump
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/constants
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/functions
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/pixmaps
@dirrm %%DATADIR%%/ump-files
@dirrm %%DATADIR%%