aboutsummaryrefslogtreecommitdiff
path: root/math/unuran/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2010-12-30 23:38:48 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2010-12-30 23:38:48 +0000
commit3a72b4d3d7a0d3b6b61e2af51589777e30135440 (patch)
tree39bb14b0741b354d2f1de3dafb556225372e807e /math/unuran/Makefile
parentacfa26a12d97a33d1b0a813e30a14cef2044cd19 (diff)
downloadports-3a72b4d3d7a0d3b6b61e2af51589777e30135440.tar.gz
ports-3a72b4d3d7a0d3b6b61e2af51589777e30135440.zip
Notes
Diffstat (limited to 'math/unuran/Makefile')
-rw-r--r--math/unuran/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
index d3bb9f02d779..026b9d3b4f1d 100644
--- a/math/unuran/Makefile
+++ b/math/unuran/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= unuran
-PORTVERSION= 1.7.1
+PORTVERSION= 1.8.0
CATEGORIES= math
MASTER_SITES= http://statmath.wu-wien.ac.at/unuran/ \
- LOCAL/wen
+ LOCAL/bf
MAINTAINER= bf@FreeBSD.org
COMMENT= Universal Non-Uniform RANdom number generators
LIB_DEPENDS= rngstreams:${PORTSDIR}/math/rngstreams
+LICENSE= GPLv2
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstream \
@@ -23,14 +24,15 @@ CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstr
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= MAKE="${GMAKE}"
USE_LDCONFIG= yes
INFO= unuran
PORTDOCS= unuran.pdf unuran.txt
post-patch:
- ${FIND} -X ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
- 's/sinclude/#sinclude/g'
+ ${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${GMAKE}/' \
+ ${WRKSRC}/Makefile.in
.ifndef(NOPORTDOCS)
post-install: