aboutsummaryrefslogtreecommitdiff
path: root/math/unuran
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:48:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:48:19 +0000
commit0579e8f00d5ddf972b759ac2d23c2de3e89c0613 (patch)
tree05f3453f5e3c5cf71a2c93cd94f19e15dd504498 /math/unuran
parent1cc19a81ad02e5d394b82cc07757d7d5b37fc7ca (diff)
downloadports-0579e8f00d5ddf972b759ac2d23c2de3e89c0613.tar.gz
ports-0579e8f00d5ddf972b759ac2d23c2de3e89c0613.zip
Notes
Diffstat (limited to 'math/unuran')
-rw-r--r--math/unuran/Makefile42
-rw-r--r--math/unuran/distinfo3
-rw-r--r--math/unuran/files/patch-doc_Makefile.in11
-rw-r--r--math/unuran/pkg-descr23
-rw-r--r--math/unuran/pkg-plist9
5 files changed, 88 insertions, 0 deletions
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
new file mode 100644
index 000000000000..fa8bb83860fc
--- /dev/null
+++ b/math/unuran/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: unuran
+# Date created: 13 November 2008
+# Whom: bf <bf2006a@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unuran
+PORTVERSION= 1.2.4
+CATEGORIES= math
+MASTER_SITES= http://statmath.wu-wien.ac.at/unuran/
+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= Universal Non-Uniform RANdom number generators
+
+LIB_DEPENDS= rngstreams:${PORTSDIR}/math/rngstreams
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstream \
+ --enable-info
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+INFO= unuran
+PORTDOCS= unuran.pdf unuran.txt
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for DD in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${DOCSDIR}
+.endfor
+.endif
+
+.ifdef(MAINTAINER_MODE)
+CONFIGURE_ARGS+= --enable-check-struct --enable-logging
+
+regression-test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check)
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/unuran/distinfo b/math/unuran/distinfo
new file mode 100644
index 000000000000..45ee73e87ccb
--- /dev/null
+++ b/math/unuran/distinfo
@@ -0,0 +1,3 @@
+MD5 (unuran-1.2.4.tar.gz) = 830c5c1fc62222f63dff34bce3295c08
+SHA256 (unuran-1.2.4.tar.gz) = 5c4adeaff517033dc2af22cbd9dd486fc9dc52e51ae1c189503cfd1e2d65a1d0
+SIZE (unuran-1.2.4.tar.gz) = 3145403
diff --git a/math/unuran/files/patch-doc_Makefile.in b/math/unuran/files/patch-doc_Makefile.in
new file mode 100644
index 000000000000..96a56fc0c3fc
--- /dev/null
+++ b/math/unuran/files/patch-doc_Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig 2008-11-14 16:43:07.846169643 -0500
++++ doc/Makefile.in 2008-11-14 16:43:34.409120521 -0500
+@@ -47,7 +47,7 @@
+ CONFIG_CLEAN_FILES =
+ SOURCES =
+ DIST_SOURCES =
+-INFO_DEPS = $(srcdir)/unuran.info $(srcdir)/unuran_win32.info
++INFO_DEPS = $(srcdir)/unuran.info
+ am__TEXINFO_TEX_DIR = $(srcdir)/./src
+ DVIS = unuran.dvi unuran_win32.dvi
+ PDFS = unuran.pdf unuran_win32.pdf
diff --git a/math/unuran/pkg-descr b/math/unuran/pkg-descr
new file mode 100644
index 000000000000..a708b3d5b7c4
--- /dev/null
+++ b/math/unuran/pkg-descr
@@ -0,0 +1,23 @@
+UNU.RAN (Universal Non-Uniform RAndom Number generator) is a collection of
+algorithms for generating non-uniform pseudorandom variates as a library of C
+functions designed and implemented by the ARVAG (Automatic Random VAriate
+Generation) project group in Vienna, and released under the GNU Public License
+(GPL). It is especially designed for situations where:
+
+- a non-standard distribution or a truncated distribution is needed;
+- experiments with different types of distributions are made;
+- random variates for variance reduction techniques are used; or
+- fast generators of predictable quality are necessary.
+
+UNU.RAN provides generators that are superior in many aspects to those found in
+quite a number of other libraries; however, due to its more sophisticated
+programming interface, it might not be as easy to use.
+
+It uses an object-oriented interface in which distributions and generators are
+treated as independent objects, so that different methods for generating
+non-uniform random variates may be chosen according to various criteria, such
+as speed, quality, and variance reduction. It is flexible enough to permit
+sampling from non-standard distributions, such as distributions that arise in
+a model and can only be computed in complicated subroutines.
+
+WWW: http://statmath.wu-wien.ac.at/unuran/
diff --git a/math/unuran/pkg-plist b/math/unuran/pkg-plist
new file mode 100644
index 000000000000..41253bb7603b
--- /dev/null
+++ b/math/unuran/pkg-plist
@@ -0,0 +1,9 @@
+include/unuran.h
+include/unuran_tests.h
+include/unuran_urng_gsl.h
+include/unuran_urng_prng.h
+include/unuran_urng_rngstreams.h
+lib/libunuran.a
+lib/libunuran.la
+lib/libunuran.so
+lib/libunuran.so.9