aboutsummaryrefslogtreecommitdiff
path: root/math/vowpal_wabbit
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2015-01-15 13:00:58 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2015-01-15 13:00:58 +0000
commit761e09d280cdf2cb1fdd0f80e8eef4b603736c47 (patch)
treea0df8e81014ea6429829bae81dfbbbd6b2cfcca3 /math/vowpal_wabbit
parentac7c2bc7f8110ab2388834b24084478553d4d3e5 (diff)
Notes
Diffstat (limited to 'math/vowpal_wabbit')
-rw-r--r--math/vowpal_wabbit/Makefile22
-rw-r--r--math/vowpal_wabbit/distinfo2
-rw-r--r--math/vowpal_wabbit/files/patch-vowpalwabbit-Makefile.in11
-rw-r--r--math/vowpal_wabbit/pkg-descr12
-rw-r--r--math/vowpal_wabbit/pkg-plist22
5 files changed, 69 insertions, 0 deletions
diff --git a/math/vowpal_wabbit/Makefile b/math/vowpal_wabbit/Makefile
new file mode 100644
index 000000000000..6eec527ee280
--- /dev/null
+++ b/math/vowpal_wabbit/Makefile
@@ -0,0 +1,22 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= vowpal_wabbit
+PORTVERSION= 7.9
+CATEGORIES= math
+MASTER_SITES= http://github.com/JohnLangford/vowpal_wabbit/archive/
+DISTFILES= ${PORTVERSION}${EXTRACT_SUFX}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Fast out-of-core learning system
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+
+USES= libtool
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS= --enable-shared=no --with-boost=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/math/vowpal_wabbit/distinfo b/math/vowpal_wabbit/distinfo
new file mode 100644
index 000000000000..f326d2cd62d7
--- /dev/null
+++ b/math/vowpal_wabbit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vowpal_wabbit/7.9.tar.gz) = 2e16eceed03ed624663044c28569aa52e387b8cd199445e953d13b05c0a1eaf9
+SIZE (vowpal_wabbit/7.9.tar.gz) = 8850729
diff --git a/math/vowpal_wabbit/files/patch-vowpalwabbit-Makefile.in b/math/vowpal_wabbit/files/patch-vowpalwabbit-Makefile.in
new file mode 100644
index 000000000000..f993af479ab0
--- /dev/null
+++ b/math/vowpal_wabbit/files/patch-vowpalwabbit-Makefile.in
@@ -0,0 +1,11 @@
+--- vowpalwabbit/Makefile.in.orig 2015-01-11 21:54:22.000000000 +0300
++++ vowpalwabbit/Makefile.in 2015-01-15 15:48:29.000000000 +0300
+@@ -85,7 +85,7 @@ bin_PROGRAMS = vw$(EXEEXT) active_intera
+ @NITPICK_TRUE@ -Wmissing-format-attribute -Wredundant-decls \
+ @NITPICK_TRUE@ -ansi -Wmissing-noreturn
+ @PARALLELIZE_TRUE@am__append_2 = -Wno-strict-aliasing -fopenmp
+-@FREEBSD_TRUE@am__append_3 = -l compat -Wall
++@FREEBSD_TRUE@am__append_3 = -lcompat -Wall
+ @FREEBSD_FALSE@am__append_4 = -Wall -pedantic
+ subdir = vowpalwabbit
+ DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
diff --git a/math/vowpal_wabbit/pkg-descr b/math/vowpal_wabbit/pkg-descr
new file mode 100644
index 000000000000..c053203d414e
--- /dev/null
+++ b/math/vowpal_wabbit/pkg-descr
@@ -0,0 +1,12 @@
+The Vowpal Wabbit (VW) project is a fast out-of-core learning system
+sponsored by Microsoft Research and (previously) Yahoo! Research.
+
+There are two ways to have a fast learning algorithm: (a) start with a slow
+algorithm and speed it up, or (b) build an intrinsically fast learning
+algorithm. This project is about approach (b), and it's reached a state
+where it may be useful to others as a platform for research and experimentation.
+
+There are several optimization algorithms available with the baseline
+being sparse gradient descent (GD) on a loss function (several are available).
+
+WWW: https://github.com/JohnLangford/vowpal_wabbit/wiki
diff --git a/math/vowpal_wabbit/pkg-plist b/math/vowpal_wabbit/pkg-plist
new file mode 100644
index 000000000000..229a65cbf230
--- /dev/null
+++ b/math/vowpal_wabbit/pkg-plist
@@ -0,0 +1,22 @@
+bin/active_interactor
+bin/library_example
+bin/spanning_tree
+bin/vw
+include/vowpalwabbit/allreduce.h
+include/vowpalwabbit/comp_io.h
+include/vowpalwabbit/config.h
+include/vowpalwabbit/example.h
+include/vowpalwabbit/global_data.h
+include/vowpalwabbit/hash.h
+include/vowpalwabbit/io_buf.h
+include/vowpalwabbit/learner.h
+include/vowpalwabbit/loss_functions.h
+include/vowpalwabbit/parse_primitives.h
+include/vowpalwabbit/parser.h
+include/vowpalwabbit/simple_label.h
+include/vowpalwabbit/v_array.h
+include/vowpalwabbit/vw.h
+include/vowpalwabbit/vwdll.h
+lib/liballreduce.a
+lib/libvw.a
+lib/libvw_c_wrapper.a