aboutsummaryrefslogtreecommitdiff
path: root/math/vtk-python
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-26 20:03:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-26 20:03:41 +0000
commit2bc3464d14d6b62ab53abebcbc35596a97cccec4 (patch)
tree9eddd0beaa3cee20fac5bdbacf02dec439b77bfb /math/vtk-python
parent1fab36bbe2aa96e1b7475c219ba58251309d097e (diff)
downloadports-2bc3464d14d6b62ab53abebcbc35596a97cccec4.tar.gz
ports-2bc3464d14d6b62ab53abebcbc35596a97cccec4.zip
Notes
Diffstat (limited to 'math/vtk-python')
-rw-r--r--math/vtk-python/Makefile61
-rw-r--r--math/vtk-python/pkg-plist179
2 files changed, 240 insertions, 0 deletions
diff --git a/math/vtk-python/Makefile b/math/vtk-python/Makefile
new file mode 100644
index 000000000000..9d1aeb5b6263
--- /dev/null
+++ b/math/vtk-python/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: vtk-python
+# Date created: 10 Oct 2003
+# Whom: Mykola Khotyaintsev <ko@irfu.se>
+#
+# $FreeBSD$
+#
+
+CATEGORIES+= python
+PKGNAMESUFFIX= -python
+
+COMMENT= The Visualization Toolkit Python libs
+
+LIB_DEPENDS= vtkCommon.${LIBVER}:${PORTSDIR}/math/vtk \
+ tcl84:${PORTSDIR}/lang/tcl84 \
+ tk84:${PORTSDIR}/x11-toolkits/tk84
+
+MASTERDIR= ${.CURDIR}/../vtk
+
+WRAP= Python
+BINARIES= vtkWrapPython vtkpython
+EXTRA_LIBS= RenderingPythonTkWidgets
+
+USE_PYTHON= yes
+TCL_INCLUDE_DIR=${PREFIX}/include/tcl8.4
+TK_INCLUDE_DIR= ${PREFIX}/include/tk8.4
+
+CXXFLAGS+= -DUSE_NON_CONST \
+ -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK \
+ -I${TCL_INCLUDE_DIR} # -Ds for TCL/TK 8.4, -I for libvtkRenderingPythonTkWidgets.so build
+
+LINKERFLAGS= -L${PREFIX}/lib # to link vtkpython to vtk libs
+
+CMAKE_DEFS= -DVTK_WRAP_PYTHON:BOOL=ON \
+ -DPYTHON_INCLUDE_PATH:PATH=${PYTHON_INCLUDEDIR} \
+ -DPYTHON_LIBRARY:FILEPATH=${PYTHON_LIBDIR}/config/lib${PYTHON_VERSION}.a \
+ -DTCL_INCLUDE_PATH:PATH=${TCL_INCLUDE_DIR} \
+ -DTK_INCLUDE_PATH:PATH=${TK_INCLUDE_DIR}
+
+PLIST_SUB+= VTK_PTH_LOCATION_DIR=${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"
+
+do-patch: patch-common
+
+do-install: install-cnotice install-binaries install-libs
+ @${ECHO_MSG} "Installing vtk site package to ${PREFIX}/lib/vtk/python ..."
+ @${MKDIR} ${PREFIX}/lib/vtk
+.for i in "" vtk/ vtk/gtk/ vtk/qt/ vtk/test/ vtk/tk/ vtk/util/ vtk/wx/
+ @${MKDIR} ${PREFIX}/lib/vtk/python/${i}
+ @${INSTALL_DATA} ${VTKSRCDIR}/Wrapping/Python/${i}*.py ${PREFIX}/lib/vtk/python/${i}
+.endfor
+ @${ECHO} ${PREFIX}/lib/vtk/python > ${PYTHON_SITELIBDIR}/vtk.pth
+ @${PYTHON_CMD} -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
+ @${PYTHON_CMD} -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
+
+.for i in ${VTK_KITS:S/$/Python/} ${EXTRA_LIBS}
+ @${LN} -sf ${PREFIX}/lib/libvtk${i}.so \
+ ${PREFIX}/lib/vtk/python/libvtk${i}.so
+.endfor
+
+.include <bsd.port.mk>
diff --git a/math/vtk-python/pkg-plist b/math/vtk-python/pkg-plist
new file mode 100644
index 000000000000..18f06fd0ab15
--- /dev/null
+++ b/math/vtk-python/pkg-plist
@@ -0,0 +1,179 @@
+bin/vtkWrapPython
+bin/vtkpython
+lib/libvtkCommonPython.so.%%LIBVER%%
+lib/libvtkCommonPython.so
+lib/libvtkFilteringPython.so.%%LIBVER%%
+lib/libvtkFilteringPython.so
+lib/libvtkGraphicsPython.so.%%LIBVER%%
+lib/libvtkGraphicsPython.so
+lib/libvtkHybridPython.so.%%LIBVER%%
+lib/libvtkHybridPython.so
+lib/libvtkIOPython.so.%%LIBVER%%
+lib/libvtkIOPython.so
+lib/libvtkImagingPython.so.%%LIBVER%%
+lib/libvtkImagingPython.so
+lib/libvtkParallelPython.so.%%LIBVER%%
+lib/libvtkParallelPython.so
+lib/libvtkPatentedPython.so.%%LIBVER%%
+lib/libvtkPatentedPython.so
+lib/libvtkRenderingPython.so.%%LIBVER%%
+lib/libvtkRenderingPython.so
+lib/libvtkRenderingPythonTkWidgets.so.%%LIBVER%%
+lib/libvtkRenderingPythonTkWidgets.so
+lib/vtk/python/QVTKRenderWidget.py
+lib/vtk/python/QVTKRenderWidget.pyc
+lib/vtk/python/QVTKRenderWidget.pyo
+lib/vtk/python/libvtkCommonPython.so
+lib/vtk/python/libvtkFilteringPython.so
+lib/vtk/python/libvtkGraphicsPython.so
+lib/vtk/python/libvtkHybridPython.so
+lib/vtk/python/libvtkIOPython.so
+lib/vtk/python/libvtkImagingPython.so
+lib/vtk/python/libvtkParallelPython.so
+lib/vtk/python/libvtkPatentedPython.so
+lib/vtk/python/libvtkRenderingPython.so
+lib/vtk/python/libvtkRenderingPythonTkWidgets.so
+lib/vtk/python/vtk/__helper.py
+lib/vtk/python/vtk/__helper.pyc
+lib/vtk/python/vtk/__helper.pyo
+lib/vtk/python/vtk/__init__.py
+lib/vtk/python/vtk/__init__.pyc
+lib/vtk/python/vtk/__init__.pyo
+lib/vtk/python/vtk/common.py
+lib/vtk/python/vtk/common.pyc
+lib/vtk/python/vtk/common.pyo
+lib/vtk/python/vtk/filtering.py
+lib/vtk/python/vtk/filtering.pyc
+lib/vtk/python/vtk/filtering.pyo
+lib/vtk/python/vtk/graphics.py
+lib/vtk/python/vtk/graphics.pyc
+lib/vtk/python/vtk/graphics.pyo
+lib/vtk/python/vtk/gtk/GtkVTKRenderWindow.py
+lib/vtk/python/vtk/gtk/GtkVTKRenderWindow.pyc
+lib/vtk/python/vtk/gtk/GtkVTKRenderWindow.pyo
+lib/vtk/python/vtk/gtk/GtkVTKRenderWindowInteractor.py
+lib/vtk/python/vtk/gtk/GtkVTKRenderWindowInteractor.pyc
+lib/vtk/python/vtk/gtk/GtkVTKRenderWindowInteractor.pyo
+lib/vtk/python/vtk/gtk/__init__.py
+lib/vtk/python/vtk/gtk/__init__.pyc
+lib/vtk/python/vtk/gtk/__init__.pyo
+lib/vtk/python/vtk/hybrid.py
+lib/vtk/python/vtk/hybrid.pyc
+lib/vtk/python/vtk/hybrid.pyo
+lib/vtk/python/vtk/imaging.py
+lib/vtk/python/vtk/imaging.pyc
+lib/vtk/python/vtk/imaging.pyo
+lib/vtk/python/vtk/io.py
+lib/vtk/python/vtk/io.pyc
+lib/vtk/python/vtk/io.pyo
+lib/vtk/python/vtk/parallel.py
+lib/vtk/python/vtk/parallel.pyc
+lib/vtk/python/vtk/parallel.pyo
+lib/vtk/python/vtk/patented.py
+lib/vtk/python/vtk/patented.pyc
+lib/vtk/python/vtk/patented.pyo
+lib/vtk/python/vtk/qt/QVTKRenderWidget.py
+lib/vtk/python/vtk/qt/QVTKRenderWidget.pyc
+lib/vtk/python/vtk/qt/QVTKRenderWidget.pyo
+lib/vtk/python/vtk/qt/QVTKRenderWindowInteractor.py
+lib/vtk/python/vtk/qt/QVTKRenderWindowInteractor.pyc
+lib/vtk/python/vtk/qt/QVTKRenderWindowInteractor.pyo
+lib/vtk/python/vtk/qt/__init__.py
+lib/vtk/python/vtk/qt/__init__.pyc
+lib/vtk/python/vtk/qt/__init__.pyo
+lib/vtk/python/vtk/rendering.py
+lib/vtk/python/vtk/rendering.pyc
+lib/vtk/python/vtk/rendering.pyo
+lib/vtk/python/vtk/required.py
+lib/vtk/python/vtk/required.pyc
+lib/vtk/python/vtk/required.pyo
+lib/vtk/python/vtk/test/BlackBox.py
+lib/vtk/python/vtk/test/BlackBox.pyc
+lib/vtk/python/vtk/test/BlackBox.pyo
+lib/vtk/python/vtk/test/Testing.py
+lib/vtk/python/vtk/test/Testing.pyc
+lib/vtk/python/vtk/test/Testing.pyo
+lib/vtk/python/vtk/test/__init__.py
+lib/vtk/python/vtk/test/__init__.pyc
+lib/vtk/python/vtk/test/__init__.pyo
+lib/vtk/python/vtk/tk/__init__.py
+lib/vtk/python/vtk/tk/__init__.pyc
+lib/vtk/python/vtk/tk/__init__.pyo
+lib/vtk/python/vtk/tk/vtkLoadPythonTkWidgets.py
+lib/vtk/python/vtk/tk/vtkLoadPythonTkWidgets.pyc
+lib/vtk/python/vtk/tk/vtkLoadPythonTkWidgets.pyo
+lib/vtk/python/vtk/tk/vtkTkImageViewerWidget.py
+lib/vtk/python/vtk/tk/vtkTkImageViewerWidget.pyc
+lib/vtk/python/vtk/tk/vtkTkImageViewerWidget.pyo
+lib/vtk/python/vtk/tk/vtkTkPhotoImage.py
+lib/vtk/python/vtk/tk/vtkTkPhotoImage.pyc
+lib/vtk/python/vtk/tk/vtkTkPhotoImage.pyo
+lib/vtk/python/vtk/tk/vtkTkRenderWidget.py
+lib/vtk/python/vtk/tk/vtkTkRenderWidget.pyc
+lib/vtk/python/vtk/tk/vtkTkRenderWidget.pyo
+lib/vtk/python/vtk/tk/vtkTkRenderWindowInteractor.py
+lib/vtk/python/vtk/tk/vtkTkRenderWindowInteractor.pyc
+lib/vtk/python/vtk/tk/vtkTkRenderWindowInteractor.pyo
+lib/vtk/python/vtk/util/__init__.py
+lib/vtk/python/vtk/util/__init__.pyc
+lib/vtk/python/vtk/util/__init__.pyo
+lib/vtk/python/vtk/util/colors.py
+lib/vtk/python/vtk/util/colors.pyc
+lib/vtk/python/vtk/util/colors.pyo
+lib/vtk/python/vtk/util/misc.py
+lib/vtk/python/vtk/util/misc.pyc
+lib/vtk/python/vtk/util/misc.pyo
+lib/vtk/python/vtk/util/vtkConstants.py
+lib/vtk/python/vtk/util/vtkConstants.pyc
+lib/vtk/python/vtk/util/vtkConstants.pyo
+lib/vtk/python/vtk/util/vtkImageExportToArray.py
+lib/vtk/python/vtk/util/vtkImageExportToArray.pyc
+lib/vtk/python/vtk/util/vtkImageExportToArray.pyo
+lib/vtk/python/vtk/util/vtkImageImportFromArray.py
+lib/vtk/python/vtk/util/vtkImageImportFromArray.pyc
+lib/vtk/python/vtk/util/vtkImageImportFromArray.pyo
+lib/vtk/python/vtk/util/vtkMethodParser.py
+lib/vtk/python/vtk/util/vtkMethodParser.pyc
+lib/vtk/python/vtk/util/vtkMethodParser.pyo
+lib/vtk/python/vtk/wx/__init__.py
+lib/vtk/python/vtk/wx/__init__.pyc
+lib/vtk/python/vtk/wx/__init__.pyo
+lib/vtk/python/vtk/wx/wxVTKRenderWindow.py
+lib/vtk/python/vtk/wx/wxVTKRenderWindow.pyc
+lib/vtk/python/vtk/wx/wxVTKRenderWindow.pyo
+lib/vtk/python/vtk/wx/wxVTKRenderWindowInteractor.py
+lib/vtk/python/vtk/wx/wxVTKRenderWindowInteractor.pyc
+lib/vtk/python/vtk/wx/wxVTKRenderWindowInteractor.pyo
+lib/vtk/python/vtkRenderWidget.py
+lib/vtk/python/vtkRenderWidget.pyc
+lib/vtk/python/vtkRenderWidget.pyo
+lib/vtk/python/vtkTkImageViewerWidget.py
+lib/vtk/python/vtkTkImageViewerWidget.pyc
+lib/vtk/python/vtkTkImageViewerWidget.pyo
+lib/vtk/python/vtkTkRenderWidget.py
+lib/vtk/python/vtkTkRenderWidget.pyc
+lib/vtk/python/vtkTkRenderWidget.pyo
+lib/vtk/python/vtkpython.py
+lib/vtk/python/vtkpython.pyc
+lib/vtk/python/vtkpython.pyo
+lib/vtk/python/vtkpythontk.py
+lib/vtk/python/vtkpythontk.pyc
+lib/vtk/python/vtkpythontk.pyo
+lib/vtk/python/wxVTKRenderWindow.py
+lib/vtk/python/wxVTKRenderWindow.pyc
+lib/vtk/python/wxVTKRenderWindow.pyo
+%%PYTHON_SITELIBDIR%%/vtk.pth
+%%DOCSDIR%%/README.html
+%%DOCSDIR%%/README.patented-classes
+%%DOCSDIR%%/vtkLogo.jpg
+@unexec rmdir %D/%%DOCSDIR%% 2>/dev/null || true
+@dirrm lib/vtk/python/vtk/wx
+@dirrm lib/vtk/python/vtk/util
+@dirrm lib/vtk/python/vtk/tk
+@dirrm lib/vtk/python/vtk/test
+@dirrm lib/vtk/python/vtk/qt
+@dirrm lib/vtk/python/vtk/gtk
+@dirrm lib/vtk/python/vtk
+@dirrm lib/vtk/python
+@unexec rmdir %D/lib/vtk 2>/dev/null || true
+@unexec rm %%VTK_PTH_LOCATION_DIR%%/vtk.pth 2>/dev/null || true