aboutsummaryrefslogtreecommitdiff
path: root/math/vtk/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1999-06-01 13:16:47 +0000
committerThomas Gellekum <tg@FreeBSD.org>1999-06-01 13:16:47 +0000
commit032421c10ea0ed6a7a14790ba766740d3c7ea3b3 (patch)
tree644bec6b81f7040a3e7bad6a84b0b1559a4fba89 /math/vtk/Makefile
parent81ca25de3b07997ad68d1cdbdddd92e75fce9582 (diff)
downloadports-032421c10ea0ed6a7a14790ba766740d3c7ea3b3.tar.gz
ports-032421c10ea0ed6a7a14790ba766740d3c7ea3b3.zip
Notes
Diffstat (limited to 'math/vtk/Makefile')
-rw-r--r--math/vtk/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/vtk/Makefile b/math/vtk/Makefile
new file mode 100644
index 000000000000..3ba8768cd17f
--- /dev/null
+++ b/math/vtk/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: vtk
+# Version required: 2.3
+# Date created: 24 Nov 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= vtk23unix
+PKGNAME= vtk-2.3
+CATEGORIES= math
+MASTER_SITES= ftp://vtk.scorec.rpi.edu/pub/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3 \
+ tk80.1:${PORTSDIR}/x11-toolkits/tk80
+
+WRKSRC= $(WRKDIR)/vtk
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CXXFLAGS="${CFLAGS}"
+
+post-install:
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>