aboutsummaryrefslogtreecommitdiff
path: root/math/vtk6/files
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-08 17:18:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-08 17:18:41 +0000
commitfaaf0a24d774f7e8687b7693a9ac934880368831 (patch)
tree42cb4ffdf9c1ed70916f561ff0ada670905deb48 /math/vtk6/files
parente7716bd0d46afc463f54e4e172cafc13e3560235 (diff)
downloadports-faaf0a24d774f7e8687b7693a9ac934880368831.tar.gz
ports-faaf0a24d774f7e8687b7693a9ac934880368831.zip
Notes
Diffstat (limited to 'math/vtk6/files')
-rw-r--r--math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt31
-rw-r--r--math/vtk6/files/patch-GUISupport-Qt_PluginInstall.cmake.in11
-rw-r--r--math/vtk6/files/patch-IO-LSDyna-private_LSDynaFamily.cxx11
-rw-r--r--math/vtk6/files/patch-ThirdParty-verdict-vtkverdict_CMakeLists.txt25
-rw-r--r--math/vtk6/files/patch-Wrapping-Python_CMakeLists.txt11
5 files changed, 89 insertions, 0 deletions
diff --git a/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt b/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt
new file mode 100644
index 000000000000..1cbf58e6a3bd
--- /dev/null
+++ b/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt
@@ -0,0 +1,31 @@
+--- GUISupport/Qt/CMakeLists.txt.orig 2013-06-12 21:47:10.000000000 +0200
++++ GUISupport/Qt/CMakeLists.txt 2013-09-13 11:24:33.000000000 +0200
+@@ -89,7 +89,7 @@
+ endif()
+
+ # This build plugin logic should just get migrated into a module I think.
+-if(BUILD_SHARED_LIBS)
++if(BUILD_SHARED_LIBS AND QT_DESIGNER_PLUGIN)
+ set(PluginLibSrcs Q4VTKWidgetPlugin.cxx)
+
+ set(PluginMocHeaders Q4VTKWidgetPlugin.h)
+@@ -100,16 +100,16 @@
+
+ # add QVTK plugin from sources
+ # stand-alone as it doesn't depend on QVTK library
+- add_library(QVTKWidgetPlugin
++ add_library(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION}
+ SHARED
+ ${PluginLibSrcs}
+ ${PluginMocSrcs}
+ )
+
+- set_target_properties(QVTKWidgetPlugin PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
++ set_target_properties(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
+
+ # link with Qt libs
+- target_link_libraries(QVTKWidgetPlugin
++ target_link_libraries(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTCORE_LIBRARY}
+ )
diff --git a/math/vtk6/files/patch-GUISupport-Qt_PluginInstall.cmake.in b/math/vtk6/files/patch-GUISupport-Qt_PluginInstall.cmake.in
new file mode 100644
index 000000000000..d702bb200db3
--- /dev/null
+++ b/math/vtk6/files/patch-GUISupport-Qt_PluginInstall.cmake.in
@@ -0,0 +1,11 @@
+--- GUISupport/Qt/PluginInstall.cmake.in.orig 2013-06-12 21:47:10.000000000 +0200
++++ GUISupport/Qt/PluginInstall.cmake.in 2013-09-13 12:06:53.000000000 +0200
+@@ -2,7 +2,7 @@
+ SET(VTK_LIB_DIR "@CMAKE_LIBRARY_OUTPUT_DIRECTORY@")
+ SET(VTK_INSTALL_QT_DIR "@VTK_INSTALL_QT_DIR@")
+ SET(VTK_INSTALL_QT_PLUGIN_DIR "@VTK_INSTALL_QT_PLUGIN_DIR@")
+-SET(VTK_INSTALL_QT_PLUGIN_FILE "@CMAKE_SHARED_LIBRARY_PREFIX@QVTKWidgetPlugin@CMAKE_SHARED_LIBRARY_SUFFIX@")
++SET(VTK_INSTALL_QT_PLUGIN_FILE "@CMAKE_SHARED_LIBRARY_PREFIX@QVTKWidgetPlugin-@VTK_MAJOR_VERSION@.@VTK_MINOR_VERSION@@CMAKE_SHARED_LIBRARY_SUFFIX@")
+ SET(VTK_CONFIGURATIONS "@CMAKE_CONFIGURATION_TYPES@")
+
+ IF(VTK_CONFIGURATIONS)
diff --git a/math/vtk6/files/patch-IO-LSDyna-private_LSDynaFamily.cxx b/math/vtk6/files/patch-IO-LSDyna-private_LSDynaFamily.cxx
new file mode 100644
index 000000000000..d724005acabf
--- /dev/null
+++ b/math/vtk6/files/patch-IO-LSDyna-private_LSDynaFamily.cxx
@@ -0,0 +1,11 @@
+--- IO/LSDyna/private/LSDynaFamily.cxx.orig 2013-06-25 14:13:58.000000000 +0200
++++ IO/LSDyna/private/LSDynaFamily.cxx 2013-06-25 14:17:08.000000000 +0200
+@@ -33,7 +33,7 @@
+ namespace
+ {
+ //Documentation on why the exemption
+-#define USE_STAT_64 VTK_SIZEOF_ID_TYPE==8 && !defined _DARWIN_FEATURE_64_BIT_INODE
++#define USE_STAT_64 VTK_SIZEOF_ID_TYPE==8 && !defined _DARWIN_FEATURE_64_BIT_INODE && !defined __FreeBSD__
+ //OSX uses stat instead of stat64
+ #if (USE_STAT_64)
+ //64bit
diff --git a/math/vtk6/files/patch-ThirdParty-verdict-vtkverdict_CMakeLists.txt b/math/vtk6/files/patch-ThirdParty-verdict-vtkverdict_CMakeLists.txt
new file mode 100644
index 000000000000..423c55bdebf9
--- /dev/null
+++ b/math/vtk6/files/patch-ThirdParty-verdict-vtkverdict_CMakeLists.txt
@@ -0,0 +1,25 @@
+--- ThirdParty/verdict/vtkverdict/CMakeLists.txt.orig 2013-06-26 09:41:53.000000000 +0200
++++ ThirdParty/verdict/vtkverdict/CMakeLists.txt 2013-06-26 09:42:13.000000000 +0200
+@@ -117,14 +117,14 @@
+ # Installation stuff
+ #
+ IF(NOT verdict_INSTALL_NO_DEVELOPMENT)
+- install(FILES
+- README
+- Verdict.htm
+- Verdict.doc
+- verdict_test.cpp
+- DESTINATION ${verdict_INSTALL_DOC_DIR}/verdict/${verdict_VERSION}/
+- COMPONENT Development
+- )
++# install(FILES
++# README
++# Verdict.htm
++# Verdict.doc
++# verdict_test.cpp
++# DESTINATION ${verdict_INSTALL_DOC_DIR}/verdict/${verdict_VERSION}/
++# COMPONENT Development
++# )
+
+ install(
+ FILES ${verdict_BINARY_DIR}/verdict.h
diff --git a/math/vtk6/files/patch-Wrapping-Python_CMakeLists.txt b/math/vtk6/files/patch-Wrapping-Python_CMakeLists.txt
new file mode 100644
index 000000000000..b54d26dc53da
--- /dev/null
+++ b/math/vtk6/files/patch-Wrapping-Python_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- Wrapping/Python/CMakeLists.txt.orig 2013-06-12 21:47:10.000000000 +0200
++++ Wrapping/Python/CMakeLists.txt 2013-11-28 16:12:38.000000000 +0100
+@@ -290,7 +290,7 @@
+
+ # Create default python setup arguments if they are not set.
+ if(NOT DEFINED VTK_PYTHON_SETUP_ARGS)
+- set(VTK_PYTHON_SETUP_ARGS "--prefix=\"${DOLLAR}{CMAKE_INSTALL_PREFIX}\""
++ set(VTK_PYTHON_SETUP_ARGS "--prefix=\"${DOLLAR}{STAGEDIR}${DOLLAR}{PREFIX}\""
+ CACHE STRING "Arguments passed to \"python setup.py install ...\" during installation.")
+ mark_as_advanced(VTK_PYTHON_SETUP_ARGS)
+ endif()