aboutsummaryrefslogtreecommitdiff
path: root/math/vtk6
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2015-01-02 18:43:29 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2015-01-02 18:43:29 +0000
commit401bf7f4c506520edc5cd43b830de597ba904f8c (patch)
treef8a5a68073a95c55ae391305b66e873f56133c26 /math/vtk6
parent1214b15c50a726025833c5171d5626ebc0322aa8 (diff)
downloadports-401bf7f4c506520edc5cd43b830de597ba904f8c.tar.gz
ports-401bf7f4c506520edc5cd43b830de597ba904f8c.zip
Notes
Diffstat (limited to 'math/vtk6')
-rw-r--r--math/vtk6/Makefile2
-rw-r--r--math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx28
2 files changed, 28 insertions, 2 deletions
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index af1ad5f9e6ec..dce565dc5c83 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -14,8 +14,6 @@ COMMENT= The Visualization Toolkit
LICENSE= BSD3CLAUSE
-BROKEN= Fails to build
-
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
diff --git a/math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx b/math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx
new file mode 100644
index 000000000000..a6177c9a6f8e
--- /dev/null
+++ b/math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx
@@ -0,0 +1,28 @@
+--- Rendering/FreeType/vtkFreeTypeTools.cxx.orig 2015-01-02 17:05:19.000000000 +0000
++++ Rendering/FreeType/vtkFreeTypeTools.cxx 2015-01-02 17:05:26.000000000 +0000
+@@ -1185,8 +1185,8 @@
+ bitmapGlyph);
+ if (bitmap)
+ {
+- metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++ metaData.ascent = std::max<int>(bitmapGlyph->top - 1, metaData.ascent);
++ metaData.descent = std::min<int>(-(bitmap->rows - (bitmapGlyph->top - 1)),
+ metaData.descent);
+ }
+ ++heightString;
+@@ -1950,10 +1950,10 @@
+ fontSize, gindex, bitmapGlyph);
+ if (bitmap)
+ {
+- bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
+- bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
++ bbox[0] = std::min<int>(bbox[0], pen[0] + bitmapGlyph->left);
++ bbox[1] = std::max<int>(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
++ bbox[2] = std::min<int>(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++ bbox[3] = std::max<int>(bbox[3], pen[1] + bitmapGlyph->top - 1);
+ }
+ else
+ {