aboutsummaryrefslogtreecommitdiff
path: root/math/vtk
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /math/vtk
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'math/vtk')
-rw-r--r--math/vtk/Makefile6
-rw-r--r--math/vtk/files/patch-vtkPNGReader.cxx20
-rw-r--r--math/vtk/files/patch-vtkPNGWriter.cxx20
3 files changed, 42 insertions, 4 deletions
diff --git a/math/vtk/Makefile b/math/vtk/Makefile
index 22207bffadfd..0bebaafe2569 100644
--- a/math/vtk/Makefile
+++ b/math/vtk/Makefile
@@ -15,7 +15,7 @@
PORTNAME= vtk
PORTVERSION= 4.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math graphics
MASTER_SITES= http://ovt.irfu.se/vtk/files/
DISTFILES?= VTK-${PORTVERSION}-LatestRelease.tar.gz
@@ -49,7 +49,7 @@ BUILD_DEPENDS+= ${CMAKE}:${PORTSDIR}/devel/cmake
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
.if defined(WITH_TESTING) && (!defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX}=="-java")
@@ -132,8 +132,6 @@ do-configure:
patch-common:
@${FIND} ${VTKSRCDIR} -name "*.cxx" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc.h|stdlib.h|g'
- @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${VTKSRCDIR}/IO/vtkPNGReader.cxx
@${REINPLACE_CMD} -E 's|lib/vtk\)|lib\)|g' \
${VTKSRCDIR}/vtkGenerateVTKConfig.cmake
.if defined(WRAP)
diff --git a/math/vtk/files/patch-vtkPNGReader.cxx b/math/vtk/files/patch-vtkPNGReader.cxx
new file mode 100644
index 000000000000..4ad23950beb5
--- /dev/null
+++ b/math/vtk/files/patch-vtkPNGReader.cxx
@@ -0,0 +1,20 @@
+--- IO/vtkPNGReader.cxx.orig 2012-05-06 13:44:56.000000000 +0200
++++ IO/vtkPNGReader.cxx 2012-05-06 13:46:04.000000000 +0200
+@@ -101,7 +101,7 @@
+ // minimum of a byte per pixel
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // add alpha if any alpha found
+@@ -200,7 +200,7 @@
+ // minimum of a byte per pixel
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // add alpha if any alpha found
diff --git a/math/vtk/files/patch-vtkPNGWriter.cxx b/math/vtk/files/patch-vtkPNGWriter.cxx
new file mode 100644
index 000000000000..70dc6030ffeb
--- /dev/null
+++ b/math/vtk/files/patch-vtkPNGWriter.cxx
@@ -0,0 +1,20 @@
+--- IO/vtkPNGWriter.cxx.orig 2003-12-30 21:51:31.000000000 +0100
++++ IO/vtkPNGWriter.cxx 2012-05-05 09:43:24.000000000 +0200
+@@ -147,7 +147,7 @@
+ void vtkPNGWriteErrorFunction(png_structp png_ptr,
+ png_const_charp vtkNotUsed(error_msg))
+ {
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+ }
+
+@@ -223,7 +223,7 @@
+ png_init_io(png_ptr, this->TempFP);
+ png_set_error_fn(png_ptr, png_ptr,
+ vtkPNGWriteErrorFunction, vtkPNGWriteWarningFunction);
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fclose(this->TempFP);
+ this->SetErrorCode(vtkErrorCode::OutOfDiskSpaceError);