aboutsummaryrefslogtreecommitdiff
path: root/math/x12arima/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2010-08-21 16:04:45 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2010-08-21 16:04:45 +0000
commitec798d26fcec750c253fa45b898b5c01bec3e5df (patch)
tree1298b735e7ba8c9e965888d0eeae258947ee8885 /math/x12arima/Makefile
parent0f7c65f788363e2e840fb9d2505f6dfe28728497 (diff)
downloadports-ec798d26fcec750c253fa45b898b5c01bec3e5df.tar.gz
ports-ec798d26fcec750c253fa45b898b5c01bec3e5df.zip
Notes
Diffstat (limited to 'math/x12arima/Makefile')
-rw-r--r--math/x12arima/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/math/x12arima/Makefile b/math/x12arima/Makefile
new file mode 100644
index 000000000000..6e5f8c6fc529
--- /dev/null
+++ b/math/x12arima/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: x12arima
+# Date created: 22 June 2010
+# Whom: jh@jameshoward.us
+#
+# $FreeBSD$
+
+PORTNAME= x12arima
+PORTVERSION= 0.3
+CATEGORIES= math finance
+MASTER_SITES= http://www.census.gov/ts/x12a/v03/unix/
+DISTFILES= omegav03src.tar.gz
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jh@jameshoward.us
+COMMENT= X-12-ARIMA seasonal adjustment program
+
+USE_FORTRAN= yes
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile.lnx
+
+PLIST_FILES= bin/x12a
+
+.ifndef(NOPORTDOCS) || make(makesum)
+DISTFILES+= docsv03.tar.gz
+.endif
+
+.ifndef(NOPORTDOCS)
+PORTDOCS= ReleaseNotesVersion03.pdf qref03unix.pdf x12adocV03.pdf
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/docs && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR})
+
+.endif
+.include <bsd.port.mk>