aboutsummaryrefslogtreecommitdiff
path: root/math/x12arima
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 13:14:34 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 13:14:34 +0000
commit3a9704f71cc20b790b7adb1f7d65f297c6f06ab9 (patch)
treeccf342f49cbc6fb64f743639c47e8d92ea56184f /math/x12arima
parent9deffedb6b14ee4a4c6eb8a9f7054aeba1504bca (diff)
downloadports-3a9704f71cc20b790b7adb1f7d65f297c6f06ab9.tar.gz
ports-3a9704f71cc20b790b7adb1f7d65f297c6f06ab9.zip
Notes
Diffstat (limited to 'math/x12arima')
-rw-r--r--math/x12arima/Makefile5
-rw-r--r--math/x12arima/files/patch-makefile.lnx10
2 files changed, 7 insertions, 8 deletions
diff --git a/math/x12arima/Makefile b/math/x12arima/Makefile
index 97177e23482c..8c14d07f1471 100644
--- a/math/x12arima/Makefile
+++ b/math/x12arima/Makefile
@@ -15,7 +15,6 @@ COMMENT= X-12-ARIMA seasonal adjustment program
USES= fortran
NO_WRKSUBDIR= yes
MAKEFILE= makefile.lnx
-NO_STAGE= yes
PLIST_FILES= bin/x12a
@@ -27,8 +26,8 @@ DISTFILES+= docsv03.tar.gz
PORTDOCS= ReleaseNotesVersion03.pdf qref03unix.pdf x12adocV03.pdf
post-install:
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/docs && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/docs && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.endif
.include <bsd.port.mk>
diff --git a/math/x12arima/files/patch-makefile.lnx b/math/x12arima/files/patch-makefile.lnx
index 2500a040340a..a16cf970fd09 100644
--- a/math/x12arima/files/patch-makefile.lnx
+++ b/math/x12arima/files/patch-makefile.lnx
@@ -1,5 +1,5 @@
---- makefile.lnx.orig 2010-08-20 22:32:52.000000000 -0400
-+++ makefile.lnx 2010-08-20 22:50:54.000000000 -0400
+--- makefile.lnx.orig 2009-11-19 23:04:08.000000000 +0800
++++ makefile.lnx 2014-06-19 21:12:15.392802744 +0800
@@ -1,15 +1,11 @@
# MKMF template makefile for protected mode executables.
-FC = ifort
@@ -18,7 +18,7 @@
OBJS = aaamain.o abend.o acf.o acfar.o acfdgn.o \
acfhdr.o addadj.o addaic.o addate.o addfix.o \
addmul.o addotl.o addsef.o addsub.o addusr.o \
-@@ -237,6 +233,8 @@
+@@ -237,6 +233,8 @@ SRCS = aaamain.f abend.f acf.
xrgdiv.f xrgdrv.f xrgtrn.f xrlkhd.f xtrm.f \
yprmy.f yrly.f
@@ -27,12 +27,12 @@
$(PROGRAM): $(OBJS) $(LIBS)
$(LINKER) -o $@ $(OBJS) $(LDMAP) $(LIBS) $(LDFLAGS)
-@@ -244,7 +242,7 @@
+@@ -244,7 +242,7 @@ clean:; @rm -f $(OBJS)
install: $(PROGRAM)
@echo Installing $(PROGRAM) in $(DEST)
- @if not $(DEST)x==.x copy $(PROGRAM) $(DEST)
-+ @$(BSD_INSTALL_PROGRAM) $(PROGRAM) $(DEST)
++ @$(BSD_INSTALL_PROGRAM) $(PROGRAM) $(DESTDIR)$(DEST)
### OPUS MKMF: Do not remove this line! Automatic dependencies follow.
aaamain.o: build.prm cchars.i chrt.cmn error.cmn hiddn.cmn lex.i \