aboutsummaryrefslogtreecommitdiff
path: root/math/xgfe/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-06 22:57:48 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-06 22:57:48 +0000
commitd3c24d35b28931a1a81edb37b2ecb04497bb5402 (patch)
tree1c57506bdf87ab09eb437aa066de64bc51f30549 /math/xgfe/Makefile
parent4d8534d2a26d0067f31dd7dedac2058fdaaaa893 (diff)
Notes
Diffstat (limited to 'math/xgfe/Makefile')
-rw-r--r--math/xgfe/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/math/xgfe/Makefile b/math/xgfe/Makefile
index 5cc2f3a00669..96476a57216c 100644
--- a/math/xgfe/Makefile
+++ b/math/xgfe/Makefile
@@ -6,21 +6,21 @@
#
PORTNAME= xgfe
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= mph
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= graphics/gnuplot/contrib
MAINTAINER= mph@freebsd.org
COMMENT= An X11 front-end for Gnuplot
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-USE_GCC= 2.95
-USE_QT_VER= 1
+USE_QT_VER= 3
USE_X_PREFIX= yes
-MAKE_ENV= X11BASE=$(X11BASE) PREFIX=$(PREFIX)
+MAKE_ENV+= DOCSDIR=$(DOCSDIR) PTHREAD_CFLAGS="$(PTHREAD_CFLAGS)" \
+ PTHREAD_LIBS="$(PTHREAD_LIBS)"
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS=$(NOPORTDOCS)
.endif
@@ -28,6 +28,6 @@ MAKE_ENV+= NOPORTDOCS=$(NOPORTDOCS)
WRKSRC= $(WRKDIR)/$(DISTNAME)/source
post-extract:
- cd $(WRKSRC) && ${RM} Makefile && ${LN} -s Makefile.freebsd-gcc Makefile
+ @cd $(WRKSRC) && ${LN} -sf Makefile.freebsd-gcc Makefile
.include <bsd.port.mk>