aboutsummaryrefslogtreecommitdiff
path: root/math/xlife++/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-13 05:46:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-13 05:46:53 +0000
commitcb539b55f1ed1098a0ad1631524a30f01822e778 (patch)
tree74b27c36f051c9cd9168d380d012dddd5f240412 /math/xlife++/Makefile
parent220c428bce75a88490a728f9e3f7009ac8ed16aa (diff)
New port: math/xlife++: XLiFE++: eXtended Library of Finite Elements in C++
Notes
Notes: svn path=/head/; revision=469772
Diffstat (limited to 'math/xlife++/Makefile')
-rw-r--r--math/xlife++/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/math/xlife++/Makefile b/math/xlife++/Makefile
new file mode 100644
index 000000000000..b4a257984667
--- /dev/null
+++ b/math/xlife++/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= xlife++
+DISTVERSION= 2.0.1
+CATEGORIES= math
+MASTER_SITES= https://uma.ensta-paristech.fr/soft/XLiFE++/var/files/src/
+DISTNAME= xlifepp-sources-v${DISTVERSION}-2018-05-09
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= XLiFE++: eXtended Library of Finite Elements in C++
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= cmake:outsource eigen:3 fortran tar:tbz
+USE_LDCONFIG= yes
+
+CMAKE_OFF= XLIFEPP_ENABLE_ARPACK # should be ON, but it fails to build. Reported to their bugs ML.
+
+CXXFLAGS+= -I${LOCALBASE}/include/eigen3/Eigen -I${LOCALBASE}/include/ARPACK++
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-extract: # delete bundled packages
+ @${RM} -r ${WRKSRC}/ext/Eigen ${WRKSRC}/ext/ARPACK ${WRKSRC}/ext/ARPACK++
+
+post-configure:
+ @${REINPLACE_CMD} -E 's/.*(ARPACK|Eigen)/#&/' ${CONFIGURE_WRKSRC}/cmake_install.cmake
+
+post-install:
+ @cd ${STAGEDIR}${PREFIX} && ${RM} -r CMakeLists.txt VERSION.txt etc/visuTermVec.m etc/templates etc/gmsh
+
+.include <bsd.port.mk>