aboutsummaryrefslogtreecommitdiff
path: root/math/xmgr/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-04-09 08:51:42 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-04-09 08:51:42 +0000
commit1ec26f18bff468912cea30497b4343779905f330 (patch)
tree1fd277c7ba9d341039b13746f195f1cfda205c4c /math/xmgr/Makefile
parent231b0d80efb3c177d46fbb2e54167891930474bd (diff)
downloadports-1ec26f18bff468912cea30497b4343779905f330.tar.gz
ports-1ec26f18bff468912cea30497b4343779905f330.zip
Notes
Diffstat (limited to 'math/xmgr/Makefile')
-rw-r--r--math/xmgr/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/xmgr/Makefile b/math/xmgr/Makefile
new file mode 100644
index 000000000000..293ea9a5b19b
--- /dev/null
+++ b/math/xmgr/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xmgr-4.1.1
+# Version required: 4.1.1
+# Date created: Sun 18 Dec 1997
+# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
+#
+# $Id$
+#
+
+DISTNAME= xmgr-4.1.1
+CATEGORIES= math print
+MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/xmgr4/src/ \
+ ftp://fire.mpi-stuttgart.mpg.de/pub/mirror/xmgr4/src/ \
+ ftp://wauug.erols.com/pub/X-Windows/xmgr4/src/
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
+
+BUILD_DEPENDS= ${X11BASE}/lib/libhlpclient.a:${PORTSDIR}/x11/libhelp \
+ ${LOCALBASE}/lib/libmfhdf.a:${PORTSDIR}/graphics/hdf
+LIB_DEPENDS= Xbae\\.6\\.:${PORTSDIR}/x11/xbae
+
+USE_X11= YES
+REQUIRE_MOTIF= YES
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= -prefix=${X11BASE} \
+ --enable-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include \
+ --enable-extra-ldpath=${LOCALBASE}/lib --enable-libhelp \
+ --enable-mfhdf --enable-acegr-home=${X11BASE}/lib/X11/xmgr
+
+ALL_TARGET=
+INSTALL_TARGET= install links
+
+.include <bsd.port.mk>