aboutsummaryrefslogtreecommitdiff
path: root/math/yacas/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-05-10 09:58:00 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-05-10 09:58:00 +0000
commit7be97a1bb4c7d3e994b0d94a1ca39d3332eced02 (patch)
tree94b4c65a1f3b67cbb021ec7536cdd1910d27252a /math/yacas/Makefile
parent24bd216d00f42439c86fca50234093cc0bbccd93 (diff)
Notes
Diffstat (limited to 'math/yacas/Makefile')
-rw-r--r--math/yacas/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index b088c9c87001..9f04f8e0840f 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.4.2
+PORTVERSION= 1.5.0
DISTVERSIONPREFIX= v
CATEGORIES= math
@@ -18,6 +18,7 @@ DOCS_BUILD_DEPENDS= sphinx-autogen:textproc/py-sphinx
PORTDOCS= *
+TEST_TARGET= test
TEST_DEPENDS= bash:shells/bash
USES= cmake:outsource compiler:c++11-lib
@@ -36,11 +37,8 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
post-patch:
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
- @${REINPLACE_CMD} -e \
- 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
+ @${REINPLACE_CMD} -e 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
${WRKSRC}/tests/test-yacas
-
-do-test:
- cd ${BUILD_WRKSRC} && ${MAKE} test
-
+ @${REINPLACE_CMD} -e '/^install/s|^|#|' \
+ ${WRKSRC}/tests/CMakeLists.txt
.include <bsd.port.post.mk>