aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /math/yacas
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
Notes
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 5d760d0a6a74..fe6263c8c94b 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
OPTIONS= X11 "Build with X11 features" off \
GMP "Use libgmp for arbitrary precision arithmetic" off
@@ -51,8 +51,8 @@ PLIST_SUB+= GMP="@comment " NOGMP=""
USE_GL= yes
CONFIGURE_ARGS+= --with-x
PLIST_SUB+= X11=""
-CPPFLAGS+= -I${X11BASE}/include
-LDFLAGS+= -L${X11BASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "