aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-04-08 11:10:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-04-08 11:10:10 +0000
commit6621dfd6c0cb438e33bf25889bf0766d6dcb339a (patch)
tree4e3c5b332ac8dc3c418cc8e3999a48050f517cbd /math/yacas
parent0286c79feb5d263bbbcd133d4966c50e40a96b1a (diff)
downloadports-6621dfd6c0cb438e33bf25889bf0766d6dcb339a.tar.gz
ports-6621dfd6c0cb438e33bf25889bf0766d6dcb339a.zip
Notes
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile10
-rw-r--r--math/yacas/distinfo4
-rw-r--r--math/yacas/files/patch-CMakeLists-docs.txt18
-rw-r--r--math/yacas/files/patch-src_mathcommands.cpp2
-rw-r--r--math/yacas/files/patch-src_yacasmain.cpp2
-rw-r--r--math/yacas/pkg-plist2
6 files changed, 32 insertions, 6 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 41ae1330c852..b088c9c87001 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.2
DISTVERSIONPREFIX= v
CATEGORIES= math
@@ -12,6 +12,12 @@ COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+OPTIONS_DEFINE= DOCS
+DOCS_CMAKE_ON= -DENABLE_DOCS:BOOL=ON -DDOCSDIR:STRING=${DOCSDIR_REL}
+DOCS_BUILD_DEPENDS= sphinx-autogen:textproc/py-sphinx
+
+PORTDOCS= *
+
TEST_DEPENDS= bash:shells/bash
USES= cmake:outsource compiler:c++11-lib
@@ -19,6 +25,8 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= grzegorzmazur
+PLIST_SUB= SHLIB_VERSION=${PORTVERSION:S/.//}.0
+
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == "gcc"
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index e7f849d194bb..9d0ac78664d8 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grzegorzmazur-yacas-v1.4.0_GH0.tar.gz) = 3c39c2cb98889a30b5a82413d233c0b0a25892d4740f1fb93b99e44ecbb4c08b
-SIZE (grzegorzmazur-yacas-v1.4.0_GH0.tar.gz) = 2032216
+SHA256 (grzegorzmazur-yacas-v1.4.2_GH0.tar.gz) = 530fdc8902f6289ed5b6ddbbfa50910f74086657c97ece2a65a5111ccb1ec710
+SIZE (grzegorzmazur-yacas-v1.4.2_GH0.tar.gz) = 2032218
diff --git a/math/yacas/files/patch-CMakeLists-docs.txt b/math/yacas/files/patch-CMakeLists-docs.txt
new file mode 100644
index 000000000000..90ca38b8fb26
--- /dev/null
+++ b/math/yacas/files/patch-CMakeLists-docs.txt
@@ -0,0 +1,18 @@
+--- CMakeLists-docs.txt.orig 2016-04-08 09:58:59 UTC
++++ CMakeLists-docs.txt
+@@ -39,7 +39,7 @@ add_custom_target(yacas_docs ALL
+ "${SPHINX_SINGLEHTML_DIR}"
+ COMMENT "Building HTML documentation with Sphinx")
+
+-install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}" DESTINATION share/yacas/documentation COMPONENT doc)
++install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}" DESTINATION ${DOCSDIR} COMPONENT doc)
+
+ if (ENABLE_OLD_DOCS)
+
+@@ -161,4 +161,4 @@ if (ENABLE_OLD_DOCS)
+
+ install (FILES ${HTML_BOOKS} ${HTML_CHAPTERS} DESTINATION share/yacas/documentation COMPONENT doc)
+
+-endif ()
+\ No newline at end of file
++endif ()
diff --git a/math/yacas/files/patch-src_mathcommands.cpp b/math/yacas/files/patch-src_mathcommands.cpp
index caf0c481bc4d..9abc90cca6d4 100644
--- a/math/yacas/files/patch-src_mathcommands.cpp
+++ b/math/yacas/files/patch-src_mathcommands.cpp
@@ -1,4 +1,4 @@
---- src/mathcommands.cpp.orig 2016-02-04 14:54:05 UTC
+--- src/mathcommands.cpp.orig 2016-03-11 09:22:12 UTC
+++ src/mathcommands.cpp
@@ -23,6 +23,7 @@
#include "yacas/arggetter.h"
diff --git a/math/yacas/files/patch-src_yacasmain.cpp b/math/yacas/files/patch-src_yacasmain.cpp
index 6cf8bbea68f8..463ab465f772 100644
--- a/math/yacas/files/patch-src_yacasmain.cpp
+++ b/math/yacas/files/patch-src_yacasmain.cpp
@@ -1,4 +1,4 @@
---- src/yacasmain.cpp.orig 2016-03-04 15:08:05 UTC
+--- src/yacasmain.cpp.orig 2016-03-11 09:22:12 UTC
+++ src/yacasmain.cpp
@@ -72,6 +72,7 @@
#if defined (__FreeBSD__) || defined (__DragonFly__)
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index 970e3d14d85e..ce11c59782b8 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -62,7 +62,7 @@ include/yacas/yacasbase.h
include/yacas/yacasprivate.h
lib/libyacas.a
lib/libyacas.so
-lib/libyacas.so.1.0.0
+lib/libyacas.so.%%SHLIB_VERSION%%
%%DATADIR%%/scripts/Makefile.am
%%DATADIR%%/scripts/array.rep/code.ys
%%DATADIR%%/scripts/array.rep/code.ys.def