aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-03-04 11:30:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-03-04 11:30:12 +0000
commitb2e89824f865a584f1b5c25c9f6dbc90629155d3 (patch)
tree932281b77e4c4c75dd7a978e56a16c5e996524b9 /math/yacas
parent58028440f768792b433b5427139a291dccd610a6 (diff)
downloadports-b2e89824f865a584f1b5c25c9f6dbc90629155d3.tar.gz
ports-b2e89824f865a584f1b5c25c9f6dbc90629155d3.zip
Notes
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile32
-rw-r--r--math/yacas/distinfo4
-rw-r--r--math/yacas/files/patch-scripts_Makefile.am11
-rw-r--r--math/yacas/files/patch-scripts_Makefile.in11
-rw-r--r--math/yacas/files/patch-src_yacasmain.cpp13
-rw-r--r--math/yacas/pkg-descr2
-rw-r--r--math/yacas/pkg-plist21
7 files changed, 26 insertions, 68 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 17ec563b429e..c03b28dd86d1 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,30 +2,22 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.3.6
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= math
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION:R}/
+DISTVERSIONPREFIX= v
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lib libtool
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-html-dir=${DOCSDIR}
-INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
-
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
+TEST_DEPENDS= bash:${PORTSDIR}/shells/bash
-DOCS_USES= perl5
-DOCS_USE= perl5=build
-DOCS_CONFIGURE_ENABLE= html-doc
+USES= cmake:outsource compiler:c++11-lib
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= grzegorzmazur
.include <bsd.port.pre.mk>
@@ -34,17 +26,13 @@ CPPFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src/yacasmain.cpp
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
@${REINPLACE_CMD} -e \
's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
${WRKSRC}/tests/test-yacas
-regression-test: build
-# This requires bash. I don't add it as a dependency to the port, as
-# it's not needed for the general use.
- @(cd ${WRKSRC} && ${DO_MAKE_BUILD} check)
+do-test:
+ cd ${BUILD_WRKSRC} && ${MAKE} test
.include <bsd.port.post.mk>
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index 7996b11f5c8d..e7f849d194bb 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yacas-1.3.6.tar.gz) = c59a0456439833dfce3e5660f848b45c5560621a70e0ce4f4ec69718d24b3638
-SIZE (yacas-1.3.6.tar.gz) = 1585826
+SHA256 (grzegorzmazur-yacas-v1.4.0_GH0.tar.gz) = 3c39c2cb98889a30b5a82413d233c0b0a25892d4740f1fb93b99e44ecbb4c08b
+SIZE (grzegorzmazur-yacas-v1.4.0_GH0.tar.gz) = 2032216
diff --git a/math/yacas/files/patch-scripts_Makefile.am b/math/yacas/files/patch-scripts_Makefile.am
deleted file mode 100644
index ef5bbba8f593..000000000000
--- a/math/yacas/files/patch-scripts_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/Makefile.am.orig 2014-02-03 10:39:12.000000000 +0100
-+++ scripts/Makefile.am 2014-02-03 10:39:21.000000000 +0100
-@@ -164,7 +164,7 @@
- @(diff scripts-listed-in-makefile.txt contents-of-tree.txt; \
- rm -f scripts-listed-in-makefile.txt contents-of-tree.txt; \
- RV=$$?; \
-- if [[ $$RV == 0 ]] ; \
-+ if [ $$RV = 0 ] ; \
- then echo " ... ok"; \
- else \
- false; \
diff --git a/math/yacas/files/patch-scripts_Makefile.in b/math/yacas/files/patch-scripts_Makefile.in
deleted file mode 100644
index 247b34c06ad2..000000000000
--- a/math/yacas/files/patch-scripts_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/Makefile.in.orig 2014-02-03 10:37:08.000000000 +0100
-+++ scripts/Makefile.in 2014-02-03 10:38:36.000000000 +0100
-@@ -562,7 +562,7 @@
- @(diff scripts-listed-in-makefile.txt contents-of-tree.txt; \
- rm -f scripts-listed-in-makefile.txt contents-of-tree.txt; \
- RV=$$?; \
-- if [[ $$RV == 0 ]] ; \
-+ if [ $$RV = 0 ] ; \
- then echo " ... ok"; \
- else \
- false; \
diff --git a/math/yacas/files/patch-src_yacasmain.cpp b/math/yacas/files/patch-src_yacasmain.cpp
deleted file mode 100644
index db827b46cd0c..000000000000
--- a/math/yacas/files/patch-src_yacasmain.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/yacasmain.cpp.orig 2014-11-25 15:18:46 UTC
-+++ src/yacasmain.cpp
-@@ -1083,7 +1083,9 @@ int main(int argc, char** argv)
- unsigned char first_stack_var = 0;
- the_first_stack_var = &first_stack_var;
-
--#if defined (__APPLE__)
-+#if defined (__FreeBSD__) || defined (__DragonFly__)
-+ root_dir = "%%DATADIR%%/scripts";
-+#elif defined (__APPLE__)
- char buf[PATH_MAX];
- uint32_t size = sizeof (buf);
- _NSGetExecutablePath(buf, &size);
diff --git a/math/yacas/pkg-descr b/math/yacas/pkg-descr
index 4685a4fc77ea..4659f70f34fd 100644
--- a/math/yacas/pkg-descr
+++ b/math/yacas/pkg-descr
@@ -7,4 +7,4 @@ arbitrary precision arithmetic (although it can optionally be linked with
the library "libgmp3") and is able to execute symbolic manipulations on
various mathematical objects by following user-defined rules.
-WWW: http://yacas.sourceforge.net/
+WWW: http://www.yacas.org/
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index 0d9a799238c2..970e3d14d85e 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -1,10 +1,10 @@
bin/yacas
-bin/ytxt2tex
include/yacas/GPL_stuff.h
include/yacas/anumber.h
include/yacas/anumber.inl
include/yacas/arggetter.h
include/yacas/arrayclass.h
+include/yacas/associationclass.h
include/yacas/choices.h
include/yacas/commandline.h
include/yacas/core_yacasmain.h
@@ -17,7 +17,6 @@ include/yacas/genericobject.h
include/yacas/genericstructs.h
include/yacas/infixparser.h
include/yacas/lispatom.h
-include/yacas/lispcleanupstack.h
include/yacas/lispenvironment.h
include/yacas/lisperror.h
include/yacas/lispeval.h
@@ -45,11 +44,17 @@ include/yacas/standard.h
include/yacas/standard.inl
include/yacas/stdcommandline.h
include/yacas/stdfileio.h
+include/yacas/string_utils.h
include/yacas/stringio.h
include/yacas/stubs.h
include/yacas/substitute.h
include/yacas/tokenizer.h
include/yacas/unixcommandline.h
+include/yacas/utf8.h
+include/yacas/utf8/checked.h
+include/yacas/utf8/core.h
+include/yacas/utf8/unchecked.h
+include/yacas/win32commandline.h
include/yacas/xmltokenizer.h
include/yacas/yacas.h
include/yacas/yacas_version.h
@@ -57,12 +62,8 @@ include/yacas/yacasbase.h
include/yacas/yacasprivate.h
lib/libyacas.a
lib/libyacas.so
-lib/libyacas.so.1
lib/libyacas.so.1.0.0
-%%DATADIR%%/documentation/hints
-%%DATADIR%%/manmake/book2TeX.sh
-%%DATADIR%%/manmake/book2TeX.ys
-%%DATADIR%%/manmake/txt2yacasdoc.pl
+%%DATADIR%%/scripts/Makefile.am
%%DATADIR%%/scripts/array.rep/code.ys
%%DATADIR%%/scripts/array.rep/code.ys.def
%%DATADIR%%/scripts/assoc.rep/code.ys
@@ -81,7 +82,6 @@ lib/libyacas.so.1.0.0
%%DATADIR%%/scripts/constants.rep/om.ys
%%DATADIR%%/scripts/controlflow.rep/code.ys
%%DATADIR%%/scripts/controlflow.rep/code.ys.def
-%%DATADIR%%/scripts/corefunctions.ys
%%DATADIR%%/scripts/debug.rep/code.ys
%%DATADIR%%/scripts/debug.rep/code.ys.def
%%DATADIR%%/scripts/deffunc.rep/code.ys
@@ -136,6 +136,7 @@ lib/libyacas.so.1.0.0
%%DATADIR%%/scripts/logic.rep/code.ys
%%DATADIR%%/scripts/logic.rep/code.ys.def
%%DATADIR%%/scripts/logic.rep/om.ys
+%%DATADIR%%/scripts/maketest
%%DATADIR%%/scripts/multivar.rep/code.ys
%%DATADIR%%/scripts/multivar.rep/code.ys.def
%%DATADIR%%/scripts/multivar.rep/makemulti.ys
@@ -144,6 +145,8 @@ lib/libyacas.so.1.0.0
%%DATADIR%%/scripts/multivar.rep/sparsetree.ys.def
%%DATADIR%%/scripts/newly.rep/code.ys
%%DATADIR%%/scripts/newly.rep/code.ys.def
+%%DATADIR%%/scripts/nintegrate.rep/code.ys
+%%DATADIR%%/scripts/nintegrate.rep/code.ys.def
%%DATADIR%%/scripts/numbers.rep/GaussianIntegers.ys
%%DATADIR%%/scripts/numbers.rep/GaussianIntegers.ys.def
%%DATADIR%%/scripts/numbers.rep/NumberTheory.ys
@@ -184,6 +187,8 @@ lib/libyacas.so.1.0.0
%%DATADIR%%/scripts/radsimp.rep/code.ys.def
%%DATADIR%%/scripts/random.rep/code.ys
%%DATADIR%%/scripts/random.rep/code.ys.def
+%%DATADIR%%/scripts/rational.rep/code.ys
+%%DATADIR%%/scripts/rational.rep/code.ys.def
%%DATADIR%%/scripts/simplify.rep/code.ys
%%DATADIR%%/scripts/simplify.rep/code.ys.def
%%DATADIR%%/scripts/simplify.rep/factorial.ys